Inventor Engineer-to-Order

Inventor Engineer-to-Order

Reply
Active Contributor
scottheide
Posts: 32
Registered: ‎01-17-2012
Message 1 of 7 (290 Views)

BOMStructure = :reference part disappears

290 Views, 6 Replies
07-27-2012 07:03 AM

We have some geometry that should show up in the drawing, but not the Parts List.   Setting BOMStructure = :reference removes it successfully from the parts list, but it also removes it from the drawing graphics.   Is there a way to have parts show up in the graphics, but not the parts list?

ScottHeide@CruzBayCustom.com
Active Contributor
scottheide
Posts: 32
Registered: ‎01-17-2012
Message 2 of 7 (281 Views)

Re: BOMStructure = :reference part disappears

07-30-2012 04:52 PM in reply to: scottheide

Anyone have any ideas on this? 

ScottHeide@CruzBayCustom.com
Board Manager
Jon.Balgley
Posts: 251
Registered: ‎08-23-2006
Message 3 of 7 (279 Views)

Re: BOMStructure = :reference part disappears

07-30-2012 05:02 PM in reply to: scottheide

I believe :smileytongue:hantom is what you want, but it didn't work for me when I tried it just now.  

 

Search for "bom structure" in the Inventor documentation for an explanation.



Jon Balgley
Autodesk Configurator 360 / Inventor ETO team
Autodesk, Inc.
Board Manager
Jon.Balgley
Posts: 251
Registered: ‎08-23-2006
Message 4 of 7 (278 Views)

Re: BOMStructure = :reference part disappears

07-30-2012 05:02 PM in reply to: Jon.Balgley

That's p-h-a-n-t-o-m.

 

Stupid smileys.



Jon Balgley
Autodesk Configurator 360 / Inventor ETO team
Autodesk, Inc.
Active Contributor
scottheide
Posts: 32
Registered: ‎01-17-2012
Message 5 of 7 (276 Views)

Re: BOMStructure = :reference part disappears

07-30-2012 06:44 PM in reply to: Jon.Balgley

Thanks and it seems you are on to something, but I couldn't get it to work either.  According to the docs it seems like :smileytongue:hantom is the right thing.

 

http://wikihelp.autodesk.com/Inventor/enu/2012/Help/0073-Autodesk73/0460-Assembli460/0530-Bills_of53...

 

If I just try to set the BOMStructure manually for the Inventor part in the Inventor UI, it only gives two choices {:smileyvery-happy:efault, :Reference}.    I don't see any way to manually set it to Phantom. 

 

Also, it isn't clear from the ETO docs why there is both a BOMStructure (with options of :smileyvery-happy:efault and :Reference) and a DefaultBOMStructure (with options of :Normal, :Inseparable :smileytongue:urchased :smileytongue:hantom :Reference)

 

I tried all the combinations I could think of for BOMStructure and DefaultBOMStructure in ETO to see if i could get it to work... but no luck.

 

Any help is appreciated!

 

Thanks,


Scott

ScottHeide@CruzBayCustom.com
Employee
MjDeck
Posts: 959
Registered: ‎02-24-2009
Message 6 of 7 (205 Views)

Re: BOMStructure = :reference part disappears

08-23-2012 07:59 AM in reply to: scottheide

Scott,

  This is Inventor behavior. You have to set the document itself to Phantom.  As a component in an assembly, you can only set it to Default or Reference.  The other settings are considered to be properties of the document itself, and not of a particular instance. 



Mike Deck
Software Developer
DLS - Mechanical Design
Autodesk, Inc.

Contributor
DryMartini79
Posts: 14
Registered: ‎04-15-2011
Message 7 of 7 (154 Views)

Re: BOMStructure = :reference part disappears

09-20-2012 07:10 AM in reply to: scottheide

Believe you already solved it....

 

If you set it to reference in the BOM, it will be shown as a dotted line on your drawing but disappear in the BOM.

 

If you set it to Phantom it will disappear in the BOM but show as normal on the drawing.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.