Inventor Engineer-to-Order

Inventor Engineer-to-Order

Reply
Distinguished Contributor
ludesroc
Posts: 172
Registered: ‎05-03-2005
Message 1 of 9 (260 Views)

Assembly Document Template

260 Views, 8 Replies
02-04-2013 10:58 AM

Hi,

 

When creating a child as :IvAssemblyDocument...Which template ETO uses? 

 

It says: If not supplied, uses system default. Is system default the location specified in Application Options/File/Default Templates or somewhere else?

 

Regards,

 

 

Ludesroc
Employee
AlexKorzun
Posts: 113
Registered: ‎11-10-2008
Message 2 of 9 (252 Views)

Re: Assembly Document Template

02-04-2013 12:03 PM in reply to: ludesroc

Hi,

 

The Manage\Projects... command brings in the Inventor Projects dialog box, where you can specify the path to templates for the active project:

 

IPJ.jpg

 

In case of [Default] (as shown), the templates are searched in the global folder you've figured out.

Thank you,



Alex Korzun
Autodesk Configurator 360 / Inventor ETO team
Autodesk, Inc.

Distinguished Contributor
ludesroc
Posts: 172
Registered: ‎05-03-2005
Message 3 of 9 (226 Views)

Re: Assembly Document Template

02-05-2013 09:26 AM in reply to: AlexKorzun

Alex,

 

Project Templates is set at: Default

Applicaton Options/File/Default Templates location is set at: W:\Mecanique\CAD\Librairies\Inventor 2013\Templates\

 

I modified the templates (Inventor/ETO) so that the UCS is orientated as shown in (Default_View_Orientation.bmp)

When creating a child (design RoofCurbWall is an AssemblyDocument) without specifying the templateFile...When I open the Assembly Document, the view (UCS) is rotated 180 deg about Z. If I specify the templateFile then the view is ok.

Child RoofCurbWallFront As (If createFrontWall? Then :RoofCurbWall Else :nullDesign)
roofcurbWallLength = RoofCurbLength
roofcurbWallLeftHeight = FrontLeftCornerHeight
roofcurbWallRightHeight = FrontRightCornerHeight
roofcurbWallSide = "Front"
ignorePosition? = False
origin = Point(0, RoofCurbWallThickness + clearanceBetweenParts + OuterSkinMaterialThickness, 0)
xDirection = Vector(1, 0, 0)
yDirection = Vector(0, 1, 0)
grounded? = True

templateFile = "W:\Mecanique\CAD\Librairies\Inventor 2013\Templates\Inventor\Standard.iam"
End Child

This of course affects the drawing views orientation!!!

 

Regards,

 

Ludesroc
Employee
AlexKorzun
Posts: 113
Registered: ‎11-10-2008
Message 4 of 9 (212 Views)

Re: Assembly Document Template

02-05-2013 09:54 AM in reply to: ludesroc

Hi

 

May I ask you a question? What is the Model on the drawing view:

  • Root?
  • Root.....RoofCurbWallFront?
  • anything else in between?

 

Thank you,



Alex Korzun
Autodesk Configurator 360 / Inventor ETO team
Autodesk, Inc.

Distinguished Contributor
ludesroc
Posts: 172
Registered: ‎05-03-2005
Message 5 of 9 (208 Views)

Re: Assembly Document Template

02-05-2013 10:07 AM in reply to: AlexKorzun

What is shown in (Without_TemplateFile.bmp) is RoofCurbWallFront.iam. 

 

See (Intent Model.bmp)

 

 

Ludesroc
Distinguished Contributor
ludesroc
Posts: 172
Registered: ‎05-03-2005
Message 6 of 9 (180 Views)

Re: Assembly Document Template

02-07-2013 09:13 AM in reply to: ludesroc

I have tons of design created earlier with this UCS orientation and everything was working just fine until now...Now in 2013,  assemblies (created within ETO) are behaving strangely...in some designs they are well orientated and in others they are all over the place!!!! 

 

If creating a child as an ivAssemblyDocument uses the template specified in the default location and that template is configured as described earlier, then could you tell me why it would not generate the correct view orientation ALL THE TIME? Is there an internal/hidden rule calling for a different template?

 

My collegue has mentionned a problem with assembly document units changing from inch to centimeter -->(http://forums.autodesk.com/t5/Autodesk-Inventor-Engineer-to/Sub-Assemblies-change-their-Document-Set... I also have this problem!

 

I strongly suspect a different template being called...

 

This isssue is becoming annoying as I can't get the proper design to generate!!!!!

 

 

Ludesroc
Mentor
Lesoux
Posts: 172
Registered: ‎03-12-2012
Message 7 of 9 (171 Views)

Re: Assembly Document Template

02-07-2013 09:58 AM in reply to: ludesroc

You are not alone. I have a lot issues after installing 2013 R2 too.

Win7 x64
Xeon X5647
24 Gb RAM
Quadro FX 6000

Inventor 2013
ETO 6.1, Build 140.
Employee
AlexKorzun
Posts: 113
Registered: ‎11-10-2008
Message 8 of 9 (168 Views)

Re: Assembly Document Template

02-07-2013 10:04 AM in reply to: ludesroc

Hi

 

We are investigating the issue. We have the reproducible case. You will be informed about the outcomes. Please file ADN case and mention DE955 defect.

 

Because of the issue, the drawing view could be rendered differently depending on whether it is created from scratch or is updated in existing document. If you save/close your Intent assembly, delete "Member Files" folder, set the ViewCube options to default, and open your assembly again: will the views be shown as desired?

 

 

Thank you,



Alex Korzun
Autodesk Configurator 360 / Inventor ETO team
Autodesk, Inc.

Distinguished Contributor
ludesroc
Posts: 172
Registered: ‎05-03-2005
Message 9 of 9 (161 Views)

Re: Assembly Document Template

02-07-2013 10:30 AM in reply to: AlexKorzun

Alex,

 

I filed a case.

No it is not!

 

I'm not even creating drawing views...still within the assembly document.

 

In the attached document...PentaFrontLeft and PentaFrontRight are well orientated. PentaFrontTop and PentaFrontBottom are not (they should be rotated 90 deg about Y)...but they used to be!

 

The child rule hasn't changed. I'm using frame-based positioning.

 

Ludesroc
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.