Inventor Customization

Inventor Customization

Reply
Valued Contributor
lornemartin
Posts: 90
Registered: ‎02-17-2011
Message 11 of 18 (515 Views)

Re: 2013 Inventor Viewer ActiveX appears to be broken same as 2012 Viewer

06-02-2012 02:18 PM in reply to: Gruff

Have you gotten to the bottom of this yet? I too am having problems with some Apprentice code. I developed it last year using 2012, now we upgraded to 2013, and it doesnt' work anymore. See here and here. Sounds like our problems might be somewhat related.

Valued Mentor
Gruff
Posts: 431
Registered: ‎11-24-2003
Message 12 of 18 (499 Views)

Re: 2013 Inventor Viewer ActiveX appears to be broken same as 2012 Viewer

06-05-2012 11:01 AM in reply to: lornemartin

Autodesk is reportedly working on a fix for the Inventor 2013 Viewer control.  According to Autodesk It appears  to be a problem with their compiled control not with how we are trying to use it.

 

I know nothing about the apprentice.dll other than the Viewer control makes use of it. 

 

Did you turn in a bug report with examples?

 

Valued Contributor
lornemartin
Posts: 90
Registered: ‎02-17-2011
Message 13 of 18 (494 Views)

Re: 2013 Inventor Viewer ActiveX appears to be broken same as 2012 Viewer

06-05-2012 01:16 PM in reply to: Gruff

I submitted a bug report yesterday. It's the first time I've submitted one to Autodesk support. I haven't heard back yet. Does it normally take them over a day to reply?

 

Did they give you a timeframe for their fix?

Valued Mentor
Gruff
Posts: 431
Registered: ‎11-24-2003
Message 14 of 18 (491 Views)

Re: 2013 Inventor Viewer ActiveX appears to be broken same as 2012 Viewer

06-05-2012 01:59 PM in reply to: lornemartin

I've never gotten much in the way of feedback from bug reporting.  Though I can tell you the more samples / examples you can give that absolutely re-creates the issue is necessary for them to sit up and take notice.

 

My problem was not always repeatable.  Eventually I found out it was only occuring on 2011  Sheetmetal Parts, Assemblies, and Drawings.  Standard parts worked fine.  Others would test with 2013 solid parts and they would not get an error. 

 

You might try to get your VAR to make arrangements for someone at autodesk development to contact you by email.

New Member
mecheng
Posts: 2
Registered: ‎04-02-2012
Message 15 of 18 (412 Views)

Re: 2013 Inventor Viewer ActiveX appears to be broken same as 2012 Viewer

10-12-2012 06:54 AM in reply to: lornemartin

I have had a similar problem but with embedding the viewer into Excel and office products. I am running 64 bit Windows 7, Inventor 2013, and Office 2010, I have registered the InventorViewCtrl.ocx via regsvr32 and it stated the install was successful however Excel dose not see the Inventor View Control via the Object->Insert function within excel. It seems to me that, From researching the issue, the control does create a registry entry but it almost as if it places it in the wrong place and Excel can not read link to it.

ADN Support Specialist
xiaodong.liang
Posts: 1,274
Registered: ‎06-12-2011
Message 16 of 18 (387 Views)

Re: 2013 Inventor Viewer ActiveX appears to be broken same as 2012 Viewer

10-30-2012 07:21 PM in reply to: mecheng

Hi,

 

For all who are having issues with Inventor view control 2013, please try with   Inventor View 2013 Service Pack 1.1 if it helps.

http://usa.autodesk.com/adsk/servlet/pc/item?siteID=123112&id=20462274

 

Replying the question of message 15 from mecheng

 I have not an idea if Inventor View Control can also support [Create Object]. But the control appears in OLE server correctly. Of course, on 64bits, you will need to register the version in C:\Program Files\Autodesk\Inventor 2013\Bin\Bin32\InventorViewCtrl.ocx instead of C:\Program Files\Autodesk\Inventor 2013\Bin\InventorViewCtrl.ocx,  



Xiaodong Liang
Developer Technical Services
Autodesk Developer Network

Active Member
Ranajit
Posts: 9
Registered: ‎07-16-2012
Message 17 of 18 (320 Views)

Re: 2013 Inventor Viewer ActiveX appears to be broken same as 2012 Viewer

04-21-2013 11:43 PM in reply to: xiaodong.liang

Hi,

Please help me to solve this problem http://forums.autodesk.com/t5/Autodesk-Inventor-Customization/Fail-to-load-InventorviewCtrl-ocx-2013... .
Thanks in advance.

Ranajit.

New Member
Attestwitness
Posts: 1
Registered: ‎06-22-2014
Message 18 of 18 (53 Views)

Re: 2013 Inventor Viewer ActiveX appears to be broken same as 2012 Viewer

06-22-2014 08:39 PM in reply to: Gruff

Using ActiveX barcode control to generate barcode in vb .net 3.5 code 3 of 9

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.