Installation & Licensing

Installation & Licensing

Distinguished Contributor
150 Posts
2 Kudos
Registered: ‎08-15-2007
Post 1 of 6

SCCM 2007 & AutoCAD 2012 Deploy Fails

2224 Views, 5 Replies
08-19-2011 07:23 AM

Hey All-  

I have a support case open with Autodesk, but I suspect the problem is really in the SCCM end (Server 2008).  I'm hoping one of you has more experience with this than I do.


I'm working with a school to deploy thier Autocad, Acad-A, Revit A and Revit S 2012 via SCCM.  The Revits and ACAD-A install fine but vanilla Autocad fails. I've rebuilt the deployment several times - and the deplyment runs fine when SCCM is out of the picture.


We are following the directions from here:  to the letter.  


Some other bits of information - they are using Deep Freeze on the student workstations but thier SCCM thaws the workstations and installs with admin rights. (Like I mentioned before, other ADSK products install ok...wierd, right?)


All of the workstations are brand new Win7 64 bit machines.  


I've attached the verbose install log in case one of you can make heads or tails of it.  The regular, non-verbose install log fails at the direct X stage with error 1602.  Direct X is already installed from the other products and I removed that bit from the adminimage.ini.  1602 is usally permissions - but we are full admin.  


Uh oh - this is getting too wordy.  If you can help I would be super-duper grateful.  Thanks. -Lou


Product Support
1,458 Posts
52 Kudos
Registered: ‎05-21-2010
Post 2 of 6

Re: SCCM 2007 & AutoCAD 2012 Deploy Fails

08-22-2011 12:35 AM in reply to: lholland

If you assume it is directx which is failing.

You could try to edit the setup.ini/deploymentname.ini file to disable directx installation

this would be in the line "PREREQUISITE=" within the ACAD section.


Please let me know if you need detailed explanation on how to disable directx installation using the ini file




If my post answers your question, please mark it as an Accepted Solution, so that others can find answers quickly!
For more tips & tricks:

Hashim Mundol
Autodesk Product Support
Autodesk, Inc.

5 Posts
0 Kudos
Registered: ‎12-09-2010
Post 3 of 6

Re: SCCM 2007 & AutoCAD 2012 Deploy Fails

11-06-2011 04:14 PM in reply to: hashim.mundol

Hey Lou,


Did you get to the bottom of this at all?  I am having the exact same problem.


Running the installation manually works fine, but running from SCCM the setup.exe process appears in the task manager for about 2 seconds and then fails!




New Member
1 Posts
0 Kudos
Registered: ‎02-08-2012
Post 4 of 6

Re: SCCM 2007 & AutoCAD 2012 Deploy Fails

02-13-2013 03:19 PM in reply to: lholland

Angus, I realize this over a year old but I'm seeing the exact same thing as you are. Did you ever get to the bottom of it? Setup.exe doesn't even run long enough for any logs to be generated.

New Member
2 Posts
0 Kudos
Registered: ‎06-28-2013
Post 5 of 6

Re: SCCM 2007 & AutoCAD 2012 Deploy Fails

09-04-2014 02:02 AM in reply to: mikeh

Hi All


Sorry for the late reply, but does anyopne know the solution to this instant fail issue?


Thanks in advance

New Member
2 Posts
0 Kudos
Registered: ‎06-28-2013
Post 6 of 6

Re: SCCM 2007 & AutoCAD 2012 Deploy Fails

09-05-2014 03:14 AM in reply to: alex.weaver

So, for anyone else finding this post and getting the same issue i found the solution in my case was to recreate the deployment with an ini file without spaces.


It seems that the way sccm deploys Autocad products either do not like spaces in the ini files or do not like the quotes you have to put the ini file location in. 

It also seems that the root directory needs to be chosen, not the admin or Img folder. So for me to get SketchBook Pro 2015 to work i used the following command


Img\Setup.exe /W /Q /I Img\Sketchbook2015.ini /language en-us


anything with spaces or quotes like the following failed immediatly:


"Img\Setup.exe" /W /Q /I "Img\Sketchbook 2015.ini" /language en-us


or anything with the source directory set to the location of the ini and setup files:


Setup.exe /W /Q /I Sketchbook2015.ini /language en-us


Hope this may be of some help to others in the same situation

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post