Installation & Licensing

Installation & Licensing

Reply
smb
Member
smb
Posts: 4
Registered: ‎10-18-2012
Message 1 of 12 (1,843 Views)

"Do you want to allow incoming network connections" appears on every Maya launch

1843 Views, 11 Replies
10-19-2012 02:11 PM

I have been running Maya 2013 for several months now with no issues. Yesterday I upgraded to the 2013.5 extension. Now every time I launch the program an OS alert pops up to ask me if I want the application to accept incoming network connections.

 

I use OS X 10.7.5 and the firewall is enabled. Maya is set to allow incoming network connections in the advanced firewall settings. At most this prompt should appear only the first time I launch the application.

 

Internet searches turned up several references to this problem. Apparently it's related to the integrity of the application file; if it isn't correctly signed or if some components are corrupt or missing, the OS responds with this prompt.

 

In terminal I ran this command:

 

% codesign -v --verbose /Applications/Autodesk/maya2013.5/Maya.app

 

and got this response:

 

Maya.app: a sealed resource is missing or invalid
In architecture: x86_64
resource added: /Applications/Autodesk/maya2013.5/Maya.app/Contents/Resources/ja_JP.lproj/plug-ins/fbxmaya.pres.mel
resource added: /Applications/Autodesk/maya2013.5/Maya.app/Contents/Resources/zh_CN.lproj/plug-ins/fbxmaya.pres.mel

I'm no developer, though, so I don't understand what this means or how it should be fixed. The recommended fix is to uninstall and then reinstall the application. I've done that but the problem persists. 

 

If anyone has any suggestions I'm all ears. This is really annoying.

 

SB

 

Product Support
david.lau
Posts: 1,475
Registered: ‎06-18-2008
Message 2 of 12 (1,793 Views)

Re: "Do you want to allow incoming network connections" appears on eve

10-23-2012 06:10 AM in reply to: smb

Can you just try to add the application as an exception?



David Lau
smb
Member
smb
Posts: 4
Registered: ‎10-18-2012
Message 3 of 12 (1,783 Views)

Re: "Do you want to allow incoming network connections" appears on eve

10-23-2012 07:29 AM in reply to: david.lau

David,

 

Thank you for your reply. I've manually added Maya.app to the list of applications in the Firewall Options panel -- is that what you mean? It makes no difference, because Maya is already listed there and has been cleared to accept all incoming network connections. Despite this the prompt still appears every time I launch the app.

 

I took a look inside the application Contents folder and found that the two files flagged by codesign have earlier modification dates than anything else (August 24 vs. Sept. 14). Again, I'm not sure what this means, but apparently the system has found something in the installation that it doesn't like and responds by sending me this prompt.

 

I'll be moving one of my installations of Maya to a new machine in a few days, so we'll see if it's the app or something with my OS.

 

Steve

 

 

Product Support
david.lau
Posts: 1,475
Registered: ‎06-18-2008
Message 4 of 12 (1,778 Views)

Re: "Do you want to allow incoming network connections" appears on eve

10-23-2012 07:41 AM in reply to: smb

I will test out an install myself of Maya 2013 Extension and check the Firewall settings too. 



David Lau
Product Support
david.lau
Posts: 1,475
Registered: ‎06-18-2008
Message 5 of 12 (1,769 Views)

Re: "Do you want to allow incoming network connections" appears on eve

10-23-2012 10:18 AM in reply to: david.lau

I just tested this in Maya 2013.5 and with the the Firewall on and with the exception for Maya, it will still come up with the  dialog box to allow/deny in the Firewall settings.  I think you are correct that there appears to be a problem with the behaviour.



David Lau
smb
Member
smb
Posts: 4
Registered: ‎10-18-2012
Message 6 of 12 (1,764 Views)

Re: "Do you want to allow incoming network connections" appears on eve

10-23-2012 10:56 AM in reply to: david.lau

David,

 

Thank you for following up -- good to know that you've been able to duplicate it.

 

 

Steve

 

Product Support
david.lau
Posts: 1,475
Registered: ‎06-18-2008
Message 7 of 12 (1,759 Views)

Re: "Do you want to allow incoming network connections" appears on eve

10-23-2012 11:35 AM in reply to: smb

I have reported the issue to development to resolve.  I hope it's easy.  This is another one that we had on Windows (more of an FYI) with Maya 2013 Extension:

 

http://upandready.typepad.com/up_and_ready/2012/09/maya-2013-extension-deployment-error-the-copy-fun...

 

Also check out posts categories by Mac...you may find some of the interesting.

 

http://upandready.typepad.com/up_and_ready/mac/



David Lau
Active Member
pixonti
Posts: 7
Registered: ‎04-22-2011
Message 8 of 12 (1,509 Views)

Re: "Do you want to allow incoming network connections" appears on eve

02-07-2013 02:39 PM in reply to: smb

I noticed this thread was listed as "solved" but I am having this issue constantly. I have searched for a solution when I discovered this, but there didn't seemed to be any real solution. Is this still in progress?

smb
Member
smb
Posts: 4
Registered: ‎10-18-2012
Message 9 of 12 (1,500 Views)

Re: "Do you want to allow incoming network connections" appears on eve

02-07-2013 03:33 PM in reply to: pixonti

No, no solution yet. Hopefully it's a simple thing to correct and on someone's to-do list for Maya 2014. 

 

Steve

 

Product Support
david.lau
Posts: 1,475
Registered: ‎06-18-2008
Message 10 of 12 (1,481 Views)

Re: "Do you want to allow incoming network connections" appears on eve

02-12-2013 10:20 AM in reply to: smb

It is indeed on someone's 2013 to-do list.   :smileyhappy:



David Lau
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are You Going To Be @ AU 2014? Feel free to drop by our AU topic post and share your plans, plug a class that you're teaching, or simply check out who else from the community might be in attendance. Ohh and don't forgot to stop by the Autodesk Help | Learn | Collaborate booths in the Exhibit Hall and meet our community team if you get a chance!