Installation & Licensing

Installation & Licensing

Reply
Distinguished Contributor
MayaWannabe
Posts: 157
Registered: ‎09-29-2010
Message 1 of 21 (9,052 Views)
Accepted Solution

New install of 2012 Entertainment Creation Suite - missing LiteHtml.dll?

9052 Views, 20 Replies
07-09-2011 10:00 AM
I have AD 2011 Entertainment suite installed on Win7-64. I'm trying to install the 64 bit AD 2012 Entertainment suite. I ran Setup.exe from the outer level of the DVD and got this message: Setup.exe System Error The program can't start because LiteHtml.dll is missing from your computer. Try reinstalling the program to fix this problem.

Yes, those files are in the setup folder, but the install does NOT know to look there.

I got it to install by copying all the files from the DVD to the hard drive, and copying many of the dlls from the setup and 'english' folders to the outer layer where the install exe was located.

But, WHY is this happening?

I just experienced the same problem with AutoCAD 2013 but fortunately I know exactly what I did to cause it.

 

There is an idiot feature that can be implemented by system administrators that causes the DLL Load Path to ignore "dlls in the current directory".

 

If you enable this, you get the complaint about LiteHtml.dll.

If you disable it, you don't.

 

This is a .REG file to clear out the problem, but your system admin will probably hate you loading it.

 

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]
"CWDIllegalInDllSearch"=dword:00000000

 

If you want to experience the problem, change the value to dword:FFFFFFFF

 

Anyone from Autodesk who is listening needs to research the SetDllDirectory() function on MSDN and call it appropriately from inside their installer.

Try checking C:\Windows\SysWOW64 for the litehtml.dll - if there is a copy there, move or rename it & try the install again.  I ran into this issue when installing AutoCAD 2013.  After moving the litehtml file, I got an error with another dll.  It was in the same SysWOW64 folder and had the same date as the litehtml.  I ended up moving all files that matched that date out of the SysWOW64 folder.  After doing that, I was able to successful install the product.

*Expert Elite*
TravisNave
Posts: 10,588
Registered: ‎01-14-2005
Message 2 of 21 (9,039 Views)

Re: New install of 2012 Entertainment Creation Suite - missing LiteHtml.dll?

07-11-2011 07:14 AM in reply to: MayaWannabe

Strange, it should be on your computer if you already have Autodesk products installed.  Typically this file is in the setup folder.  Perhaps your 2012 files are corrupt.  Based on the fact that you already have 2011 products, I doubt it is an SSE2 issue. 

 

Distinguished Contributor
MayaWannabe
Posts: 157
Registered: ‎09-29-2010
Message 3 of 21 (9,032 Views)

Re: New install of 2012 Entertainment Creation Suite - missing LiteHtml.dll?

07-11-2011 09:48 AM in reply to: TravisNave

Yes, those files are in the setup folder, but the install does NOT know to look there.

I got it to install by copying all the files from the DVD to the hard drive, and copying many of the dlls from the setup and 'english' folders to the outer layer where the install exe was located.

But, WHY is this happening?

*Expert Elite*
TravisNave
Posts: 10,588
Registered: ‎01-14-2005
Message 4 of 21 (9,029 Views)

Re: New install of 2012 Entertainment Creation Suite - missing LiteHtml.dll?

07-11-2011 10:03 AM in reply to: MayaWannabe

Ours is not to reason why...  :smileyvery-happy:

 

It seems quite common that copying the media to the HDD has always been a good way to resolve strange installation errors.  Thanks for posting your work-around as it may be helpful to someone down the road. 

Distinguished Contributor
MayaWannabe
Posts: 157
Registered: ‎09-29-2010
Message 5 of 21 (9,024 Views)

Re: New install of 2012 Entertainment Creation Suite - missing LiteHtml.dll?

07-11-2011 10:38 AM in reply to: TravisNave

Hey, we're all in this together, right?

 

But - are replies in this forum from Autodesk - or from kind souls who are helping out?

 

I guess I'd expected a response more along the lines of "we'll have to fix that!" from Autodesk?

 

Thanks!

*Expert Elite*
TravisNave
Posts: 10,588
Registered: ‎01-14-2005
Message 6 of 21 (9,022 Views)

Re: New install of 2012 Entertainment Creation Suite - missing LiteHtml.dll?

07-11-2011 10:58 AM in reply to: MayaWannabe

This is mostly a user forum of peers helping peers.  Autodesk does review the boards though and pitch in when they can or need to.  Their involvement has gotten a lot better as of late. 

New Member
jeff.laing
Posts: 2
Registered: ‎03-29-2012
Message 7 of 21 (8,791 Views)

Re: New install of 2012 Entertainment Creation Suite - missing LiteHtml.dll?

03-29-2012 06:09 PM in reply to: MayaWannabe

I just experienced the same problem with AutoCAD 2013 but fortunately I know exactly what I did to cause it.

 

There is an idiot feature that can be implemented by system administrators that causes the DLL Load Path to ignore "dlls in the current directory".

 

If you enable this, you get the complaint about LiteHtml.dll.

If you disable it, you don't.

 

This is a .REG file to clear out the problem, but your system admin will probably hate you loading it.

 

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]
"CWDIllegalInDllSearch"=dword:00000000

 

If you want to experience the problem, change the value to dword:FFFFFFFF

 

Anyone from Autodesk who is listening needs to research the SetDllDirectory() function on MSDN and call it appropriately from inside their installer.

Member
jfrost5
Posts: 4
Registered: ‎08-12-2011
Message 8 of 21 (8,613 Views)

Re: New install of 2012 Entertainment Creation Suite - missing LiteHtml.dll?

07-12-2012 07:29 AM in reply to: MayaWannabe

Try checking C:\Windows\SysWOW64 for the litehtml.dll - if there is a copy there, move or rename it & try the install again.  I ran into this issue when installing AutoCAD 2013.  After moving the litehtml file, I got an error with another dll.  It was in the same SysWOW64 folder and had the same date as the litehtml.  I ended up moving all files that matched that date out of the SysWOW64 folder.  After doing that, I was able to successful install the product.

Distinguished Contributor
MayaWannabe
Posts: 157
Registered: ‎09-29-2010
Message 9 of 21 (8,602 Views)

Re: New install of 2012 Entertainment Creation Suite - missing LiteHtml.dll?

07-14-2012 09:40 PM in reply to: jfrost5
No, there's no litehtml.dll in sysWow64. It exists in other folders such as 3dsMax2012/setup/setup - and probably only after I 'fixed' the problem as mentioned earlier. The truth is, AD doesn't know how to write an install program, as I still have errors with 3ds whenever I open it, such as: LINK 0.0 error 191007: cannot load .\shaders_standard\mentalray\shaders/base.dll, The specified module could not be found. LINK 0.0 error 191012: Unable to load file: base.dll LINK 0.0 error 191007: cannot load .\shaders_standard\mentalray\shaders/contour.dll, The specified module could not be found. LINK 0.0 error 191012: Unable to load file: contour.dll LINK 0.0 error 191007: cannot load .\shaders_standard\mentalray\shaders/physics.dll, The specified module could not be found. LINK 0.0 error 191012: Unable to load file: physics.dll etc. etc. etc. I guess the install program coders from nVidia found a new place to work!!! And the only 'support' on the phone is some guy confined to his house who 'googles' to try to find an answer. They just pay him to annoy people enough to stop trying to get support. Rather shoddy for a company that charges so much.
New Member
abrumathew007
Posts: 1
Registered: ‎01-24-2013
Message 10 of 21 (8,235 Views)

Re: New install of 2012 Entertainment Creation Suite - missing LiteHtml.dll?

01-24-2013 10:25 PM in reply to: TravisNave

Hi Travis,

I am getting system error:Litehtml.ddl missing from your machine for AUTOCAD2013 when i try to install the trial version silently.could you please tell me a workaround for this.I have this file along with my package.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are You Going To Be @ AU 2014? Feel free to drop by our AU topic post and share your plans, plug a class that you're teaching, or simply check out who else from the community might be in attendance. Ohh and don't forgot to stop by the Autodesk Help | Learn | Collaborate booths in the Exhibit Hall and meet our community team if you get a chance!