Installation & Licensing

Installation & Licensing

New Member
Posts: 2
Registered: ‎03-10-2014
Message 1 of 3 (346 Views)
Accepted Solution

Network License Error: adskflex using TCP-port 0, tcp_s is bad!!!

346 Views, 2 Replies
03-10-2014 07:00 PM

Hello Everyone,


I'm trying to get a Network License Server running.  Using XP and the latest license manager version (IPv4 only).  I've already got my license file and the hostname and MAC address match.  I cannot seem to get my server running at all. Here is an excerpt from the log file.  I edited out the keys of  course.


I've already tried reinstalling the license manager and checked to see that no other services are configured in LMTOOLS.  When I watch the Task Manager, I see adskflex.exe start and disappear.  I see 2 instances of lmgrd.exe after starting the service.  The both terminate when I stop the service using LMTOOLS.  I have disabled Windows Firewall and Macafee On-Access Scan.  There are other licensing packages installed on this machine including lservrc and codemeter for other software.


I've tried various solutions on this board like swapping the adskflex.exe to 11.7 to no avail.  Any help would be greatly appreciated!


15:35:47 (lmgrd) pid 2720
15:35:47 (lmgrd) Detecting other license server manager (lmgrd) processes...
15:35:47 (lmgrd) Done rereading
15:35:47 (lmgrd) FlexNet Licensing (v11.11.0.0 build 106800 i86_n3) started on CEELABCOMP (IBM PC) (3/10/2014)
15:35:47 (lmgrd) Copyright (c) 1988-2012 Flexera Software LLC. All Rights Reserved.
15:35:47 (lmgrd) World Wide Web:
15:35:47 (lmgrd) License file(s): C:\Program Files\Autodesk Network License Manager\394-14595167.lic
15:35:47 (lmgrd) lmgrd tcp-port 27000
15:35:47 (lmgrd) Starting vendor daemons ...
15:35:47 (lmgrd) Starting vendor daemon at port 2080
15:35:47 (lmgrd) Using vendor daemon port 2080 specified in license file
15:35:47 (lmgrd) Started adskflex (pid 3064)
15:35:47 (adskflex) Unable to initialize access to trusted storage: 1
15:35:47 (adskflex) FlexNet Licensing version v11.11.0.0 build 106800 i86_n3
15:35:48 (adskflex) Server started on CEELABCOMP for:    
15:35:48 (adskflex) EXTERNAL FILTERS are OFF
15:35:48 (lmgrd) adskflex using TCP-port 0
15:35:48 (adskflex) tcp_s is bad!!! Exiting
15:35:48 (adskflex) EXITING DUE TO SIGNAL 28 Exit reason 5
15:35:53 (lmgrd) adskflex exited with status 28 (Communications error)
15:35:53 (lmgrd) Since this is an unknown status, license server
15:35:53 (lmgrd) manager (lmgrd) will attempt to re-start the vendor daemon.

Product Support
Posts: 247
Registered: ‎03-25-2010
Message 2 of 3 (332 Views)

Re: Network License Error: adskflex using TCP-port 0, tcp_s is bad!!!

03-10-2014 07:43 PM in reply to: MitchPin

Hi MitchPin,


Welcome to Autodesk Forum Community.

The issue could be attributed to other application service using Port 2080, conflicting with the vendor daemon. If you are unable to change the application port use, then you can explore changing that on FLEXNET license.



Thank you.

Aaron Hai
New Member
Posts: 2
Registered: ‎03-10-2014
Message 3 of 3 (319 Views)

Re: Network License Error: adskflex using TCP-port 0, tcp_s is bad!!!

03-10-2014 09:49 PM in reply to: aaronhai

Right on target Aaron!  I scanned which ports were listening using the tips found here:

I used the netstat –ano ¦find /i “listening” command and using the PID, I looked in taskmanager (after adding the PID column) and found it was a file called monitor.exe which was using port 2080.  It came from an old Simulia Abaqus license installation.  Anyway, I deleted all my registry entries pertaining to monitor.exe and that cured it.  It runs just fine now.  Hopefully it stays running and I don't have the problem of it crashing a few days later like some.

Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.