Installation & Licensing

Installation & Licensing

Reply
Employee
alison.gangler
Posts: 125
Registered: ‎04-12-2010
Message 11 of 43 (913 Views)

Re: Missing Assemblies on Tool Palette after network deployment of Civil 3D 2013

09-20-2012 09:47 AM in reply to: justforthispost

Hi,

 

Thanks for confirming that the .cab files exist. In this case, the next step to determine the cause of the behavior is to examine the permissions which could possible be blocking the cabs from unpacking.

 

What is the OS of the system where the deployment AdminImage is hosted? Please verify that the account used to launch the install of the deployment has full Admin permissions, especially in the location of the deployment and across the OS of the server.

 

Also, you can elevate the Windows Installer policy by adding the following registry key on the client workstation and the server:

 

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Installer]
"AlwaysInstallElevated"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
"AlwaysInstallElevated"=dword:00000001
 
There is additional information about this Windows Installer policy at:
http://msdn.microsoft.com/en-us/library/aa367561(v=vs.85).aspx

Microsoft recommends that the policy be set back to "0" upon completion of the install maintenance.

 

If you would prefer not to set this policy, please make sure that the UAC, User Account Control Settings are set to the lowest level so that the install sequences are not blocked by the security.

 

Please let me know if any of these suggestions help.

 

Cheers,

Alison

___________________________________________________________

If my post answers your question, please click the "Accept as Solution" button. This helps everyone find answers more quickly!



Alison Gangler
IPG - ICP Install Engineer
Autodesk, Inc.

Active Contributor
justforthispost
Posts: 37
Registered: ‎02-23-2011
Message 12 of 43 (888 Views)

Re: Missing Assemblies on Tool Palette after network deployment of Civil 3D 2013

09-24-2012 12:31 AM in reply to: alison.gangler

As this installation is being done by group policy's the SYSTEM account is being used to install the application. This account has all the appropiate rights on the file locations and hasn't been "restricted" with UAC. It's not possible to login on a machine with this account as its a builtin Windows account. The deployment Adminimage is hosted on a Windows Server 2003 R2 x64 machine.

 

So for now I'm sorry to report that these suggestions don't help. I do not really understand why the installation works correctly when useing the .lnk file. What is the difference between that and assigning the MSI + MST files through GPO?

Active Contributor
justforthispost
Posts: 37
Registered: ‎02-23-2011
Message 13 of 43 (846 Views)

Re: Missing Assemblies on Tool Palette after network deployment of Civil 3D 2013

10-01-2012 11:08 PM in reply to: justforthispost

Any update?

Active Contributor
justforthispost
Posts: 37
Registered: ‎02-23-2011
Message 14 of 43 (819 Views)

Re: Missing Assemblies on Tool Palette after network deployment of Civil 3D 2013

10-08-2012 03:17 AM in reply to: alison.gangler

Hello guys, any update please?

Employee
alison.gangler
Posts: 125
Registered: ‎04-12-2010
Message 15 of 43 (812 Views)

Re: Missing Assemblies on Tool Palette after network deployment of Civil 3D 2013

10-08-2012 08:45 AM in reply to: justforthispost

Hi,

 

Thank you for the update and I'm sorry that the suggestions haven't helped so far. What account is being used to launch the install when you apply through the GPO?

 

Please keep in mind that if the System account is being used, this could cause the behavior you are seeing. In this case, can you try the local Admin account to launch the install? The Content Packs will install to the account user folders for the account used to launch the install.

 

Please let me know if this helps at all.

Cheers,

Alison

___________________________________________________________

If my post answers your question, please click the "Accept as Solution" button. This helps everyone find answers more quickly!



Alison Gangler
IPG - ICP Install Engineer
Autodesk, Inc.

Active Contributor
justforthispost
Posts: 37
Registered: ‎02-23-2011
Message 16 of 43 (779 Views)

Re: Missing Assemblies on Tool Palette after network deployment of Civil 3D 2013

10-11-2012 02:01 AM in reply to: alison.gangler

Thanks for your reply.

 

Can you please tell me how to set up my group policy so it will be run by a different account?

 

 

Thanks

Active Contributor
justforthispost
Posts: 37
Registered: ‎02-23-2011
Message 17 of 43 (743 Views)

Re: Missing Assemblies on Tool Palette after network deployment of Civil 3D 2013

10-23-2012 05:20 AM in reply to: justforthispost

Anyone?

Mentor
ceethreedee.com
Posts: 192
Registered: ‎10-04-2012
Message 18 of 43 (684 Views)

Re: Missing Assemblies on Tool Palette after network deployment of Civil 3D 2013

11-11-2012 08:55 PM in reply to: justforthispost

Resolution for this?

 

Did anyone have one. We have the smae problem here!

 

Regards

 

Brad

Civil 3D 2014 (SP2)
Win 7 Pro x64 -DELL Precision Workstation T3500
Intel Xeon 3.3GHz (w3680) -24Gb Ram
NVIDIA Quadro 2000 (1GB)
ceethreedee.com
Mentor
ceethreedee.com
Posts: 192
Registered: ‎10-04-2012
Message 19 of 43 (683 Views)

Re: Missing Assemblies on Tool Palette after network deployment of Civil 3D 2013

11-11-2012 08:58 PM in reply to: ceethreedee.com

From Cp log, there are heaps more where they came from though

 

!=> Failed to resolve Content\en\C3D_Imperial_Base\Profile.cab
!=> Failed to resolve Content\en\C3D_Metric_Base\Profile.cab
!=> Failed to resolve Content\en\C3D_ImageAssets\ImageAssets.cab
!=> Failed to resolve Content\en\C3D_ImageAssets\VideoTooltips.cab
!=> Failed to resolve Content\en\C3D_Profiles\ToolPalettes.cab
!=> Failed to resolve Content\en\C3D_Profiles\ToolCatalogs.cab
!=> Failed to resolve Content\en\C3D_Profiles\HHExpress.cab
!=> Failed to resolve Content\en\C3D_Profiles\HHHydrographs.cab
!=> Failed to resolve Content\en\C3D_Profiles\HHStormSewers.cab
!=> Failed to resolve Content\en\C3D_RoadCatalogs\Road_Catalogs.cab
!=> Failed to resolve Content\en\C3D_VizCatalogs\visualization.cab
!=> Failed to resolve Content\en\C3D_VizCatalogs\WS_Cat_Imperial.cab
!=> Failed to resolve Content\en\C3D_PPipesCat\PressurePipesCat.cab
!=> Failed to resolve Content\en\C3D_PPipesCat\PressurePipesConfig.cab
!=> Failed to resolve Content\en\C3D_PPipesCat\PartPublishingWizard.cab
!=> Failed to resolve Content\en\C3DCK_ANZ\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_ANZ\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_ANZ\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_ANZ\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_ANZ\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Austria\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_Austria\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_Austria\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_Austria\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_Austria\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Belgium\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_Belgium\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_Belgium\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_Belgium\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Belgium\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_Brazil\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_Brazil\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_Brazil\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_Brazil\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Brazil\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_Denmark\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_Denmark\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_Denmark\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_Denmark\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Denmark\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_Germany\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_Germany\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_Germany\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_Germany\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Germany\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_India\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_India\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_India\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_India\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_India\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_Italy\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_Italy\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_Italy\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_Italy\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Italy\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_Mexico\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_Mexico\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_Mexico\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_Mexico\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_Mexico\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Netherlands\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_Netherlands\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_Netherlands\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_Netherlands\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Netherlands\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_Norway\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_Norway\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_Norway\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_Norway\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Norway\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_Romania\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_Romania\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_Romania\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_Romania\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Romania\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_SouthAfrica\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_SouthAfrica\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_SouthAfrica\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_SouthAfrica\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Spain\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_Spain\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_Spain\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_Spain\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_Spain\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Sweden\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_Sweden\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_Sweden\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_Sweden\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Sweden\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_Switzerland\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_Switzerland\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_Switzerland\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_Switzerland\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_Switzerland\InstallDir.cab
!=> Failed to resolve Content\en\C3DCK_UKIE\AllUsers.cab
!=> Failed to resolve Content\en\C3DCK_UKIE\PerUser.cab
!=> Failed to resolve Content\en\C3DCK_UKIE\PerUser_Local.cab
!=> Failed to resolve Content\en\C3DCK_UKIE\DataDir.cab
!=> Failed to resolve Content\en\C3DCK_UKIE\InstallDir.cab

Civil 3D 2014 (SP2)
Win 7 Pro x64 -DELL Precision Workstation T3500
Intel Xeon 3.3GHz (w3680) -24Gb Ram
NVIDIA Quadro 2000 (1GB)
ceethreedee.com
Active Contributor
justforthispost
Posts: 37
Registered: ‎02-23-2011
Message 20 of 43 (670 Views)

Re: Missing Assemblies on Tool Palette after network deployment of Civil 3D 2013

11-13-2012 04:15 AM in reply to: alison.gangler

We are still having this problem, so no resolution as yet.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are You Going To Be @ AU 2014? Feel free to drop by our AU topic post and share your plans, plug a class that you're teaching, or simply check out who else from the community might be in attendance. Ohh and don't forgot to stop by the Autodesk Help | Learn | Collaborate booths in the Exhibit Hall and meet our community team if you get a chance!