Installation & Licensing

Installation & Licensing

Reply
Valued Contributor
jneal
Posts: 75
Registered: ‎11-14-2011
Message 1 of 36 (10,978 Views)
Accepted Solution

FLEXnet Licensing errors

10978 Views, 35 Replies
06-07-2013 09:03 AM

Greetings all-

I have searched and read multiple threads and can't seem to find an answer for my problems. Here goes:

 

NLM has been running fine for months since the update for 2014 software.

3 days ago NLM is down so I go check it.

"Winsock" errors, multiple -16,287  -15,10 -97,121 etc. errors... 

I reboot the server and it works fine for a day or so

When it goes down I cannot click on the "System Settings" tab. It is blank and locks up LMGRD.exe and I have to end the process.

 

Any ideas?

 

Here's the latest from my log file. I see that it says multiple lmgrd.exe's running but I'm not sure i understand why that is happening-

-------------------------------------------------------------------------------------------------



3:04:07 (lmgrd) TIMESTAMP 6/7/2013
9:04:07 (lmgrd) TIMESTAMP 6/7/2013
9:57:55 (lmgrd) adskflex exited with status 1 signal = 332
9:57:55 (lmgrd) Since this is an unknown status, license server
9:57:55 (lmgrd) manager (lmgrd) will attempt to re-start the vendor daemon.
9:57:55 (lmgrd) Starting vendor daemon at port 2080
9:57:55 (lmgrd) Using vendor daemon port 2080 specified in license file
9:57:55 (lmgrd) REStarted adskflex (pid 5200)

9:58:11 (lmgrd)
9:58:11 (lmgrd) pid 5856
9:58:11 (lmgrd) Done rereading
9:58:11 (lmgrd) FLEXnet Licensing (v11.7.0.0 build 73797 x64_n6) started on master (IBM PC) (6/7/2013)
9:58:11 (lmgrd) Copyright (c) 1988-2009 Acresso Software Inc. All Rights Reserved.
9:58:11 (lmgrd) US Patents 5,390,297 and 5,671,412.
9:58:11 (lmgrd) World Wide Web: http://www.acresso.com
9:58:11 (lmgrd) License file(s): C:\allcadnw\IT\License Manager\master.lic
9:58:11 (lmgrd) lmgrd tcp-port 27000
9:58:11 (lmgrd) Starting vendor daemons ...
9:58:11 (lmgrd) Starting vendor daemon at port 2080
9:58:11 (lmgrd) Using vendor daemon port 2080 specified in license file
9:58:11 (lmgrd) Started adskflex (pid 5072)
9:58:11 (adskflex) Unable to initialize access to trusted storage: 1
9:58:11 (adskflex) FLEXnet Licensing version v11.7.0.1 build 79971 x64_n6
9:58:11 (adskflex) EXITING DUE TO SIGNAL 32 Exit reason 9
9:58:13 (lmgrd) adskflex exited with status 32 (Exited because another server was running)
9:58:13 (lmgrd) MULTIPLE "adskflex" license server systems running.
9:58:13 (lmgrd) Using Task Manager, stop adskflex and run lmreread
9:58:13 (lmgrd)
9:58:13 (lmgrd) This error probably results from:
9:58:13 (lmgrd) 1. Another copy of the license server manager (lmgrd) is running.
9:58:13 (lmgrd) 2. Another copy of the vendor daemon is running.
9:58:13 (lmgrd) 3. The locking mechanism(s) were removed by an
9:58:13 (lmgrd) outside program.
9:58:13 (lmgrd)
9:58:13 (lmgrd) Rereading license file... Requested from Administrator@master
9:58:13 (lmgrd) Starting vendor daemon at port 2080
9:58:13 (lmgrd) Using vendor daemon port 2080 specified in license file
9:58:13 (lmgrd) Reread: Started adskflex (pid 1192) 9:58:13 (lmgrd) Done rereading
9:58:13 (lmgrd) ...Finished rereading
9:58:13 (adskflex) Unable to initialize access to trusted storage: 1
9:58:13 (adskflex) FLEXnet Licensing version v11.7.0.1 build 79971 x64_n6
9:58:13 (adskflex) EXITING DUE TO SIGNAL 32 Exit reason 9
9:58:15 (lmgrd) adskflex exited with status 32 (Exited because another server was running)
9:58:15 (lmgrd) MULTIPLE "adskflex" license server systems running.
9:58:15 (lmgrd) Using Task Manager, stop adskflex and run lmreread
9:58:15 (lmgrd)
9:58:15 (lmgrd) This error probably results from:
9:58:15 (lmgrd) 1. Another copy of the license server manager (lmgrd) is running.
9:58:15 (lmgrd) 2. Another copy of the vendor daemon is running.
9:58:15 (lmgrd) 3. The locking mechanism(s) were removed by an
9:58:15 (lmgrd) outside program.
9:58:15 (lmgrd)

10:00:42 (lmgrd) Forced shutdown requested
10:00:43 (lmgrd) SHUTDOWN request from Administrator at node master
10:00:43 (lmgrd) lmgrd will now shut down all the vendor daemons

10:00:43 (lmgrd) EXITING DUE TO SIGNAL 15
10:00:46 (lmgrd) -----------------------------------------------

10:00:46 (lmgrd) pid 1168
10:00:46 (lmgrd) Done rereading
10:00:46 (lmgrd) FLEXnet Licensing (v11.7.0.0 build 73797 x64_n6) started on master (IBM PC) (6/7/2013)
10:00:46 (lmgrd) Copyright (c) 1988-2009 Acresso Software Inc. All Rights Reserved.
10:00:46 (lmgrd) US Patents 5,390,297 and 5,671,412.
10:00:46 (lmgrd) World Wide Web: http://www.acresso.com
10:00:46 (lmgrd) License file(s): C:\allcadnw\IT\License Manager\master.lic
10:00:46 (lmgrd) lmgrd tcp-port 27000
10:00:46 (lmgrd) Starting vendor daemons ...
10:00:46 (lmgrd) Starting vendor daemon at port 2080
10:00:46 (lmgrd) Using vendor daemon port 2080 specified in license file
10:00:46 (lmgrd) Started adskflex (pid 2312)
10:00:46 (adskflex) Unable to initialize access to trusted storage: 1
10:00:46 (adskflex) FLEXnet Licensing version v11.7.0.1 build 79971 x64_n6
10:00:46 (adskflex) EXITING DUE TO SIGNAL 32 Exit reason 9
10:00:49 (lmgrd) adskflex exited with status 32 (Exited because another server was running)
10:00:49 (lmgrd) MULTIPLE "adskflex" license server systems running.
10:00:49 (lmgrd) Using Task Manager, stop adskflex and run lmreread
10:00:49 (lmgrd)
10:00:49 (lmgrd) This error probably results from:
10:00:49 (lmgrd) 1. Another copy of the license server manager (lmgrd) is running.
10:00:49 (lmgrd) 2. Another copy of the vendor daemon is running.
10:00:49 (lmgrd) 3. The locking mechanism(s) were removed by an
10:00:49 (lmgrd) outside program.
10:00:49 (lmgrd)
10:00:49 (lmgrd) Rereading license file... Requested from Administrator@master
10:00:49 (lmgrd) Starting vendor daemon at port 2080
10:00:49 (lmgrd) Using vendor daemon port 2080 specified in license file
10:00:49 (lmgrd) Reread: Started adskflex (pid 6040)10:00:49 (lmgrd) Done rereading
10:00:49 (lmgrd) ...Finished rereading
10:00:49 (adskflex) Unable to initialize access to trusted storage: 1
10:00:49 (adskflex) FLEXnet Licensing version v11.7.0.1 build 79971 x64_n6
10:00:49 (adskflex) EXITING DUE TO SIGNAL 32 Exit reason 9
10:00:54 (lmgrd) adskflex exited with status 32 (Exited because another server was running)
10:00:54 (lmgrd) MULTIPLE "adskflex" license server systems running.
10:00:54 (lmgrd) Using Task Manager, stop adskflex and run lmreread
10:00:54 (lmgrd)
10:00:54 (lmgrd) This error probably results from:
10:00:54 (lmgrd) 1. Another copy of the license server manager (lmgrd) is running.
10:00:54 (lmgrd) 2. Another copy of the vendor daemon is running.
10:00:54 (lmgrd) 3. The locking mechanism(s) were removed by an
10:00:54 (lmgrd) outside program.
10:00:54 (lmgrd)

---------------------------------------------------------------------------------------------------------

 

Any ideas?

 

Thanks

Jess

 

 

Application Engineer
All CAD Northwest
Meridian ID

does the license file info match to what the license manager see as far as mac address and server name?

can you try disabling the firewall or allow these ports through?

TCP ports 2080 (for the adskflex vendor daemon)
TCP ports 27000 to 27009 (for the lmgrd master daemon)

*Expert Elite*
TravisNave
Posts: 10,736
Registered: ‎01-14-2005
Message 2 of 36 (10,954 Views)

Re: FLEXnet Licensing errors

06-10-2013 07:58 AM in reply to: jneal

Yes, it appears it is in conflict with another vendor service running.

 

9:58:13 (lmgrd) adskflex exited with status 32 (Exited because another server was running)
9:58:13 (lmgrd) MULTIPLE "adskflex" license server systems running.

 What you need to do is stop the server and then make sure you kill any remaining lmgrd.exe and adskflex.exe processes in Task Manager.  Then restart the service.

 

Make sure you are only running one service for Autodesk licenses and you don't have more than one Autodesk license file configured.  If you do, then you need to see my Combining LIC Files link in my signature. 

Mentor
Darin.Green
Posts: 179
Registered: ‎05-18-2008
Message 3 of 36 (10,949 Views)

Re: FLEXnet Licensing errors

06-10-2013 09:56 AM in reply to: TravisNave

I think Travis is correct, you may need to combine the licenses into one. Aside from that, since you're running licenses for version 2014, I recommend updating the license manager to 11.11 which can be found here:

 

License Manager: IPv6 Supported

http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=10976858&linkID=9240618

 

License Manager: IPv6 not supported

http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=16273699&linkID=9240618

 

 

Darin Green
Synergis Technologies

If this resolve your issue/question, give Kudos or Accept as Solution...
Valued Contributor
jneal
Posts: 75
Registered: ‎11-14-2011
Message 4 of 36 (10,943 Views)

Re: FLEXnet Licensing errors

06-10-2013 10:19 AM in reply to: Darin.Green


TravisNave wrote:

Yes, it appears it is in conflict with another vendor service running.

 What you need to do is stop the server and then make sure you kill any remaining lmgrd.exe and adskflex.exe processes in Task Manager.  Then restart the service.

 

Make sure you are only running one service for Autodesk licenses and you don't have more than one Autodesk license file configured.  If you do, then you need to see my Combining LIC Files link in my signature. 


Travis - Thanks for the reply. I went and looked in the containing folder and there was another license file that was an old one that had not been renamed yet. Just to clarify.. even if I am pointing to a specific license file i cannot have any other/old license files in the same folder?

Darin.Green wrote:

I think Travis is correct, you may need to combine the licenses into one. Aside from that, since you're running licenses for version 2014, I recommend updating the license manager to 11.11 which can be found here:

 

License Manager: IPv6 Supported

http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=10976858&linkID=9240618

 

License Manager: IPv6 not supported

http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=16273699&linkID=9240618

 

 


I read in one of Travis's posts that MS Server 2008 R2 has issues with 11.11. Thats why I'm running 11.7. If thats not the case I will revert back to the latest version...

 

 Thanks Guys

Jess

 

Application Engineer
All CAD Northwest
Meridian ID
Mentor
Darin.Green
Posts: 179
Registered: ‎05-18-2008
Message 5 of 36 (10,938 Views)

Re: FLEXnet Licensing errors

06-10-2013 10:24 AM in reply to: jneal

Good to hear its resolved. Please mark Travis response as the solution for others.

Darin Green
Synergis Technologies

If this resolve your issue/question, give Kudos or Accept as Solution...
*Expert Elite*
TravisNave
Posts: 10,736
Registered: ‎01-14-2005
Message 6 of 36 (10,931 Views)

Re: FLEXnet Licensing errors

06-10-2013 11:01 AM in reply to: jneal

 


I read in one of Travis' posts that MS Server 2008 R2 has issues with 11.11. Thats why I'm running 11.7. If thats not the case I will revert back to the latest version...

 

 Thanks Guys

Jess

 


Yeah, I would almost certainly stick to 11.7 until your issue is resolved.  Then you can try the newer version to see if it works. 

*Expert Elite*
TravisNave
Posts: 10,736
Registered: ‎01-14-2005
Message 7 of 36 (10,930 Views)

Re: FLEXnet Licensing errors

06-10-2013 11:03 AM in reply to: jneal

 


Travis - Thanks for the reply. I went and looked in the containing folder and there was another license file that was an old one that had not been renamed yet. Just to clarify.. even if I am pointing to a specific license file i cannot have any other/old license files in the same folder?

 



As for this, you simply need to make sure there isn't more than one service listed in the pulldown of config services.  You can have old LIC files.  That's no big deal.  You just wanna run one service for the Autodesk stuff and make sure that only one adskflex.exe is running when started. 

Valued Contributor
jneal
Posts: 75
Registered: ‎11-14-2011
Message 8 of 36 (10,925 Views)

Re: FLEXnet Licensing errors

06-10-2013 11:32 AM in reply to: TravisNave

It's not resoved yet. I'm still getting errors. Here's the chain of events i just went through:

 

  1. rebooted server on Friday. Server status = good
  2. go check on NLM this morning after reading some replies here
  3. Server Status = FLEXnet Licensing error:-15,10.  System Error: 10061 "WinSock: Connection refused"
  4. Open LMTools. Check to see only 1 service is configured. See attached
  5. open Task Manager. End all associated processes (adskflex.exe, lmgrd.exe and lmtools)
  6. Start LMTools, go to Start/Stop/Reread tab
  7. Force stop server. 
  8. Check task manager. Nothing running. 
  9. Hit Start Server...
  10. (2) lmgrd.exe's appear along with an adskflex.exe

What is going on? If there is only 1 service configured there should only be 1 lmgrd.exe running if I'm not mistaken...

 

 

Application Engineer
All CAD Northwest
Meridian ID
*Expert Elite*
TravisNave
Posts: 10,736
Registered: ‎01-14-2005
Message 9 of 36 (10,915 Views)

Re: FLEXnet Licensing errors

06-10-2013 11:46 AM in reply to: jneal

No, everything you described and have shown is correct.  What error remains?

Valued Contributor
jneal
Posts: 75
Registered: ‎11-14-2011
Message 10 of 36 (10,913 Views)

Re: FLEXnet Licensing errors

06-10-2013 11:51 AM in reply to: TravisNave

Here's a copy/paste from a server status:


--------
Status
--------
Flexible License Manager status on Mon 6/10/2013 13:02

[Detecting lmgrd processes...]
License server status: 27000@master
License file(s) on master: C:\allcadnw\IT\License Manager\master.lic:

lmgrd is not running: Cannot connect to license server system.
The license server manager (lmgrd) has not been started yet,
the wrong port@host or license file is being used, or the
port or hostname in the license file has been changed.
Server name: 192.168.10.50
License path: 27000@master;
FLEXnet Licensing error:-15,10. System Error: 10061 "WinSock: Connection refused"
For further information, refer to the FLEXnet Licensing documentation,
available at "www.acresso.com".



See attached. It says lmgrd.exe is not running and there are two running currently. If i end task on one, they both dissapear. *edit* i just ended one and only one went away this time. Still a winsock error*edit*

 

Do you need to see the log file or anything else?

 

I really appreicate your help Travis-

Application Engineer
All CAD Northwest
Meridian ID
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.