Installation & Licensing

Installation & Licensing

Reply
Valued Contributor
sakkaku
Posts: 51
Registered: ‎01-03-2007
Message 1 of 8 (7,560 Views)

Error 1053 when starting service

7560 Views, 7 Replies
06-12-2009 08:13 AM
When I attempt to start the license manager as a service it immediately pops up with:

"Windows could not start the service on local computer.
Error 1053: The service did not respond to the start or control request in a timely fashion."


If I tick off the "Use Services" check box under the "Config Services" tab in LMTOOLS then I can start it via the "Start/Stop/Restart" tab. I have spent several hours perusing google to find a solution (most of which seem to go hand in hand with IIS), but none seem to be related to the license manager.

Anyone know a solution?
Valued Contributor
sakkaku
Posts: 51
Registered: ‎01-03-2007
Message 2 of 8 (7,560 Views)

Re: Error 1053 when starting service

06-12-2009 09:44 AM in reply to: sakkaku
I found a solution that seems to be working.

The executable shipped with the product are 32bit while I was using a 64bit OS (Server 2008). Doing a little research I found that flexlm/flexnet was bought out by Acresso Software. From there I was able to locate an up to date version of Flexlm that was 64bit via http://www.globes.com/support/fnp_utilities_download.htm

Replace the executables except for the autodesk daemon (adskflex), set the configuration and it should start right up.
Member
gparent
Posts: 4
Registered: ‎07-05-2010
Message 3 of 8 (7,530 Views)

Re: Error 1053 when starting service

07-07-2010 09:04 AM in reply to: sakkaku

Hi,

 

I'm having the same issue, I've installed FlexLM on a Windows 2003 (SP1 32bits), it runs fine in "manual" mode, with LMtools running with a user loggued in,  but I am unable to install it as a service using LMTools (Use Services checkbox under the "Config Services" tab.

 

If I try to start the server as a service it give the generic error:

Server Start Failed. The Server May Already Be Running!! (it isn't)

 

If I try to ReRead License File it gices the error:

Reread Server Failed.

 

It does create the service in windows, but trying to start the service gives an error

"Could not start the service name service on Local Computer" Error 193: 0xc1

 

Any help, suggestions??

 

Marc

Member
gparent
Posts: 4
Registered: ‎07-05-2010
Message 4 of 8 (7,529 Views)

Re: Error 1053 when starting service

07-07-2010 09:12 AM in reply to: gparent

Forgot to mention, I've also installed the latest FlexLM version, the one from Acresso.

*Expert Elite*
TravisNave
Posts: 10,588
Registered: ‎01-14-2005
Message 5 of 8 (7,526 Views)

Re: Error 1053 when starting service

07-07-2010 09:20 AM in reply to: gparent

The latest version now at the time of this post is 11.8 and is provided by Flexera.  You can download the appropriate 32-bit version for your Server 2003 here:

 

http://www.globes.com/support/fnp_utilities_downlo ad.htm

I would recommend the following steps:

 

1.  Open LMTOOLS

2.  Stop the service from Stop/Start/Reread, making sure the Force Server Shutdown box is checked.

3.  Remove the service from the Config Services tab. 

4.  Recreate the service (default name is Flexlm Service 1) pointing to all the correct files.  Create a new debug.log file if an old one already exists.  Check both boxes at the bottom and save the service.

5.  Start the service from the Stop/Start/Reread tab.

 

I also highly recommend adding all four NLM .exe files to the Data Execution Prevention (DEP) exception list found under the WIndows System Properties > Advanced tab > Performance settings > Data Execution Prevention tab. 

 

If you still have problems, please let me know. 

Member
gparent
Posts: 4
Registered: ‎07-05-2010
Message 6 of 8 (7,523 Views)

Re: Error 1053 when starting service

07-07-2010 09:33 AM in reply to: sakkaku

Hi,

 

Hadn't thought of DEP!

 

I've updated to Flexera and made the changes to DEP.

 

Unfortunatly DEP requires a reboot and the server is used by that department for some other purpose, so I can only reboot it off hours.

 

I'll keep you posted, thank you for the fast reply!

 

Marc

Member
gparent
Posts: 4
Registered: ‎07-05-2010
Message 7 of 8 (7,500 Views)

Re: Error 1053 when starting service

07-08-2010 07:00 AM in reply to: gparent

I found the culprit... the service wouldn't start because there are spaces in the path...

(ie: D:\Program Files\AutoCAD License Manager\...)

 

Here's the fix:

 

To resolve this issue, add quotation marks around the following entry in the Windows registry, where <ServiceName> is the name of the service:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<ServiceName>\ImagePath

The ImagePath entry contains the path of the executable file for the service. To add quotation marks around the ImagePath entry for a service:

  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate, and then click the following registry entry, where <ServiceName> is the name of the service:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<ServiceName>.
    For example, if the service is named MyService, locate the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MyService key.
  4. In the right pane, double-click ImagePath.
  5. In the Value data box, add quotation marks around the complete path of the executable file for the service.

    For example, if the path of the MyService service is C:\Program Files\MyProgram\MyService.exe, change the entry in the Value data box for the MyService service to the following
    "C:\Program Files\MyProgram\MyService.exe"
  6. Click OK, and then quit Registry Editor.

Thanks for your help!

 

Marc

*Expert Elite*
TravisNave
Posts: 10,588
Registered: ‎01-14-2005
Message 8 of 8 (7,497 Views)

Re: Error 1053 when starting service

07-08-2010 07:08 AM in reply to: gparent

Very good find and thanks for sharing that information.  It's strange that sometimes spaces will still break programs even though they work for 99% of everyone else. 

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post