Installation & Licensing

Installation & Licensing

Posts: 24
Registered: ‎09-14-2012
Message 31 of 58 (8,187 Views)

Re: Error 0xc000007b while starting AutoCad 2013

12-19-2012 03:12 AM in reply to: charles1017

Hi Bujans,


I have read through your reply, I believe you are right because when i search the web before, people are all saying that some dll are running incorrectly. and i believe so but i just dont know how to check whats being called when starting up a program. and wow, i learn new things to solve system problem from here.

im gonna give it a try right the way! (though i gave up already and have 2012 installed+using coz its like a dead end before :smileytongue: )



something ends up wrong while installing 2013, maybe i need to uninstall the 2012 and install 2013

but uninstall cause a LOT of trouble and im working on a project so im not going to do that now.

anyway i think your method will work!!!

THANKS for all those work!!!




New Member
Posts: 1
Registered: ‎01-16-2013
Message 32 of 58 (7,955 Views)

Re: Error 0xc000007b while starting AutoCad 2013

01-16-2013 07:23 AM in reply to: charles1017

I'm getting the same problem and I tried some of the solutions you offered but none of them worked.  Also, it will not allow me to uninstall the program.  No idea what to do next...

New Member
Posts: 1
Registered: ‎01-16-2013
Message 33 of 58 (7,951 Views)

Re: Error 0xc000007b while starting AutoCad 2013

01-16-2013 02:10 PM in reply to: charles1017

I get this same error. HELP!!!!

Posts: 24
Registered: ‎09-14-2012
Message 34 of 58 (7,936 Views)

Re: Error 0xc000007b while starting AutoCad 2013

01-17-2013 04:52 AM in reply to: charles1017

You may use ADSUninstallTool.exe inside

to uninstall AutoCAD2013.

Posts: 5
Registered: ‎01-13-2013
Message 35 of 58 (7,831 Views)

Re: Error 0xc000007b while starting AutoCad 2013

01-27-2013 05:19 AM in reply to: charles1017
New Member
Posts: 1
Registered: ‎12-05-2012
Message 36 of 58 (7,818 Views)

Re: Error 0xc000007b while starting AutoCad 2013

01-27-2013 01:25 PM in reply to: charles1017



I've got the same problem on my Windows 7 x64 PC.  It's a DELL OEM OS version if that makes a difference.


I've tried all of the suggestions around the net that I can find and have reloaded the OS once as well.  I've tried:


Reload OS

Clear TMP, stop AV, Firewall and any other programs from running - still errors

Update directx runtimes

Uninstall all C++ runtimes and only install x64 versions


I'm out of ideas.  Is there anything else I can try?




Posts: 3
Registered: ‎11-28-2012
Message 37 of 58 (7,797 Views)

Re: Error 0xc000007b while starting AutoCad 2013

01-27-2013 08:55 PM in reply to: ellie.mullard

Hi Ellie and others,...


Since this problem mostly in Windows 7, 64 bit system, and the Error message code is : 0xc000007b ; First, you must know if this problem with the same error message may happened in other aplication too, i.e : Adobe, MS Office, Solidworks,  etc.  If you check to MIcrosoft support online, this error code mean "incompatibility file that should be run in 64 bit system". This message inform you that you have one or more files (mostly in *.DLL) 32 bit system but worked as 64 bit system in your machine. Some applications may work well, but other will cause error like Error message above.


Maybe some peoples get solving just only re-install or update their DirectX runtime files, but the other still have no solving the problem. In my case, all troubleshoots or suggestions from Internet and Autodesk discussion Groups, no one work !!  Until I found this way and it solving my problem very well. :smileyhappy:  


It is important to knows what exactly files (*.DLL) that caused the problem in your machine. If you aren't an experienced IT with C++ runtime files, you can find to solving the problem with free utility : "Dependency Walker". Dependency Walker is a free utility that scans any 32-bit or 64-bit Windows module (exe, dll, ocx, sys, etc.) and builds a hierarchical tree diagram of all dependent modules. It is also very useful for troubleshooting system errors related to loading and executing modules. Dependency Walker detects many common application problems such as missing modules, invalid modules, mismatched machine types of modules, and module initialization failures like Error message 0xc000007b when you click AutoCAD.exe.


You can download this free utility from : . Please download only match with your OS. Install it to your Hard drive system.


If your problem always shows up everytime you open AutoCAD.exe (or other vertical Autodesk products), try to check any dependencies file  (mostly in *.DLL) for AutoCAD.exe using this utility (Dependency Walker). 


Below is the steps to use Dependency Walker (DW) to solving your problem : 


1. Run Dependency Walker utility, and then click File > Open > choose ACAD.exe (from the path you installed AutoCAD 2013).  Wait for some seconds, then DW's hierarchical tree diagram will shows up.

capture-DW menu.jpg


2. Check into hierachy diagram, looking into module column which files (mostly in *.DLL format) with Yellow and RED colour. YELLOW is warning if one or more files failed to load, but your application still can working. RED is very important to do, that you must more attention, this files caused the problem with your AutoCAD (or other vertical Autodesk Products).

a 64 or 32 symbols also appeared in front of your module files. If your system is 64 bit, it should be running module for 64 bit too. If you find it is a 32 bit, that is the problem, then you must change this file with 64 bit system version.

Some messages with RED colour in the bottom of menu, will inform you any warnings regarding the runtime module file. Use this information to help you solving the problem !!


3. After you find the RED colour (maybe with 32 bit symbols) of runtime module, what you must to do next is delete these files (please note the location of these files) and change with 64 bit version from your source of Autodesk products (DVD Source). Make sure you have choosed same file from DVD Source (Autodesk products) but for 64 bit system. (refer to x64 folder in your DVD Source). There are maybe more than 2 files with the same name already in your machine, but don't worry, you need copy paste a fresh one from AutoCAD DVD Source. Paste it into where you instaled AutoCAD folder in your machine. (You can check from hierarchy diagram in Dependency Walker, for location of file)


Hopefuly this step can solving your problem

Active Contributor
Posts: 26
Registered: ‎10-18-2007
Message 38 of 58 (7,719 Views)

Re: Error 0xc000007b while starting AutoCad 2013

01-29-2013 01:30 PM in reply to: charles1017

THANKS !!! I too was having the same problems on a new installation. I could not open any Autodesk programs.

I ran the dependancy walker and found that "msvcr100.dll" was not working. I simply copied this file from another computer with a similar setup, and now everything is working.

Active Member
Posts: 6
Registered: ‎02-20-2006
Message 39 of 58 (7,552 Views)

Re: Error 0xc000007b while starting AutoCad 2013

02-08-2013 05:46 AM in reply to: charles1017

It's the curse of 2013,  just like AutoCAD 13

Posts: 15
Registered: ‎04-20-2012
Message 40 of 58 (7,245 Views)

Re: Error 0xc000007b while starting AutoCad 2013

02-28-2013 01:20 PM in reply to: BurjanS

Thank you for figureing this out! This has fixed the error each and every time i've come across it. Thank you for posting!

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.