Installation & Licensing

Installation & Licensing

New Member
Posts: 2
Registered: ‎01-10-2012
Message 1 of 3 (588 Views)

Cannot activate Civil 3D 2012

588 Views, 2 Replies
01-10-2012 11:02 AM

Hello Everyone!


For approximately 1 week I've been having an issue activating Civil 3D 2012.  It should be a network license.  Originally it was not but one of our CAD teammate's straightened it out with the reseller and I was able to get a new license file.


Currently the license server has one for Civil 3D 2010 and it works.  The NLM is running and I can see that.  When the one person left who is using Civil 3D 2010 opens it it's fine. The moral of this short paragraph is that Civ3D 2010 works fine.


When I got the new license file for 2012 I gave them the server name and its MAC address.   I had our admin remove the 2010 license file, replace it with 2012, reread it using the NLM and make sure the server was started.  However Civ3D 2012 could not find the license manager. 

So I uninstalled and reinstalled Civ3D 2012 and when it came time to input my license key I input the serial number and key and they both checked off okay.  Then I selected Network License, single server license and input the server name.  Tried running Civ3D 2012 again but still no luck.  NLM cannot find a license.


By the way, the 2010 license is not in the same directory with 2012.  They are isolated. 


Since 2012 didn't work when it should have I examined both license files.  The first line was different on both of them.  I'm unsure if the admin gave me the incorrect MAC address or if I relayed it incorrectly or where the disconnect was but the MAC address of the 2012 file didn't match that of the 2010. 


If I remember correctly you can change the server name and/or MAC address without any issues.  So I copied the first line of 2010 (the working license file) over the 2012 first line but still no luck.  The error code it gave me was an indicator that th server was not started when in fact it is.  After I made the change the admin still reread the license file without error but I still could not get into Civil 3D.  Same error about the server not started when in fact it was.


Just to cover my bases I uninstalled Civ3D and reinstalled it, no dice.


So now my question is what do I do to get this to work?  Additionally, does anything need to be installed on the server for Civ3D 2012 on a workstation to properly communicate with it?


If you have any questions about my situation feel free to ask.


Thank You

*Expert Elite*
Posts: 10,746
Registered: ‎01-14-2005
Message 2 of 3 (585 Views)

Re: Cannot activate Civil 3D 2012

01-10-2012 11:13 AM in reply to: JT_at_work

Two problems here:


1.  You cannot simply change the MAC address of your LIC file and expect it to work.  You need to get a new LIC from Autodesk that contains the correct hostname and MAC address of your NLM server.  Configure your LMTOOLS with the new LIC file and confirm the license with a Status Enquiry.  To get a new LIC file call Autodesk Activations at 1-800-551-1490 > Option 1 (English) > Option 2 (Network)


2.  You should not run more than one license manager service.  So if you are running 2010 in conjunction with 2012, this will also fail.  If your 2012 is under Subscription, it will automatically allow you to continue using your 2010 network seat.  This is by design. 


For a Quick-Start Guide on configuring the Autodesk License Manager, please see my post for further information:



New Member
Posts: 2
Registered: ‎01-10-2012
Message 3 of 3 (578 Views)

Re: Cannot activate Civil 3D 2012

01-10-2012 12:09 PM in reply to: TravisNave

Awesome!  I'm not sure where I heard you can do that at.  So I did call that number and got a new license file.  Tomorrow morning I will see if the new one works.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.