Installation & Licensing

Installation & Licensing

Reply
Member
kens
Posts: 5
Registered: ‎11-13-2012
Message 1 of 5 (150 Views)

AutoCAD Mechanical 2010, Choosing install is not available.

150 Views, 4 Replies
02-26-2014 06:48 AM

I am trying to [re] install AutoCAD Mechanical 2010. There are no traces of any Autodesk product on my machine. But for some reason, the option to install AutoCAD Mechanical 2010 is gray and unavailable for selection.

 

I have checked the Registry for any/all traces of Autodesk, Autocad, Inventor, Mechanical and I have removed the keys specified on the Autodesk Support page. Yet for some reason, the installation CD still seems to think I have AutoCAD Mechanical 2010 installed on this machine.

 

Obviously somewhere in the Registry there are references that for some reason have no noticeable association with the trade name Autodesk, nor the product Autocad – they apparently have some strange and unknown names of their own, yet they clearly tell the install shield that AutoCAD Mechanical 2010 is already installed. Can someone please help?

 

 

 

Product Support
asburyj
Posts: 530
Registered: ‎08-26-2008
Message 2 of 5 (140 Views)

Re: AutoCAD Mechanical 2010, Choosing install is not available.

02-26-2014 03:51 PM in reply to: kens

If the installer is not letting you perform the re-install because it believes the software is already installed most likely there are registry keys left over from a partial install. Please use the microsoft install cleanup fixit tool at the below link

 

http://support.microsoft.com/mats/Program_Install_and_Uninstall

 

1.) Click the "Run now" Button in the Fix-it box

2.) Accept the License Agreement

3.) Choose the option "Detect Problems and let me select fixes to apply"

4.) Select "Uninstalling"

5.) When the list of installed programs populates, select the one from the list you are unable to Re-install and then click next and yes

6.) When the tool completes There may be remnants left so please delete the directory where the product was installed



Jeffry Asbury
Member
kens
Posts: 5
Registered: ‎11-13-2012
Message 3 of 5 (131 Views)

Re: AutoCAD Mechanical 2010, Choosing install is not available.

02-27-2014 04:21 AM in reply to: asburyj
This was no help. The MicroSoft aplicatin was not even able to see AUtoCAD Mechanical 2010. If choosing "Not Listed", I am then prompted to enter a value....apparently a registry value. Something like {12345-12345-12345-12345}...similar to that. And since I my7self cannot find any traces of the application, then I am unclear as to how I might be expected to provide such information. I did use RegCurePro registry cleaner - it found very few mistakes across the entire PC environment. I instructed to fix thise mistakes it did find. AutoCAD Inventor Suite instakller still thinks that AutoCAD Mechanical 2010 is already installed on this machine - no luck.

KBS
*Expert Elite*
pendean
Posts: 22,513
Registered: ‎11-06-2003
Message 4 of 5 (129 Views)

Re: AutoCAD Mechanical 2010, Choosing install is not available.

02-27-2014 05:04 AM in reply to: kens
If that's what you want to do... REGSEEKER is a 3rd party app you can use to specifically search for and target all Autodesk entries for deletion.
You're just using a generic "cleaner", it only hunts for mistakes and blanks, nothing more, and not relevant for the task at hand.
Dean Saadallah Blog | Facebook | Google+ | Twitter | PINS
Member
kens
Posts: 5
Registered: ‎11-13-2012
Message 5 of 5 (119 Views)

Re: AutoCAD Mechanical 2010, Choosing install is not available.

02-27-2014 07:22 AM in reply to: kens
Using REGSEEKER I have performed the following Registry enter REMOVALS:

HKEY_CURRENT_USER\Software\Autodesk
HKEY_LOCAL_MACHINE\Software\Autodesk
acad
acad.exe
acadm
acadm.exe
autocad
autodesk
autocad inventor suite 2010
autocad mechanical 2010
drafting
inventor
mechanical

Also, I have removed all Registry entries pertaining to adsk and FLEX...licensing entries.

In total, I have removed some 1,600 registry entries directly relating to Autodesk/Autocad in general, and Autocad Mechanical 2010 specifically. And still the installation DVD for AutoCAD Inventor Suite 2010 thinks that AutoCAD Mechanical 2010 is already installed on this machine.

There are no directories, not in Program Files, not in Application Settings, not in Local Settings, not on the main C:\ drive - nowhere...there are no files or directories that contain any AutoCAD or other Autodesk files...at least none that are clearly marked as such. There are no .dll files anywhere that have even a remote relevance or relation to any autocad, acad, acadm, etc... to all visible and recognizable extents, Everything "Autodesk" has been wiped from my machine. Yet...the install wizard insists that "There is a newer version or AutoCAD Mechanical 2010 already installed".

Here is what gets my goat... according to Autodesk OWN WEB SITE....deleting these two registry entries:
HKEY_CURRENT_USER\Software\Autodesk
HKEY_LOCAL_MACHINE\Software\Autodesk
supposedly remove all traces of anything Autodesk from your machine. I can assure you - 100% accurately - that is a falsehood. I do not want to come right out and say "lie" but it is DEFINITELY not a true statement.

Last year, on a different machine, I experienced an identical problem with AutoCAD Electrical 2013. After a power outage, wherein my machine shut down (my employer does not believe in UPS backup apparently), when I rebooted and attempted to continue working on my drawing, AutoCAD Electrical 2013 would not open - it gave me a 2 minute long process of "cannot find .dll file..." and it refused to open. All efforts to uninstall via Control Panel resulted in a variety of .dll error messages as well, so I could not uninstall. So I opened a Tech Support ticket. Over a period of 4 days, the Tech agent instructed me to perform a variety of "jumping through the flaming hoops" procedures...ultimately ending with being told to
outright DELETE all folders..from program files, from Local Settings, from Application Data...on & on...I was instructed to outright delete all those folders - ALL reference to Autodesk (sounding familiar yet?). He then instructed me to remove (those identical) registry keys referenced above. Nothing solved the problem! Finally, while I was awaiting the next Tech Support email with further instructions, I used a [different] third party registry editing application and performed exactly the routine I just performed today..with the same result, which is to say, with zero result. A couple of hours later, the "latest" tech support email arrived and I was instructed to...are you ready for this?...I was instructed to install a third party Registry Editor and... You see where this is going?

Finally - and THIS is the moral to the story...the point I "accused" as being a falsehood.... Finally, after a total of 6 work days (wherein I got NO real work done) the fellow from Tech Support contacted me via telephone. Once the agent called, it was decided that he would take remote possession of my machine. As I watched him cleaning entries from the Registry - the entries he was deleting were nothing in anyway that the 'lay person' would ever have looked at and associated with Autodesk, or any sort of AutoCAD application...they could just have easily been entries related to cereal or pet supplies as to anything as technical as Autodesk.

So along with the almost 2,000 registry entries I have removed, I can absolutely guarantee you that there are at least several hundred other entries that Autodesk never tells you about - and have no kind of nomenclature that the layperson would even have a chance of 'taking a wild guess' about. Autodesk applications take possession of your machine at even deeper levels than Microsoft, and THIS problem is the end result.

By the way - Tech Support is scheduled to call at 10:30 this morning - about 15 minutes from now. And I'm reasonable certain that he will take remote possession of my machine to resolve this matter.

Regards
KBS
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.