Infrastructure Map Server Developer

Infrastructure Map Server Developer

Reply
Valued Contributor
88 Posts
1 Kudo
Registered: ‎04-12-2012
Post 1 of 4

widget not display in the Toolbar

1254 Views, 3 Replies
06-05-2012 09:18 AM

Hi,

 

I try to create a JS, xml file and copy to the right location under fusion/widgets folder; Added the widget into ToobarVertical, but the widget did not show. Probaly something wrong. Anyone can give me some suggetion?

Valued Mentor
284 Posts
24 Kudos
Registered: ‎10-06-2008
Post 2 of 4

Re: widget not display in the Toolbar

06-05-2012 07:16 PM in reply to: swimming123

Did you declare the appropriate widget in your the WidgetSet portion of the Flexible Layout document?

 

- Jackie

Valued Contributor
88 Posts
1 Kudo
Registered: ‎04-12-2012
Post 3 of 4

Re: widget not display in the Toolbar

06-05-2012 07:37 PM in reply to: jackie.ng
I just use the InvokeURL widget (js and xml) and modified it. because I need create a point layer using OpenLayer, then pass the lot/lat value of point to server side and do the query. So I delete the selection part, binded the digitize a point function with the widget. I didn't check the WidgetSet part in ApplicationDefinition file. Is this the right way?
Active Member
9 Posts
0 Kudos
Registered: ‎09-06-2011
Post 4 of 4

Re: widget not display in the Toolbar

07-02-2012 11:29 AM in reply to: swimming123

Hi, i did something similar. I created a widget to invoque js from this i did a http request to server and the server side (C#.net) response the result that i wanted.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post