Infrastructure Map Server General Discussion

Infrastructure Map Server General Discussion

Reply
Active Member
howard.thompson2
Posts: 10
Registered: ‎12-14-2007
Message 1 of 5 (606 Views)

Markup example for Mapserver 2012

606 Views, 4 Replies
10-15-2012 07:12 AM

Good Day All!!! Has anyone tried to use the sharable markup example (I believe it was call gt.zip) that came out a few years ago with Mapserver 2012/2013?? I had downloaded this for use with Mapguide Enterprise 2009 and it worked great for what I was doing, but doesn't seem to work with Mapserver2012. I don't get any error messages, and I'm sure with the change to Mapserver there was some coding changes, but I was hoping someone has had success getting it to work, or using something similar for sharable markups. Thanks!!

Valued Mentor
gluckett
Posts: 426
Registered: ‎10-10-2003
Message 2 of 5 (586 Views)

Re: Markup example for Mapserver 2012

10-17-2012 04:08 AM in reply to: howard.thompson2
Don't forget to make an authoring user in the administrator.
Markup - markup
for username and password
make sure your layout logs in with this user when you open the layout

Active Member
howard.thompson2
Posts: 10
Registered: ‎12-14-2007
Message 3 of 5 (497 Views)

Re: Markup example for Mapserver 2012

10-31-2012 01:13 PM in reply to: gluckett

That was certainly part of my problem...I'm close to having this...but I'm getting an error listed below out of the Mapserver log files:

 

<2012-10-29T09:36:02>  4832 Ajax Viewer 140.139.196.103 Administrator
 Error: Failed to stylize layer: _howard33333
        The coordinate system initialization failed.
        Could not initialize the geodetic transformation.

 

I'm creating shp files and dwf files using Autodesk Map. I believe it doesn't like the coordinate system, but I've tried different ones to no avail.

Valued Mentor
gluckett
Posts: 426
Registered: ‎10-10-2003
Message 4 of 5 (495 Views)

Re: Markup example for Mapserver 2012

10-31-2012 01:17 PM in reply to: howard.thompson2

Yes, the definition of LL84 has changed (this is true for MGOS 2.4 too)

 

I had this issue before, find how I fixed it here:

http://osgeo-org.1560.n6.nabble.com/API-Change-in-MG-2-4-tt4996684.html#a4997139

 

 

Active Member
howard.thompson2
Posts: 10
Registered: ‎12-14-2007
Message 5 of 5 (486 Views)

Re: Markup example for Mapserver 2012

11-01-2012 05:59 AM in reply to: gluckett

That did work for me!!! Thanks alot!!!!! One last question...this only works for data with a true coordinate system doesn't it?? I have some data that I published, but becasue it wasn't in a true coordinate system, I used the arbitrary XY-FT when I published my data, and the markup tool doesn't seem to work on that...but I have other data, with true coordinate systems, and it appears to work on that just fine.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.