Infrastructure Map Server Developer

Infrastructure Map Server Developer

Reply
Member
5 Posts
0 Kudos
Registered: ‎11-13-2006
Post 1 of 4

Map does not show up on localhost with flexible layouts (fusion)

325 Views, 3 Replies
01-28-2009 01:08 PM
As a developer I need to create a web application first on my localhost PC and then deploy it to the production server. On my PC I installed MG Studio and web server extensions.
If I use the basic web layout (e.g. AJAX) I can see in application my map without any problems. But if I try to use in the same way any flexible web layout then map newer shows up, even though I do not get any errors.

In other words this URL works:
http://localhost/mapguide2009/mapviewerajax/?WEBLAYOUT=.........

but this URL does not work:
http://localhost/mapguide2009/fusion/templates/mapguide/slate/index.html?ApplicationDefinition=Library.............
All panes are loaded into the browser, but all of them are empty.

Does anyone know how to fix this problem?

Thanks.
Contributor
21 Posts
1 Kudo
Registered: ‎10-31-2003
Post 2 of 4

Re: Map does not show up on localhost with flexible layouts (fusion)

02-24-2009 11:59 AM in reply to: borisgorevoy7019
Replace localhost with the ip address 127.0.0.1.

Stan
Member
5 Posts
0 Kudos
Registered: ‎11-13-2006
Post 3 of 4

Re: Map does not show up on localhost with flexible layouts (fusion)

02-25-2009 05:53 AM in reply to: borisgorevoy7019
Replacing “localhost” with 127.0.0.1 does help. The map still does not show up.

I found a temporary workaround for this issue. I did the following:
1. Changed in IIS 5 (this version of IIS is on my PC) Application Protection from High (Isolated) to Low (IIS Process) for all five folders:
- mapguide2009
- mapviewerajax
- mapviewerdwf
- mapviewernet
- mapagent
2. Repaired MGE web server extensions through add/remove programs
3. Restarted PC

Then “localhost” works.
If I install Update 1 for MGE web server extensions - then localhost does not work again, no matter what settings are in ISS.

So, the problem is hiding somewhere between IIS 5 Application Protection setting and MGE web server extensions.
Update 1 only worsens the problem.

As a result I can now use the localhost to develop and test applications, but I cannot install Update 1.
New Member
2 Posts
0 Kudos
Registered: ‎05-14-2009
Post 4 of 4

Re: Map does not show up on localhost with flexible layouts (fusion)

05-14-2009 05:17 PM in reply to: borisgorevoy7019
I have the same problem but with the version 2009 porfavor ayudenme my servant is local
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!