Infrastructure Map Server General Discussion

Infrastructure Map Server General Discussion

Reply
Contributor
cpietra
Posts: 18
Registered: ‎10-09-2010
Message 1 of 8 (656 Views)

Map Display issue Using MobileViewer

656 Views, 7 Replies
10-12-2012 07:02 PM

Initial Map display on ipad iphone very small and does not follow initial display sale size as set in Mapguide Studio.

 

   More importantly as zooming into map, at a partiular scale everytime all layers turn off. All layers are set in studio to remain on at all scales. Map initial display is set to within extents. Is there something I need to modify in html filr or related.

 

Thanks ahead of time

Valued Mentor
gluckett
Posts: 414
Registered: ‎10-10-2003
Message 2 of 8 (627 Views)

Re: Map Display issue Using MobileViewer

10-17-2012 04:05 AM in reply to: cpietra
the map extents are very important to all layouts and the mobile viewer.

i would recommend downloading the latest Maestro and using the tool to collect the extents from all layers in the current map. to find it, just open your map.

i wish this tool was in studio.
Contributor
cpietra
Posts: 18
Registered: ‎10-09-2010
Message 3 of 8 (623 Views)

Re: Map Display issue Using MobileViewer

10-17-2012 04:11 AM in reply to: cpietra

Gordon

 

I have played with the extents in studio 2013 but it does not seem to make any difference.  I get Parse errors or the map displays way out and zooming in causes all layers to turn off.  Different maps may not load at all , just spin indefinitely.  One map is down to a single parcel layer. No dice.  By the way I still have the Cold Fusion T shirt from the Autodesk training in Virginia around 1998 MapGuide 6.0 from the class you taught

Valued Mentor
gluckett
Posts: 414
Registered: ‎10-10-2003
Message 4 of 8 (621 Views)

Re: Map Display issue Using MobileViewer

10-17-2012 04:15 AM in reply to: cpietra
ah, remember that class. love cold fusion still.

i had trouble adding any map not in spherical mercator. are your maps in that?
Contributor
cpietra
Posts: 18
Registered: ‎10-09-2010
Message 5 of 8 (617 Views)

Re: Map Display issue Using MobileViewer

10-17-2012 04:35 AM in reply to: cpietra

No   State Plane NAD 83 NY Central    Do you have a link to current Maestro ?

Valued Mentor
gluckett
Posts: 414
Registered: ‎10-10-2003
Message 6 of 8 (614 Views)

Re: Map Display issue Using MobileViewer

10-17-2012 04:40 AM in reply to: cpietra
i would try spherical mercator (google projection) first.

maestro
http://trac.osgeo.org/mapguide/wiki/maestro/Downloads
Contributor
tony.witham
Posts: 25
Registered: ‎09-24-2012
Message 7 of 8 (171 Views)

Re: Map Display issue Using MobileViewer

11-13-2013 03:44 AM in reply to: gluckett

Hi,

 

I can use MobileViewer in MapServer 2014 if my map is based on data that is in Lat Long.  If I try to view a map based on data that is in the British National Grid projection I experience exactly the same issues i.e. layers all turn off when I zoom in.

 

Has there been any progress in solving this problem?

Valued Mentor
gluckett
Posts: 414
Registered: ‎10-10-2003
Message 8 of 8 (157 Views)

Re: Map Display issue Using MobileViewer

11-14-2013 08:36 AM in reply to: cpietra

Try adding the &baselayers=osm to the end to see the data (in a weird location) but at least your will see your data.

 

 

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are You Going To Be @ AU 2014? Feel free to drop by our AU topic post and share your plans, plug a class that you're teaching, or simply check out who else from the community might be in attendance. Ohh and don't forgot to stop by the Autodesk Help | Learn | Collaborate booths in the Exhibit Hall and meet our community team if you get a chance!