Infrastructure Map Server General Discussion

Infrastructure Map Server General Discussion

Reply
Valued Contributor
gbneff
Posts: 63
Registered: ‎11-08-2000
Message 1 of 4 (120 Views)

DWF Viewer Problem

120 Views, 3 Replies
11-02-2006 09:49 AM
I've noticed that point layers that have rotated symbols are displayed correctly in the AJAX viewer but not in the dwf viewer. I'm using the latest version of the viewer.

I'm just pointing this out in case anyone at Autodesk is listening. Except for this problem, I prefer the dwf viewer.
Employee
bill.dhimitri
Posts: 42
Registered: ‎12-18-2003
Message 2 of 4 (120 Views)

Re: DWF Viewer Problem

11-03-2006 08:29 AM in reply to: gbneff
I'm trying to reproduce the problem. Can you give some more details? Is the orientation angle incorrect? Or is the symbol being displayed at the wrong location? Are you using "mark" symbols or symbols from a symbol library?

Bill
Valued Contributor
gbneff
Posts: 63
Registered: ‎11-08-2000
Message 3 of 4 (120 Views)

Re: DWF Viewer Problem

11-03-2006 01:01 PM in reply to: gbneff
Here is what I'm doing:

I have a point layer used to represent the direction of flow along a line. The data source for my layer is an Access database with a table that has columns for Lat, Long and a rotation angle.

For the point style I am using the triangle mark. I have distorted the symbol in the y-axis to make it look like an arrowhead. I am using the center point for insertion of the symbol. For the rotation of the symbol I have "Rot" - 90 where Rot is the name of the rotation angle column of my database. The rotation angle is in degrees.

I have attached two files in a zip file: one is a .png file created using the Ajax viewer and the other by printing from the dwf viewer to a DWF file using the dwf writer. As you will see the Ajax viewer displays correctly and the dwf viewer does not. The rotation appears correct, meaning the arrowhead is parallel to the line, but is offset. The offset looks more pronounced in the E-W (x-axis) direction.

Incidentally, I have been using this same dataset with mapguide 6.5 and the activex viewer for some time and the display is perfect.

Hope this information is helpful.

Greg Neff
Employee
bill.dhimitri
Posts: 42
Registered: ‎12-18-2003
Message 4 of 4 (120 Views)

Re: DWF Viewer Problem

11-03-2006 02:10 PM in reply to: gbneff
Greg,

Your description and pictures are very helpful.

Thanks,
Bill
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.