Infrastructure Map Server Developer

Infrastructure Map Server Developer

Reply
Valued Contributor
swimming123
Posts: 87
Registered: ‎04-12-2012
Message 1 of 5 (1,588 Views)

Could not load 'MapGuideDotNetApi' warning message

1588 Views, 4 Replies
09-17-2012 07:40 AM

When I start to do customization for AIMS using VS2010 .NET4.0, I copy the .dll file to my project folder, add reference to5 OSGeo***.dll files.  I got the warning messageis as follows:

 

Warning           C:\Altus\AltusWebMap\AltusWebMap\Default.aspx: ASP.NET runtime error: Could not load file or assembly 'MapGuideDotNetApi' or one of its dependencies. An attempt was made to load a program with an incorrect format. C:\Abc\AbcWebMap\AbcWebMap\Default.aspx         1          1          AbcWebMap

 

How to fix this?  Is this the problem that cause my redline not working? Thank you.

Valued Mentor
jackie.ng
Posts: 284
Registered: ‎10-06-2008
Message 2 of 5 (1,584 Views)

Re: Could not load 'MapGuideDotNetApi' warning message

09-17-2012 07:50 PM in reply to: swimming123

You need to make sure your IIS application pool assigned to your web application is running at the same bit-ness as your version of AIMS/MapGuide

 

- Jackie

Valued Contributor
swimming123
Posts: 87
Registered: ‎04-12-2012
Message 3 of 5 (1,578 Views)

Re: Could not load 'MapGuideDotNetApi' warning message

09-18-2012 07:28 AM in reply to: jackie.ng

IIS Application pool is 64 bits, AIMS2013 is also 64bits, but my visual studio 2010 is 32 bits. It also matters,right?

Valued Mentor
jackie.ng
Posts: 284
Registered: ‎10-06-2008
Message 4 of 5 (1,572 Views)

Re: Could not load 'MapGuideDotNetApi' warning message

09-18-2012 09:00 PM in reply to: swimming123

If you're debugging with Visual Studio's built-in web server (or IIS express), it's probably a 32-bit process, which is why it can't load your 64-bit MapGuide assemblies.

 

Try setting up a virtual directory in IIS for your MapGuide/AIMS application (assigned to the same application pool as MapGuide/AIMS) and open that virtual dir with Visual Studio (probably need UAC elevation). This should let you debug with IIS proper and have all the bitnesses be the same.

 

- Jackie

Contributor
andy62
Posts: 21
Registered: ‎10-29-2007
Message 5 of 5 (65 Views)

Re: Could not load 'MapGuideDotNetApi' warning message

10-31-2014 10:18 AM in reply to: jackie.ng

 

after days and days of work, I am still not able to compile my dot.net application with AIMS 2014 64-bit.
I followed this video also:
http://download.autodesk.com/media/adn/AIMS2012_Webcast_English/AIMS2012_Webcast_English.html
but without success :smileyembarrassed:

can someone help me?

 

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.