Infrastructure Map Server Developer

Infrastructure Map Server Developer

Reply
Distinguished Contributor
wesbird
Posts: 351
Registered: ‎12-05-2003
Message 1 of 3 (367 Views)

AIMS 2013 Oracle spatial layer filter does not working

367 Views, 2 Replies
09-17-2013 12:16 PM

Hi, 

 

Actually I downloaded a demo project MgViewerExtension from link and try it on the "Sheboygan" sample in Autodesck Infrastructure Server Web Extension. It works kinda fine with the url "http://localhost/MgViewerExtension/default.aspx?Layer=Districts&LayerFilter=Autogenerated_SDF_ID =9". Sometimes it gives me an error like beblow.

"Problem:
The application encountered a problem and could not finish the operation you just requested properly.

Solution:
If it\'s the first time you met this problem, try again or restart the application / session; otherwise, describe the steps to reproduce this problem to the server administrator for suggestions.

After I refresh the browser, it's works again. It's like sometimes it works sometimes not.


And then I created my own map and weblayout, The Map has one layer which is using the Oracle as the datasource. After change the weblayout and map definition in the code from
string webLayout = @"Library://Samples/Sheboygan/Layouts/SheboyganAsp.WebLayout";
tring mapDef = @"Library://Samples/Sheboygan/Maps/Sheboygan.MapDefinition";

to
string webLayout = @"Library://RealSuite/Layouts/MapLayout.WebLayout";
string mapDef = @"Library://RealSuite/Maps/RealSuiteMap.MapDefinition";

When I run the url http://localhost/MgViewerExtension/default.aspx without any filter, it works fine. But when I run the url with layer and filter as
http://localhost/MgViewerExtension/default.aspx?Layer=SpatialLayer&LayerFilter=BUILDING_ID = 'TDB0103'

It gives me an error The map definition is invalid.

Do you have any idea what's happening here? All the code is the same except the two lines I mentioned above. I am totally a newbie in the mapguide development. If you can give some help, that would be perfect and I appreciate it.

Attached are the screenshots

Thank you very much.

Distinguished Contributor
wesbird
Posts: 351
Registered: ‎12-05-2003
Message 2 of 3 (366 Views)

Re: AIMS 2013 Oracle spatial layer filter does not working

09-17-2013 12:17 PM in reply to: wesbird
Distinguished Contributor
wesbird
Posts: 351
Registered: ‎12-05-2003
Message 3 of 3 (345 Views)

Re: AIMS 2013 Oracle spatial layer filter does not working

09-18-2013 11:06 AM in reply to: wesbird

Update: 

 the error doesn’t happen in the MgViewerExtention project, it happens in the file C:\Program Files\Autodesk\Autodesk Infrastructure Web Server Extension 2013\www\mapviewernet\mapframe.aspx.  Line105:  map.Create(resourceSrvc, resId, mapName);  

When I check the exception .Message and exception.StackTrace, It information is below:

The map definition is invalid.- MgMap.Create() line 328 file d:\build\ims2013\build_52.8\ent\os\common\mapguidecommon\MapLayer/Map.cpp.

 

For Sheboycan there is no problem, but for our Map, it happens.

 

Is there any bug in AIMS 2013? should I use 2014? 

Anybody have a example dynamically filtering the oracle spatial layer, or know where I can find one, I really appreciate.

 

 

Thanks

Wes

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.