AutoCAD Utility Design General Discussion

AutoCAD Utility Design General Discussion

Reply
New Member
2 Posts
0 Kudos
Registered: ‎12-09-2011
Post 1 of 5

LISP in AUD

1447 Views, 4 Replies
12-09-2011 05:39 PM

Does anyone have experience in bringing LISP over from AutoCad into AUD? I have some code that I have dropped in and thought it would work. It looks like it is more or less hit and miss. Any help understanding why would be greatly appreciated!

 

Member
4 Posts
0 Kudos
Registered: ‎07-20-2006
Post 2 of 5

Re: LISP in AUD

12-11-2011 07:32 PM in reply to: bbeck110

Would it be possible to share your LISP routine? There shouldn't be anythiing different between ACAD and AUD as far as LISP code goes. Also are we referencing 2009 version of ACAD and AUD?

Rick...

New Member
2 Posts
0 Kudos
Registered: ‎12-09-2011
Post 3 of 5

Re: LISP in AUD

12-11-2011 08:33 PM in reply to: bbeck110
Thanks for the reply, Rick
To be more specific I meant UDS. My understanding is that AUD is on a similar but different platform thatn straight acad. I don't have the lisp to share. I am getting errors in AUD like: object set to a reference...
Member
4 Posts
0 Kudos
Registered: ‎07-20-2006
Post 4 of 5

Re: LISP in AUD

12-12-2011 08:20 AM in reply to: bbeck110

Well this will be certainly hard to give an answer w/o seeing code for this error. That said AUD is built on AutoCAD Map 3D which is built on ACAD so it is essentially the same underlying engine everything bubbles up. Only thing I can think of is the LISP code has something specific to an ACAD that is slightly different in AUD except I cannot think of anything from a LISP perspective.

Would it help to take this off-line to share code? Otherwise not a lot to go on to figure out issue you are seeing.

Rick...

Active Contributor
37 Posts
1 Kudo
Registered: ‎10-02-2008
Post 5 of 5

Re: LISP in AUD

12-12-2011 05:25 PM in reply to: bbeck110

Hello,

Depending on what you are trying to do Lisp code that works in autocad will work in AUD (UDS), how ever AUD does store some extended entity data on all of its entities (Lines, blocks, etc.) this could be causing your error, again with out know what you are trying to do its hard to diagnose where the problem lies.

 

you can look in the AUD_core.lsp and AUD_custom.lsp fiels and you will find examples of lisp code that currently runs in AUD2009 to about UDS2000i

 

Jim Bower

Spatial Network Solutions

 

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New Utility Design Category!

The Utility Design forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.

Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!