AutoCAD R12/R13/R14 Archive

AutoCAD R12/R13/R14 Archive

New Member
2 Posts
0 Kudos
Registered: ‎08-28-2000
Post 1 of 2

phar lap error 35, grr

1076 Views, 1 Replies
08-28-2000 08:43 PM
Hi all,

Well its nice to see that I'm not the only one whose tryin to still run R12. I'm running R12 on a Pentium 200 MMX, 96 MB RAM, Voodo 2x accelerator, and the OS is NT 5.0

I went through the normal installation routine and everything seemed to go well. I then switched to the ...\AWCD\ directory and tried to run the awcd.exe, which resulted in the ungentlemen like message of "Divide Error"! I see that in an earlier post that someone suggested this has to do with the way the processor is running, and I agree as I tried some testing in safe mode and recieved a few cpu error messages. However I didn't see how to configure anything in my BIOS that might improve the situation.

Not taking no for an answer from R12, I got it running on an old NT 4.0 box and then copied all the files from that via a zip disk onto my NT 5.0 box into the same directories. The windows version of R12 worked like a charm, just had to fire up the executable and it went to work. My only complaint is the thing wants to tie up 100% of my CPU time, I assume this is something that can be configured through windows???

The next item I tried to get running is the 3D Studio, Release 2. I copied these files just like the autocad, but when I tried to start the executable it gave me the error message:

"Phar Lap err 35: The 386 chip is currently executing in virtual 8096 mode under the control of another program. You must turn off this other program in order to use 386|DOS-Extender to run in protected mode."

Went through a bunch of troubleshooting steps to see if any other programs were interfering, but couldn't see anything wrong. The only thing I can see that I might not have set correctly is the Memory settings of which in NT 5 I can set: Conventional Memory, Initial Environment, EMS Memory, XMS Memory, and MS-DOS Protected Mode (DPMI) Memory. - Not really sure what these (esp EMS and XMS) should be set for for 3D Studio.

I searched around on the files for readme's and on the knowledge base here and haven't found anything extremely useful. Anyone have any ideas on how to overcome this problem?

Also does anyone know what are the AAPLAY.exe, CFIG386.exe, and OLDDXARC.exe programs that are found in the ...\3DS2\ directory? Sorry for the long post. :smileywink:


Active Member
9 Posts
0 Kudos
Registered: ‎07-18-2007
Post 2 of 2

Re: phar lap error 35, grr

07-18-2007 08:13 AM in reply to: Shawn_Johnston
Here are 3 common Phar Lap error messages that occur when trying to run old Extended DOS programs in Win 2000 or XP accompanied by possible solutions:

(You'll want to check the first one, err 35)

No DOSX.EXE loaded (Microsoft DPMI host):

Error TNT.20035: The 386 chip is currently executing in virtual 8086 mode under
the control of another program. You must turn off this other
program in order to use TNT DOS-Extender to run in protected

Solution: Load DOSX.EXE in an Autoexec .NT file such as AUTOEXEC.NT or a
program specific Autoexec .NT you create and set in the
Program Shortcut/Program/Advanced/Custom MS-DOS initialization files/Autoexec filename: -

REM Install DPMI support
lh %SystemRoot%\system32\dosx

This is the standard line in AUTOEXEC.NT.

In your program shortcut's Memory tab, set EMS to None.

(CFIG386.EXE is a utility from Phar Lap that allows configuring the DOS-Extender when it's bound into the main program's .EXE. See error 74 below for an example).

PADS Perform DOS with built-in 386|DOS-Extender v5.1 sometimes does not delete swap file when it terminates abnormally and then cannot, or refuses to, start a new one (overwriting the one left):

Phar Lap err 58: Can't create VM swap file of size 0 in directory

Solution: Start the program with a batch file and add
"del C:\PPERFORM.SWP" before the line that starts PADS Perform

For a different program, substitute the appropriate path and swap file name.

No DPMI v1.0 host with Map Conventional Memory in Memory Block function (INT31h AX=0509h), required by any program which uses -REALBREAK:

Phar Lap err 74: Can't use -REALBREAK under this version of DPMI
Error TNT.20074: Can't use -REALBREAK under this version of DPMI

The purpose of the -REALBREAK switch is to request that some of the code and data be placed in conventional memory. There appears to be 2 reasons to use -REALBREAK to load some of the application in conventional memory:

1. Having some of the application in conventional memory can apparently improve the performance for some programs.

2. Mixing Real-mode and Protected-mode code. Apparently Real-mode code can be mixed with Protected-mode code if the Real-mode code and data are 64K or less and they are loaded in conventional memory (linked to be positioned at the beginning of the executable file).


1. If program is all Protected-mode code, apply -REALBREAK 0 -

"CFIG386.EXE Program.EXE -realbreak 0" if DOS-Extender is bound to the
Program (one .EXE),

"TNT.EXE -REALBREAK 0 Program.EXE" if using a separate DOS-Extender loader

This says load 0KB in conventional memory, effectively eliminating the need for -REALBREAK support and allowing a DPMI v0.9 host to suffice. Microsoft's EMM386.EXE and DOSX.EXE DPMI hosts provide DPMI v0.9 support.
The performance will decrease, but the program should run.

2. If program is mixed Real-mode and Protected-mode code, you're screwed.
This is because Real-mode code and data MUST be loaded in conventional
memory, thus requiring support for INT31h Function AX=0509h, which in turn
requires a DPMI v1.0 host.

In this case, with -REALBREAK set to 0, the DOS-Extender will load. But when the program starts to load, it quickly displays an error such as the following:

cannot reach real mode vector
EAX ........ 0000250F
EBX ........ 00000000
ECX ........ 00008DC0
EDX ........ 002D0008
Exiting ...

since the Real-mode code isn't being loaded in conventional memory.

Reverse engineer the program and add the realcopy() function shown in DOX-Extender's MDRAW sample program and eliminate the need for -REALBREAK. Then the program should work in the NT series.

Or, for a more practical solution, try a Virtual Machine or Emulator such as DOSBox, Virtual PC, or VMware Workstation. Virtual PC can run PADS Perform DOS in Windows XP SP2, but only at 640x480 because of limited video support. DOSBox can even run PADS Perform DOS at 1024x768 in Windows XP SP2. DOSBox and Virtual PC are free.

So, even if ACAD R12 DOS uses mixed code like PADS Perform, you can still run it in Win 2000 or XP. But you'll have to use a virtual machine or emulator such as Virtual PC or DOSBox. On an Athlon XP 3200 with 2GB of memory, performance was acceptable for PADS. Try both to see which has the best performance and video support for ACAD. And get the fastest computer possible if your drawings are very large.

If interested, see:

" ort.mspx"
Community, Virtual PC newsgroup
Search for: Virtual PC 2004 or 2007 Video Card Support for DOS programs
See the 2 posts on 07/18/2007.

VMware Workstation 5.5 or 6.0 Video Card Support for DOS programs
" 595889"
See post of 07/15/2007.

(CFIG386.EXE is a utility from Phar Lap that allows configuring the DOS-Extender when it's bound into the main program's .EXE).

(PHARLAP.386 is a VxD, virtual driver, only for the Win 9x series. It will not load or work in the NT series).

(PADS Perform DOS is an Electronic CAD program that uses mixed code, the Phar Lap 386|DOS-Extender, and the -REALBREAK switch).
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!