AutoCAD Plant 3D General DIscussion

AutoCAD Plant 3D General DIscussion

Reply
Valued Contributor
54 Posts
13 Kudos
Registered: ‎05-03-2010
Post 1 of 10
Accepted Solution

Custom part not showing in BOM in 2012...

1367 Views, 9 Replies
08-25-2011 11:35 AM

I am having an issue with custom parts not being added to the BOM, they are shown on the ISO but have no part ID number and no info in the BOM. All other parts for the spec show up in the BOM. I have even taken a .pcf file I created and iso'd in 2011 and performed a "pcf to iso" run on it. The 2012 version still fails to add custom parts to the BOM, even on pcf created ion 2011. Is there a setting in the isoconfig.xml that I missing? Please help. 

 

Chad

Chad,

 

Could you please check whether the "INSTRUMENTS <Instruments>" section shows up in the BOM Table int he dwt file?

 

1. Make the changes to isoconfig.xml as suggested in the other posts. You need to make this change in the iso style that you are testing with.

 

2. Go to Project Setup, Isometric DWG Settings, Title Block and Display. Click on "Setup Title Block" button. If you have the "Grouped with category titles" set in the Table Setup, you should see the BOM table show up as attached (BOM Table in dwt.png).

 

3. Now, exit all the way out of project setup and use PCF to Iso. Make sure that you choose the same Iso Style that you changed to enable display of Instruments in BOM Table.

 

The generated output dwg should have the Instruments section. See the attached images. That is what I see for the pcf that you sent.

 

If that still does not work, please zip up your entire style and then attach it to a message. We can debug further and determine the cause of the issue.

 

Thanks.


Ratti.

Employee
37 Posts
4 Kudos
Registered: ‎12-14-2009
Post 2 of 10

Re: Custom part not showing in BOM in 2012...

08-25-2011 01:57 PM in reply to: chad70811

Hello Chad,

 

I have forwarded your question to our Isometrics Team. They should be able to provide more information soon.

 

Thanks,

Raj Inugala.

Employee
20 Posts
7 Kudos
Registered: ‎04-23-2008
Post 3 of 10

Re: Custom part not showing in BOM in 2012...

08-25-2011 03:53 PM in reply to: chad70811

Chad,

 

By default, instruments are not output to the BOM table in the out-of-box styles. Looking at the iso image that you attached, I suspect that you have added custom part instruments.

 

To add instruments to the BOM table, please add a new group for Instruments to the AggregatedList/Groups element. As an illustration, I have added such a group at the end of the XML snippet below. Hopefully, that should fix your problem. Please let us know if the below suggestion does not resolve the issue that you are seeing.

 

        <Groups>
          <!-- 'UseAlternateUnitsStyle': 'true' or 'false' -->
          <!--    Designates if the alternate units should style be used to format (pipe length) -->
          <!--    measurements in this data list. -->
          <Group Name="PIPE" UseAlternateUnitsStyle="true">
            <!-- An expression that is used to filter which rows are included in the list -->
            <!-- Refer to http://msdn.microsoft.com/en-us/library/system.data.datacolumn.expression.aspx -->
            <!-- for expression syntax. -->
            <RowFilter Filter="Pipe" />
            <!-- List of 'Label' configurations -->
            <Labels>
              <!-- 'Label': (string) -->
              <!--    The label of the group. Used only in table templates. -->
              <Label Name="pipe" />
            </Labels>
            <!-- List of columns to group rows by -->
            <Columns>
              <!-- 'name': (string); Column name -->
              <Column Name="Category" />
              <Column Name="Code" />
              <Column Name="Description" />
            </Columns>
            <!-- Specifies the sort columns and sort order -->
            <!-- 'SortBy': (string); Contains the column name followed by a space and 'ASC' (ascending) or 'DESC' (descending). -->
            <!-- Columns are sorted ascending by default. Multiple columns can be separated by commas. -->
            <Sort SortBy="Type ASC,Size ASC" />
          </Group>
          <Group Name="FITTINGS">
            <RowFilter Filter="BOMFitting"/>
            <Labels>
              <Label Name="fittings" />
            </Labels>
            <Columns>
              <Column Name="Category" />
              <Column Name="Code" />
            </Columns>
            <Sort SortBy="Type ASC,Size ASC" />
          </Group>
          <Group Name="OLETS">
            <RowFilter Filter="Olet" />
            <Labels>
              <Label Name="olets" />
            </Labels>
            <Columns>
              <Column Name="Category" />
              <Column Name="Code" />
            </Columns>
            <Sort SortBy="Type ASC,Size ASC" />
          </Group>
          <Group Name="FLANGES">
            <RowFilter Filter="Flange" />
            <Labels>
              <Label Name="flanges" />
            </Labels>
            <Columns>
              <Column Name="Category" />
              <Column Name="Code" />
            </Columns>
            <Sort SortBy="Type ASC,Size ASC" />
          </Group>
          <Group Name="FASTENERS">
            <RowFilter Filter="Fastener" />
            <Labels>
              <Label Name="fasteners" />
            </Labels>
            <Columns>
              <Column Name="Category" />
              <Column Name="Code" />
              <Column Name="Size" />
            </Columns>
            <Sort SortBy="Type ASC,Size ASC" />
          </Group>
          <Group Name="VALVES">
            <RowFilter Filter="Valve" />
            <Labels>
              <Label Name="valves" />
            </Labels>
            <Columns>
              <Column Name="Category" />
              <Column Name="Code" />
            </Columns>
            <Sort SortBy="Type ASC,Size ASC" />
          </Group>
          <Group Name="PIPE SUPPORTS">
            <RowFilter Filter="Support" />
            <Labels>
              <Label Name="pipe supports" />
            </Labels>
            <Columns>
              <Column Name="Category" />
              <Column Name="Code" />
            </Columns>
            <Sort SortBy="Type ASC,Size ASC" />
          </Group>
          <Group Name="INSTRUMENTS">
            <RowFilter Filter="Instrument" />
            <Labels>
              <Label Name="Instruments" />
            </Labels>
            <Columns>
              <Column Name="Category" />
              <Column Name="Code" />
            </Columns>
            <Sort SortBy="Type ASC,Size ASC" />
          </Group>      
   </Groups>

 

Thanks.

 

Ratti.

Autodesk, Inc.
Valued Contributor
54 Posts
13 Kudos
Registered: ‎05-03-2010
Post 4 of 10

Re: Custom part not showing in BOM in 2012...

08-25-2011 09:56 PM in reply to: ratti

Chad

Thanks for the quick response, but the solution you posted above did not fix the issue for me. I have attached a .pcf file and the associated iso that was created. Maybe these files will help you.

 

 

Thanks,

Employee
30 Posts
9 Kudos
Registered: ‎08-26-2011
Post 5 of 10

Re: Custom part not showing in BOM in 2012...

08-26-2011 12:18 AM in reply to: chad70811

Add below into </AggregatedList> in isoconfig.xml

 

          <Group Name="Instrument">

            <Labels>

               <Label Name=”instrument” />

            </Labels>

              <Columns>

              <Column Name="Category"/>

              <Column Name="Code"/>

            </Columns>

            <Sort SortBy="Type ASC"/>

              <RowFilter Filter="Instrument"/>

          </Group>

 

E.g. Red text are the location which should be added.

<Group Name="PIPE SUPPORTS">

            <RowFilter Filter="Support" />

            <Labels>

              <Label Name="pipe supports" />

            </Labels>

            <Columns>

              <Column Name="Category" />

              <Column Name="Code" />

            </Columns>

            <Sort SortBy="Type ASC,Size ASC" />

          </Group>

                <Group Name="Instrument">

            <Labels>

               <Label Name="instrument" />

            </Labels>

              <Columns>

              <Column Name="Category"/>

              <Column Name="Code"/>

            </Columns>

            <Sort SortBy="Type ASC"/>

              <RowFilter Filter="Instrument"/>

          </Group>

        </Groups>

      </AggregatedList>

      <AggregatedList xsi:type="IsoCompositeDataListConfig" Name="ShopMaterials">

        <RowFilter Filter="ItemCodeNotNullAndCategoryFabItem" />

 

If BOM is separated into Fabrication & Erection items, then we should also add above into ShopMaterials and FieldMaterials </AggregatedList> as well.

 

-Vicky

 

Vicky
Autodesk Plant Solutions
Employee
20 Posts
7 Kudos
Registered: ‎04-23-2008
Post 6 of 10

Re: Custom part not showing in BOM in 2012...

08-26-2011 10:50 AM in reply to: chad70811

Chad,

 

Could you please check whether the "INSTRUMENTS <Instruments>" section shows up in the BOM Table int he dwt file?

 

1. Make the changes to isoconfig.xml as suggested in the other posts. You need to make this change in the iso style that you are testing with.

 

2. Go to Project Setup, Isometric DWG Settings, Title Block and Display. Click on "Setup Title Block" button. If you have the "Grouped with category titles" set in the Table Setup, you should see the BOM table show up as attached (BOM Table in dwt.png).

 

3. Now, exit all the way out of project setup and use PCF to Iso. Make sure that you choose the same Iso Style that you changed to enable display of Instruments in BOM Table.

 

The generated output dwg should have the Instruments section. See the attached images. That is what I see for the pcf that you sent.

 

If that still does not work, please zip up your entire style and then attach it to a message. We can debug further and determine the cause of the issue.

 

Thanks.


Ratti.

Autodesk, Inc.
Valued Contributor
54 Posts
13 Kudos
Registered: ‎05-03-2010
Post 7 of 10

Re: Custom part not showing in BOM in 2012...

08-29-2011 09:13 AM in reply to: ratti

Thanks Ratti, that was the solution.

Active Contributor
31 Posts
3 Kudos
Registered: ‎11-15-2013
Post 8 of 10

Re: Custom part not showing in BOM in 2012...

11-22-2013 06:30 AM in reply to: chad70811

I've done the same procedure,  however its grouping all instruments into one row on the BOM.


The instruments mentioned are both custom parts using Add Custom Part in the model. They have different long descriptions and different symbols. Both started as "in-line instrument"

 

What I got was actually:

 

ID 17, QTY 2, SIZE 15, LD = PRESSURE GAUGE FLOW SWITCH

 

You see that it also somehow combined the long descriptions

 

 

Employee
358 Posts
39 Kudos
Registered: ‎08-15-2007
Post 9 of 10

Re: Custom part not showing in BOM in 2012...

11-22-2013 11:53 AM in reply to: Asimo5000

It's using the Item Code to determine which components are the same. After you place them, give them different item codes and it should stick them in different rows in the material list.

 

I didn't try it myself, but this should work.



Peter Quinn
Senior Product Manager
Autodesk, Inc.

Active Contributor
31 Posts
3 Kudos
Registered: ‎11-15-2013
Post 10 of 10

Re: Custom part not showing in BOM in 2012...

11-25-2013 06:37 AM in reply to: chad70811

That's done the trick. Excellent help Peter

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD Plant 3D Category!

The AutoCAD Plant 3D forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.

Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!