AutoCAD P&ID General Discussion

AutoCAD P&ID General Discussion

Reply
Active Contributor
PATRICKCAREY9382
Posts: 27
Registered: ‎09-25-2008
Message 1 of 9 (1,261 Views)

Unique Tag Assignment Error

1261 Views, 8 Replies
11-17-2008 04:34 PM
I am getting an error when assigning a tag to a component. the tag I am using is unique, but I get the following error:

"Another asset in the project has the same tag which has not been saved. Cannot merge with that tag. Please enter a unique tag"

Can anyone explain what is going on in this situation?

Thanks, Patrick
*Peter Quinn
Message 2 of 9 (1,260 Views)

Re: Unique Tag Assignment Error

11-18-2008 08:10 AM in reply to: PATRICKCAREY9382

Patrick,

 

You might try auditing the project. The project has
a record of that tag associated with something else in the data cache. Auditing
the project should clear it.

 

Peter Quinn (Autodesk)


style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
I
am getting an error when assigning a tag to a component. the tag I am using is
unique, but I get the following error: "Another asset in the project has the
same tag which has not been saved. Cannot merge with that tag. Please enter a
unique tag" Can anyone explain what is going on in this situation? Thanks,
Patrick
Active Contributor
PATRICKCAREY9382
Posts: 27
Registered: ‎09-25-2008
Message 3 of 9 (1,260 Views)

Re: Unique Tag Assignment Error

11-18-2008 08:53 AM in reply to: PATRICKCAREY9382
Thanks Peter. That cleared the tag registry, and I was able to use the tag I wanted on a new component.

--Patrick
Active Contributor
funkbro2
Posts: 31
Registered: ‎01-18-2009
Message 4 of 9 (1,260 Views)

Re: Unique Tag Assignment Error

03-05-2009 06:34 AM in reply to: PATRICKCAREY9382
I have this same problem too, however auditing the project did NOT fix the problem!

This stemmed from copying the drawing in Windows, adding it to the project, removing the first drawing from project. Some objects were retagged successfully but a few wont budge.
Active Member
Scuderia77
Posts: 9
Registered: ‎05-11-2011
Message 5 of 9 (1,160 Views)

Re: Unique Tag Assignment Error

05-19-2011 12:15 AM in reply to: PATRICKCAREY9382

I'm having the same issue, trying to place a butterfly valve and I'm having the "Please enter a unique number" error come up even after auditing the drawing and running a validation.

New Member
m_atmaca
Posts: 2
Registered: ‎01-04-2012
Message 6 of 9 (872 Views)

Re: Unique Tag Assignment Error

01-04-2012 02:34 PM in reply to: PATRICKCAREY9382

I'm having the same problem too, however auditing the project did NOT fix the problem....!!!!

Member
albarney99
Posts: 4
Registered: ‎09-24-2008
Message 7 of 9 (858 Views)

Re: Unique Tag Assignment Error

01-05-2012 05:03 PM in reply to: PATRICKCAREY9382

If the Audit doesn't work we found the error to be within the ProcessPower.dcf file. I used a free program called sqlitebrowser to open the SQL Database. I went to the Browse Data tab and viewed the PnPTagRegistry Table. In here I searched for the tag that I was trying to rename to (which PID was saying wasn't unique) and deleted that record. When I reopened the PID program and opened the drawing and changed tag number it was fine.

 

I would urge caution doing this. Make sure no-one is in the database and double check that Audit doesn't fix the issue. Also would back it up before editing. I think our issue happened when the program fatal errored while the user was mirroring the existing item. This I think caused the corruption in the DB.

 

Hope this helps

 

New Member
m_atmaca
Posts: 2
Registered: ‎01-04-2012
Message 8 of 9 (855 Views)

Re: Unique Tag Assignment Error

01-05-2012 05:16 PM in reply to: PATRICKCAREY9382

Thank you very much man that was a clever thinking.

Active Contributor
M!chelle
Posts: 43
Registered: ‎09-04-2012
Message 9 of 9 (692 Views)

Re: Unique Tag Assignment Error

10-04-2012 10:16 AM in reply to: m_atmaca

I audited both the drawing and the entire project.  I believe my issue is also the result of a fatal error crash.  The audit is not fixing the problem and I am unable to download the sqlite or whatever it was. 

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD P&ID Category!

The AutoCAD P&ID forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.

Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.