AutoCAD P&ID General Discussion

AutoCAD P&ID General Discussion

Reply
Mentor
craig.wood
Posts: 231
Registered: ‎02-20-2012
Message 1 of 9 (831 Views)

Random Bold Text Problem

831 Views, 8 Replies
07-12-2012 11:15 AM

I studied the former post regarding this issue found here, but found no working solution to this problem.

 

It appears that any text that is mirrored within Plant 3D 2013 runs a high possiblity of showing up as bold; however, this is not always the case. Sometimes text that is not mirrored will randomly appear as bold as well. The best example of this is with Off-Page Connectors since they auto-mirror when placed - based on the flow direction of the line.

 

Can anyone offer any practical solutions to this?

 

Thanks for your time,

Craig

Product Support
Dan.Scales
Posts: 325
Registered: ‎03-05-2010
Message 2 of 9 (804 Views)

Re: Random Bold Text Problem

07-19-2012 04:43 AM in reply to: craig.wood

Hi,

 

This is actually an AutoCAD issue that also exists in P&ID.

 

If the suggestion in the other post did not help try using the FLATTEN command as that often fixes the display of the bold text.

 

Thanks,
Dan

 



Dan Scales
Mentor
craig.wood
Posts: 231
Registered: ‎02-20-2012
Message 3 of 9 (799 Views)

Re: Random Bold Text Problem

07-19-2012 01:58 PM in reply to: Dan.Scales

I tried that, but get the following results:

Command: flatten
Select objects to convert to 2d...
Select objects: Specify opposite corner: 538 found, 11 groups
Select objects:
Remove hidden lines? <No>: n
bad argument type: lselsetp nil
Command:

Am I doing something wrong?

Thanks,
Craig

Product Support
Dan.Scales
Posts: 325
Registered: ‎03-05-2010
Message 4 of 9 (793 Views)

Re: Random Bold Text Problem

07-20-2012 02:06 AM in reply to: craig.wood

Hi,

 

Your steps look OK to me.

 

Does that error occur in all drawing when you use FLATTEN?

 

Thanks,

Dan



Dan Scales
Mentor
craig.wood
Posts: 231
Registered: ‎02-20-2012
Message 5 of 9 (791 Views)

Re: Random Bold Text Problem

07-20-2012 02:09 AM in reply to: Dan.Scales

Yes...everytime I've tried to use it from drawing to drawing, it yeilds the same results.

 

Any other ideas?

 

Thanks!

Craig

Product Support
Dan.Scales
Posts: 325
Registered: ‎03-05-2010
Message 6 of 9 (787 Views)

Re: Random Bold Text Problem

07-20-2012 03:28 AM in reply to: craig.wood

Hi,

 

Could you upload a small example drawing for me to test with?

 

Thanks,

Dan



Dan Scales
Mentor
craig.wood
Posts: 231
Registered: ‎02-20-2012
Message 7 of 9 (785 Views)

Re: Random Bold Text Problem

07-20-2012 03:37 AM in reply to: Dan.Scales

Sure thing...see the attached file.

 

Thanks!

Product Support
Dan.Scales
Posts: 325
Registered: ‎03-05-2010
Message 8 of 9 (782 Views)

Re: Random Bold Text Problem

07-20-2012 05:58 AM in reply to: craig.wood

Hi Craig,

 

I don't get the same error with the FLATTEN command, but it doesn't fix the bold text in the drawing anyway.

 

I think if you are experiencing this issue with bold text frequently you should consider switching to an SHX font rather than using TrueType.

 

Unfortunately I don't have any other workaround to offer you.

 

Thanks,

Dan 



Dan Scales
Mentor
craig.wood
Posts: 231
Registered: ‎02-20-2012
Message 9 of 9 (775 Views)

Re: Random Bold Text Problem

07-22-2012 09:08 PM in reply to: Dan.Scales

Thank for your time and effort Dan; I appreciate it!

 

Craig

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD P&ID Category!

The AutoCAD P&ID forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.

Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.