AutoCAD P&ID General Discussion

AutoCAD P&ID General Discussion

Reply
Distinguished Contributor
207 Posts
0 Kudos
Registered: ‎02-04-2005
Post 1 of 11

Export to spreadsheet not working

430 Views, 10 Replies
03-21-2007 05:40 AM
The export is grayed out in the data manager. Does anyone know why this would be?
Member
4 Posts
0 Kudos
Registered: ‎03-20-2007
Post 2 of 11

Re: Export to spreadsheet not working

03-21-2007 06:22 AM in reply to: cawaugh
Do you have Excel 2003?
It seems to be 1 of the known issues of the P&ID package.
Distinguished Contributor
207 Posts
0 Kudos
Registered: ‎02-04-2005
Post 3 of 11

Re: Export to spreadsheet not working

03-21-2007 07:07 AM in reply to: cawaugh
I do have '03. Does it not like '03?
Member
4 Posts
0 Kudos
Registered: ‎03-20-2007
Post 4 of 11

Re: Export to spreadsheet not working

03-21-2007 07:24 AM in reply to: cawaugh
No it should work with 03 and later.
At this moment I cannot test it myself because on my stsytem I still have office 2000.
But maybe someone else can really check it for you on their system.
Member
3 Posts
0 Kudos
Registered: ‎03-07-2008
Post 5 of 11

Re: Export to spreadsheet not working

03-07-2008 06:56 AM in reply to: cawaugh
I have Excel 2000 and I am having the same problem. I cannot export any data into excel. It appears as if it creates it, but the xls file never gets generated.
Member
3 Posts
0 Kudos
Registered: ‎03-07-2008
Post 6 of 11

Re: Export to spreadsheet not working

03-12-2008 05:00 AM in reply to: cawaugh
I have since upgraded to 2003 version of Excel and that fixed the problem. I am now able to export my data to excel and the application is working they way it should.
Contributor
19 Posts
1 Kudo
Registered: ‎03-18-2008
Post 7 of 11

Re: Export to spreadsheet not working

03-18-2008 02:38 PM in reply to: cawaugh
I have excel 2007 and I can't get the import to fully work. We can export then change the tags in excel but when we import the excel file back into the drawing it updates the tags but they do not show up on the drawing itself. When we go into the assign tag command the tag is in there but it doesn't automatically show up on the drawing. We have to manually place the tag under each valve or component. Does anybody know what we are doing wrong or have a suggestion on how this can be fixed?
Active Contributor
46 Posts
0 Kudos
Registered: ‎02-22-2003
Post 8 of 11

Re: Export to spreadsheet not working

04-03-2008 02:44 PM in reply to: cawaugh
I had a similar problem. I can export a report. We have Excel 2007. When I open the report in Excel I get the message "the file you are ttryin gto open 'name.xls' is in a different format than specified by the file extension. Verify that the file is not coorrupted and is from a trusted source before opening the file. Do you want to open the file now?" When I open the file it seems correct. If I make a change, save, and import into P&ID, it will import the file without the change I made. Anyone know what is going on?
*Peter Quinn
Post 9 of 11

Re: Export to spreadsheet not working

04-07-2008 09:38 AM in reply to: cawaugh
Bumble,

I suspect it has to do with the change in extensions from XLS to XLSx. But I
don't know for sure.


wrote in message news:5894727@discussion.autodesk.com...
I had a similar problem. I can export a report. We have Excel 2007. When I
open the report in Excel I get the message "the file you are ttryin gto open
'name.xls' is in a different format than specified by the file extension.
Verify that the file is not coorrupted and is from a trusted source before
opening the file. Do you want to open the file now?" When I open the file it
seems correct. If I make a change, save, and import into P&ID, it will
import the file without the change I made. Anyone know what is going on?
Board Manager
68 Posts
1 Kudo
Registered: ‎08-02-2007
Post 10 of 11

Re: Export to spreadsheet not working

04-23-2008 10:29 AM in reply to: cawaugh
Can you provide some more information which could help in finding why it is behaving strange on your machine. I
I have tested using Excel 2007 with both xls and xlsx format and import seems to work fine in both cases; the Tag's are updated in Data Manager as well as drawing. Can you also make sure if this behavior is only for that particular project and also. if it is just one particular machine.


Mangesh Kalbhor
Autodesk Plant Solutions
Autodesk, Inc.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD P&ID Category!

The AutoCAD P&ID forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.