AutoCAD P&ID General Discussion

AutoCAD P&ID General Discussion

Reply
Contributor
nikoR
Posts: 25
Registered: ‎01-03-2011
Message 1 of 5 (566 Views)

Acquisition values not up to date

566 Views, 4 Replies
12-16-2011 03:20 AM

Hello all - do you have good hints on this issue - happens with PID2012: 

 

Issues with Acquisition fields not always updating; they rather get stuck with empty field. Normally if there’s no data in the field acquired from, the acquisition field shows ?-mark – that’s clear. However if the acquisition gets stuck it shows only empty field “ “ despite there is data in the field acquired from.

 

Example below – pls see also attachment:

 

Pipeline has size DN 600 that can be seen in the list; column DN (that is directly pipeline value in the valve list). If the same data is inherited from pipeline to valve as valve property, column “PipeOrProcessEquimnentSizeIn” the field is empty. If user clicks “Override mode” and then back to “Acquire mode” the data gets updated there as if there’s no problem at all?

 

However the problem is that we can have hundreds of such issues in large project and a constant disbelief if the inherited data is up to date.

 

Command SYNCHSTYLES updates efficiently the annotations; we would desperately need command like “SYNCHACQUISITIONS” to update acquisiton fields.

(Audit project makes no difference…)

 

You can easily reproduce the problem by building a new acquisition rule to existing data field with existing value; the acquisition does not work and the acquisition field is empty.  

 

Thanks for your help  & Best Regards;

 

Niko R

Sweco Industry / Finland

Product Support
jason.drew
Posts: 322
Registered: ‎06-17-2010
Message 2 of 5 (542 Views)

Re: Acquisition values not up to date

12-22-2011 09:36 PM in reply to: nikoR

Hello Niko,

 

Thank you for posting and bringing this to my attention.

 

We are currently checking into this issue with the acquisition rules. I will post another update as soon as I have additional information.

 

With regard,



Jason Drew
Premium Support Specialist
Product Support
Autodesk, Inc.





If my post answers your question, please click the "Accept as Solution" button. This helps everyone find answers more quickly.
Active Member
doug.webb
Posts: 6
Registered: ‎03-13-2013
Message 3 of 5 (359 Views)

Re: Acquisition values not up to date

05-02-2013 06:40 AM in reply to: jason.drew

Hello Autodesk / Jason,

Has there been further development of an acquisition update feature?  I am in need of this functionality for thousands of items within my project, using AutoCAD P&ID 2013.

Please advise?.

 

Regards,

Doug

Mentor
craig.wood
Posts: 219
Registered: ‎02-20-2012
Message 4 of 5 (340 Views)

Re: Acquisition values not up to date

05-03-2013 01:01 PM in reply to: doug.webb

Hey Doug! Hope you're doing well since we met at AU.

 

I also have experienced this issue and came across a partial fix for this. It's not perfect, but it helps somewhat:

http://lazcad.com/2012/12/lazplantbrowser-0.2.01beta

 

This is a free utility developed by Rave Tam (who frequents the forum here). This utility allows for batch update commands to be run on your P&IDs, say when you leave for the day.

 

One other thing to note is that anytime you add a new P&ID property to a class after the symbols for that class have already been placed in your drawings, you often have to disconnect/re-connect it to whatever it is getting its infomation from in order to refresh the new acquisition property...very annoying. This utility helps in part, but does not refresh all of the acquisition properties in any given drawing.

 

Check it out, and good luck!

 

Craig

 

If my reply solves your problem, please mark it as 'solved.'

Active Member
djwebb
Posts: 8
Registered: ‎11-14-2012
Message 5 of 5 (310 Views)

Re: Acquisition values not up to date

05-16-2013 09:16 AM in reply to: craig.wood

Hello Craig.   Sorry for the late reply, I do appreciate you quick response, and will keep you posted on the results of my testing with your suggested solution.  Unfortunately at this point we are in the late stages of issuing 132 P&ID's and I have implemented a work around to address only those acquisition rules that I need updated.  My hesitation on implementing your proposed solution, comes from witnessing properties changing via careless Off Page connector management, segment breakers, and in one particulare case I have witnessed an equipment property that has purposely been set to override, yet something is causing it to reset back to acquire mode. 

As soon as I have a bit more time, I will investigate this solution, and post my findings here.

 

Thanks,

Doug

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD P&ID Category!

The AutoCAD P&ID forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.