AutoCAD MEP General Discussion

AutoCAD MEP General Discussion

Reply
Mentor
dtiemeyer
Posts: 403
Registered: ‎01-09-2004
Message 1 of 6 (298 Views)
Accepted Solution

Tags linked to Lights discontinue 'linking' until CAD is restarted

298 Views, 5 Replies
09-06-2012 06:38 AM

I have a bit of a weird one here. I have Light Fixtures as devices and I have a Tag that displays the 'ID' as shown in the 'Design' tab of properties. After several hours of work my electrical engineers will experience a condition where the tags no longer refelect the changes made in Properties. If a new light fixture is placed after this condition occurs, then the tag displays the 'default' value that the tags block attribute default was set to.


Restarting CAD and reopening the drawing will cause all the tags to work correctly again. This tells me the drawing is not the issue, but the underlying code is getting broken somehow.

 

Has anyone else expereinced this?  it seems to be only my electrical users, does anybody know if the code that runs the tag association is based on .NET or something else drawing data from a pool in Windows as opposed to its only memory space like the rest of AutoCAD? Might one of our (independent of CAD) lighting design software's be causing this crash in AutoCAD?

 

Any suggestions are appreciated.

 

AutoCAD MEP 2011 w/ all service packs

Striving to be a WOMBAT, Waste Of Money, Brains, & Talent...

⁞|⁞ Please use the Mark Solutions!.Accept as Solution and Give Kudos!Give Kudos functions as appropriate to further enhance the value of these forums. Thank you!

Unfortunately that does not fix it. That command does not work after this high level failure occurs. I shouldve mentioned that in the original post. Thanks Joshua.

Product Support
Joshua.Benoist
Posts: 518
Registered: ‎08-23-2006
Message 2 of 6 (274 Views)

Re: Tags linked to Lights discontinue 'linking' until CAD is restarted

09-10-2012 01:44 PM in reply to: dtiemeyer

The model may just need to be updated.  At the command line, type in OBJRELUPDATE, enter, enter again to select all and update. 

Joshua

 

 

 


______________________________________________________________

If my post answers your question, please click the "Accept as Solution" button. This helps everyone find answers more quickly!



Joshua Benoist, PE
Senior Support Specialist
Product Support
Autodesk, Inc.

Mentor
dtiemeyer
Posts: 403
Registered: ‎01-09-2004
Message 3 of 6 (272 Views)

Re: Tags linked to Lights discontinue 'linking' until CAD is restarted

09-10-2012 01:46 PM in reply to: Joshua.Benoist

Unfortunately that does not fix it. That command does not work after this high level failure occurs. I shouldve mentioned that in the original post. Thanks Joshua.

Striving to be a WOMBAT, Waste Of Money, Brains, & Talent...

⁞|⁞ Please use the Mark Solutions!.Accept as Solution and Give Kudos!Give Kudos functions as appropriate to further enhance the value of these forums. Thank you!
Product Support
Joshua.Benoist
Posts: 518
Registered: ‎08-23-2006
Message 4 of 6 (269 Views)

Re: Tags linked to Lights discontinue 'linking' until CAD is restarted

09-10-2012 01:51 PM in reply to: dtiemeyer

Oops, I was going for the reply button and clicked the Accept As Solution button.  I'm still here though.  So you mentioned some 3rd party lighting tools.  Tell us more about them.  Does this issue occur on new drawing files?  Is it specific to these files or this project?  What happens in files where you have not yet used the 3rd party lighting apps?

 

Joshua

 

 

 



Joshua Benoist, PE
Senior Support Specialist
Product Support
Autodesk, Inc.

Mentor
dtiemeyer
Posts: 403
Registered: ‎01-09-2004
Message 5 of 6 (267 Views)

Re: Tags linked to Lights discontinue 'linking' until CAD is restarted

09-10-2012 02:02 PM in reply to: Joshua.Benoist

The problem is sporatic and not reproducable, and I am not certain it is a 3rd party software, its just a hunch. The only time my users mention it is in lighting plans. And usually they are running lighting calc software simultaneously. I thought if this 'tag updating' was running off some microsoft .net or other shared dll's that one of the other programs might be making calls to a similar library and screwing things up. Ive seen it before, but I'm not sure thats what is happening. Any suggestions would be great.  AGI is the one that seems more commonly in play when this error occurs.

Striving to be a WOMBAT, Waste Of Money, Brains, & Talent...

⁞|⁞ Please use the Mark Solutions!.Accept as Solution and Give Kudos!Give Kudos functions as appropriate to further enhance the value of these forums. Thank you!
Product Support
Joshua.Benoist
Posts: 518
Registered: ‎08-23-2006
Message 6 of 6 (263 Views)

Re: Tags linked to Lights discontinue 'linking' until CAD is restarted

09-10-2012 02:06 PM in reply to: dtiemeyer

I have not seen this issue before, not here in support.  So it may be unique to that AGI software.  Our property sets and palettes do use xml and .NET pretty heavily.  It's entirely possible.  Maybe someone else out here in the forums has some experience with the AGI and similar 3rd party lighting apps...

 

Joshua

 

 



Joshua Benoist, PE
Senior Support Specialist
Product Support
Autodesk, Inc.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD MEP Category!

The AutoCAD MEP forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.

Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.