AutoCAD MEP General Discussion

AutoCAD MEP General Discussion

Valued Contributor
Posts: 69
Registered: ‎11-01-2011
Message 1 of 9 (3,429 Views)

msscript.ocx AutoCAD MEP 2012

3429 Views, 8 Replies
08-10-2012 09:33 AM

I am running Windows 7 x64 with Autodesk product that range from 2010 to 2013 on a subscription 2012 and 2013 AutoCAD mep and 2011,12,13 RME

while trying to modify settings in the Style manager for Duct routing preferences in AutoCAD MEP 2012 I receive an error message.


ERROR; There is a problem with the Script Control (msscript.ocx)

This problem may be corrected by reinstalling Internet Explorer, or by Reregistering the control.


This message appears and I am forced to go to task manager to stop the acad process to clear it out.


I have tried a repair on my computer with no positive results.

I am hoping there is a simple fix but have not seen one on any message boards


please help.


Thank you

New Member
Posts: 1
Registered: ‎08-13-2012
Message 2 of 9 (3,408 Views)

Re: msscript.ocx AutoCAD MEP 2012

08-13-2012 07:27 AM in reply to: kadmonkee8

I also have this problem and no solution suggested has worked so far. I have Windows 7, 64bit, and MEP 2011.

Valued Contributor
Posts: 69
Registered: ‎11-01-2011
Message 3 of 9 (3,406 Views)

Re: msscript.ocx AutoCAD MEP 2012

08-13-2012 07:46 AM in reply to: kadmonkee8

i was able to correct this by using the info from a previous post. see below

i did follow as written do the first one after this message then go to the next one

i did this in the sequence as shown  part 1 just do step 3 and 4 (in BOLD) after you confirm you can register the control go to Part 2 and follow the instruction as written this fixed my issue



02-24-2011 04:48 PM in reply to:MIKE_ST

Here is what I received from AutoDesk Tech support. Which it did not work for us, maybe it will for someone else.


1) The simplest and most common fix is to reboot the computer.

2) The next most common fix is to try a repair, from the Add/Remove Programs > AutoCAD MEP > Change/Edit button > Repair or Reinstall > Repair.

3) The scripting file is actually a Microsoft system file. You can try downloading the Windows Scripting components from (Note: this is for Windows XP customers)

2) Next thing to try would be a repair installation. Go into Add/Remove Programs or Programs/Features in the Control Panel, find the entry for AutoCAD MEP 2010, click the Change/Remove button, select the option to Repair.  Test to see whether the error persists and the installation repair completes.

3) The 64-bit version of Internet Explorer 7, and IE8, may be preventing it from operating.  Please follow this link to roll Internet Explorer back to IE7 32-bit.

4) Try reregistering the msscript.ocx file.  Open a command prompt in Windows (from the Start menu, select Run, type in CMD and then enter.) At the command prompt, enter regsvr32.exe msscript.ocx /u and then hit enter. You will receive a dialog box that says “DllUnregister Server in msscript.ocx succeeded.” Click OK. Still in the command prompt, enter regsvr32.exe msscript.ocx and then hit enter. You should receive a dialog box that says “DllRegisterServer in msscript.ocx succeeded.  If it does not say that, it failed to reregister.

5) The AutoCAD MEP 2011 error may be fixed by the above suggestions, though we have one other possibility.  We recently encountered that 2011 error when a user opened a file that contains electrical objects, with the desktop icon that launches AutoCAD MEP 2011 as Classic AutoCAD.  Classic AutoCAD does not have the resource modules needed to draw the electrical objects.  Check your 2011 desktop icon and see if it is launching MEP as classic AutoCAD.  look for a different desktop icon the says AutoCAD MEP US Imperial.



Product Support
Posts: 387
Registered: 08-23-2006
Re: MEP 2011 Tool Palettes (msscript.ocx)
04-08-2011 01:46 PM in reply to:jdaulton

Good news.  We have been working on this MSscript.ocx issue.

We recently discovered the cause and developed a solution.   Would you please have a look at folder: C:\Program Files (x86)\Common Files\Autodesk Shared, and verify the existence of the following files.





If missing please find the attached zip file, unzip and copy the above 3 into the above location.   Next, let's import the attached registry settings file.  To import registry, save the txt file attachment to your desktop, rename the txt file's extension to .reg, and then double click on it.  That will fix the registry.  Go ahead and test for the MSscript.ocx error to be gone.   Please let us know your impression on the above material and if this helps.  Have a great day.

Joshua Benoist, PE Senior Support Specialist Product Support Autodesk, Inc.
New Member
Posts: 1
Registered: ‎08-22-2012
Message 4 of 9 (3,356 Views)

Re: msscript.ocx AutoCAD MEP 2012

08-22-2012 10:08 AM in reply to: kadmonkee8

I am using autocad mep 2013, I am currently having this issue. I followed the steps above and this hasnt solved the script issue. when I unzip the file I notice the tbl file wont open. i get a message that says to select a program or webservice to open the tbl file. My autocad is completely usless right now and this couldnt have happened at a worse time. HELP!

Valued Contributor
Posts: 69
Registered: ‎11-01-2011
Message 5 of 9 (3,342 Views)

Re: msscript.ocx AutoCAD MEP 2012

08-23-2012 08:30 AM in reply to: fbruno1

AutoCAD MEP 2013 is a new version

not sure if it matters but some solutions wont work in newer versions (but don't hold me to that)

I would uninstall clean up any registry entries relating to that version and reinstall 2013 to possibly clear things up

Posts: 3
Registered: ‎02-24-2009
Message 6 of 9 (1,982 Views)

Re: msscript.ocx AutoCAD MEP 2012

10-01-2013 10:47 AM in reply to: kadmonkee8

Good Job Joshua!!


Works great!!!

Posts: 21
Registered: ‎09-24-2008
Message 7 of 9 (1,462 Views)

Re: msscript.ocx AutoCAD MEP 2012

12-12-2013 03:13 AM in reply to: kadmonkee8

I have tried all of the listed solutions, plus others I have found online. I have this msscript.ocx error on both MEP2012 and 2013. It happened after a Windows update. It was fixed after a restore to a previous point, but unfortunately I forgot to turn off auto update, and the problem came back overnight when the computer updated again. I wasn't able to roll back to an earlier restore point, so I was unable to draw one pipe all day. WHAT is causing this?? I thought it was IE 11, but looking back, I see others have had the problem early than the rolling out of that. Other programs that use visual basic also get this error. Today I will try a CLEAN install of all Autodesk products and see if that helps.

Anyone esle find a solution that works yet?

Posts: 5
Registered: ‎05-18-2012
Message 8 of 9 (1,334 Views)

Re: msscript.ocx AutoCAD MEP 2012

01-04-2014 01:04 AM in reply to: kadmonkee8

it helped also on Civil 3D 2014

New Member
Posts: 1
Registered: ‎02-25-2011
Message 9 of 9 (660 Views)

Re: msscript.ocx AutoCAD MEP 2012

05-16-2014 08:37 AM in reply to: kadmonkee8

Thanks! Tried re-registering the msscript.ocx module, but that didn't work. For whatever reason, the Aec32BitAppServer.dll file was missing from the Autodesk Shared folder, although the other two were there. Instead of messing around with reinstalling software, I thought I would go straight for the download routine. That worked for Civil 3D 2013 when I thought I would have to reinstall everything, so it saved me a huge amount of time!

For information, in case it means anything to anyone, the existing Aec32BitAppServer57.exe was 88KB vs 107KB for the one in the zip file.


Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD MEP Category!

The AutoCAD MEP forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.