AutoCAD Mechanical General Discussion

AutoCAD Mechanical General Discussion

Reply
New Member
mlars010
Posts: 2
Registered: ‎10-17-2011
Message 1 of 4 (638 Views)

Dimension Style Override Unresponsive

638 Views, 3 Replies
10-17-2011 04:50 PM

Hello,

 

I am using AutoCAD Mechanical 2012 (Student Edition) and need to override my base dimension style settings to include tolerances on drawings.

 

The program seems to disregard anything I do with regard to overriding the dimension style settings.  The specific tolerane desired in this example is (Upper: +0.021; Lower: 0) but I need both numbers to display to three decimals.

 

Here's how things look at my end:

 

  1. Create dimensions using my preferred generic settings
  2. 'DDIM' -> Dimension Style Manager
  3. Select current style, 'Override'
  4. Override Current Style window > Tolerances tab > Tolerance Format area > Precision: '0.000' (base setting is '0');  Method: 'Limits';  Enter appopriate Upper value and Lower value
  5. Preview window updates correctly for all changes
  6. 'OK'
  7. Dimension Style Manager: Preview of: <style overrides> still displays correctly
  8. Close Dimension Style Manager window
  9. Annotate tab: Dimension panel: Update Dimension
  10. Select object(s), press 'return' on keyboard
  11. Nohing happens - selected dimension has no tolerance and remains at original precision
  12. 'DDIM' -> Dimension Style Manager
  13. <style overrides> sill selected and Preview still looks correct (3 decimal places)
  14. 'Modify'
  15. Precision drop-down is reset to '0'

(Note: Skipping from 5 to 14 gives the same response.)

 

Here is what the command prompt returns for the Update Dimension command:

  • Current dimension style: ASME     Annotative: Yes
  • Current dimension overrides:
  •   DIMLIM         ON
  •   DIMTDEC      3
  •   DIMTOLJ       1
  •   DIMTP           0
  •   DIMTZIN        0
  • Enter a dimension style option
  • [ ANnotative/Save/Restore/STatus/Variables/Apply/? ] <Restore>: _apply
  • Select objects:

The formatting options in the Power Dimensioning tab don't allow me to show redundant zeroes (e.g. 25.000) so I cannot use that method regardless of the DIMTZIN value.  The rest I have already described.  Can anyone help me with this? 

Employee
Sridhar-Autodesk
Posts: 1,101
Registered: ‎12-18-2006
Message 2 of 4 (621 Views)

Re: Dimension Style Override Unresponsive

10-19-2011 03:08 AM in reply to: mlars010

Hi,

 

Can you uncheck " Trailing" option in DDIM>>Select the base dimenesion style>>Modify>>Primary units tab>>Zero Suppression>>Uncheck " Trailing" and verify the issue.

 

Repeat the above step for Tolerance tab too.

 

Try creating a new powerdim and enable the tolerance button.

 

powerdim.png

 

 

Thanks

 

 



Sridhar Subramani
Autodesk, Inc.
Employee
Sridhar-Autodesk
Posts: 1,101
Registered: ‎12-18-2006
Message 3 of 4 (620 Views)

Re: Dimension Style Override Unresponsive

10-19-2011 03:09 AM in reply to: Sridhar-Autodesk

Please find attached sample drawing too.

 

Thanks,

 



Sridhar Subramani
Autodesk, Inc.
New Member
mlars010
Posts: 2
Registered: ‎10-17-2011
Message 4 of 4 (607 Views)

Re: Dimension Style Override Unresponsive

10-23-2011 09:31 PM in reply to: Sridhar-Autodesk

I've been able to fix this issue by going to AMOPTIONS>Standards>Dimension Settings and setting my custom dimension style as the "Base dimension style" while leaving "Force power dimensions to use this dimension style" selected.   I can now obtain a dimension that looks like:

 

6.0000

5.0079

 

Previously I was unable to force trailing zeroes to show, regardless of options being de-selected in the DDIM window tabs.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.