AutoCAD Mechanical General Discussion

AutoCAD Mechanical General Discussion

Valued Mentor
Posts: 456
Registered: ‎04-20-2011
Message 1 of 3 (222 Views)

Dim Scale error

222 Views, 2 Replies
05-01-2012 02:48 AM

In our company we draw in model and dimension in paper - mostly because we have to deliver several different prints of the same model object. (eg. our production wants different tollerance method (limits) then our customers).


Now, on Mechanical 2012 (sp1) a drafter is having the problem that the scaling on the paperspace inconsistently takes the viewport scale or the paperspace distance. As he describes it: It can do the right scale for 11 dimensions, but the 12th would be wrong.


Now in some cases this was "user-error": centerlines and such objects were also placed in paperspace, hence the dimensions gave paperspace distances... but on the attached drawing I can reproduce the error!


The 96.4 dimension should be 48.2.


When I use the ACM "replace" option when re-dimensioning it, often I get the 96.4 again. When I delete the dimension first and re-do it... the 96.4 re-appears once every 10 tries or so.


Filter options do not allow snapping to dimensions, generally only snap to endpoint is used when dimensioning. Dimassoc is 2.


Please help... is dimassoc randomly messing up?

Posts: 483
Registered: ‎07-11-2008
Message 2 of 3 (203 Views)

Re: Dim Scale error

05-01-2012 07:46 PM in reply to: acwtzwegers



I think it may be caused by different types of snaps when you dimension the geometry. There are some types of snaps that could lead you to snap paper space points, like intersection. I have tried your drawing and tried to use "End Point" to snap it and it works fine. 

Michael Su
SQA Engineer
Please mark any response as "Accept as Solution" if it answers your question.

Valued Mentor
Posts: 456
Registered: ‎04-20-2011
Message 3 of 3 (195 Views)

Re: Dim Scale error

05-02-2012 03:36 AM in reply to: michaelsu

We use the powersnap configurations, with just "snap to endpoint"  being used for dimensioning (I think I pointed that out in my first post). However: no-one ever told me before that other snaps would not work... nor do they do so consistently either. (intersection is just as random as snap to end now I've tried it.)


However: I have only been experiencing this on drawings by a particular set of drafters (like the one included) that use a modified dwt... could it be that? (and if so: what can be done?) Can it be the user's particular choice of commands?

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.