AutoCAD Map 3D General Discussion

AutoCAD Map 3D General Discussion

Reply
Active Member
ajhayes
Posts: 8
Registered: ‎07-15-2008
Message 1 of 5 (2,156 Views)
Accepted Solution

Problemts Connecting to Microsoft Access Database

2156 Views, 4 Replies
04-30-2010 08:13 AM
Hi all,

I'm having trouble getting my microsoft access database to connect to my drawing. It has only recently started giving me problems - it always worked perfectly before.

If I attach the database as a data source, all that comes up is the name of the database with the red "X" symbol next to it. If I right click and go to properties, I choose the Microsoft Jet 4.0 OLE DB Provider. If I try the test connection, I get this vague message:
"Test connection failed because of an error in initializing provider. Unspecified Error."

I've tried moving the database from the server to my local drive to see if it was a network issue and got the same thing.

According to the microsoft website, I've got the most recent update to the Microsoft Jet 4.0.

Any thoughts on what's going wrong here?

64 bit requires a Microsoft Access Driver

 

You may need to download from Microsoft

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=13255

 

Then you just need to create a new Data Source (in Control Panel -> Data Sources -> ODBC Data Source Administrator)

 

Check this out for more info:

http://gisexchange.typepad.com/blog/2010/08/odbc-on-x64-operating-systems.html?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+GisExchange+%28GIS+Exchange%29

*Murph
Message 2 of 5 (2,156 Views)

Re: Problemts Connecting to Microsoft Access Database

04-30-2010 08:37 AM in reply to: ajhayes
Try logging on to the workstation as another user and see if it works.

I have a client that is having the same trouble, a system restore even
failed for him.


--

Murph
http://map3d.wordpress.com/


"ajhayes" wrote in message news:6383630@discussion.autodesk.com...
Hi all,

I'm having trouble getting my microsoft access database to connect to my
drawing. It has only recently started giving me problems - it always worked
perfectly before.

If I attach the database as a data source, all that comes up is the name of
the database with the red "X" symbol next to it. If I right click and go to
properties, I choose the Microsoft Jet 4.0 OLE DB Provider. If I try the
test connection, I get this vague message:
"Test connection failed because of an error in initializing provider.
Unspecified Error."

I've tried moving the database from the server to my local drive to see if
it was a network issue and got the same thing.

According to the microsoft website, I've got the most recent update to the
Microsoft Jet 4.0.

Any thoughts on what's going wrong here?
Distinguished Contributor
JohnPM
Posts: 658
Registered: ‎04-29-2007
Message 3 of 5 (2,156 Views)

Re: Problemts Connecting to Microsoft Access Database

04-30-2010 06:48 PM in reply to: ajhayes
This is my cheat sheet for connecting to a 2007 Access database.


Go to control panel/administrative tools
Select data source ODBC
ADD a new data source
Select proper driver Microsoft Access Driver [* .mdb, *.accdb] 2007 (12.6423 aceodbc.dll)
Name your data source
Hit OK, hit OK again to exit ODBC database administrator
Go to task pane in Map
Select configure data source
Give your Data Source a Name and Hit OK
Now go to connection tab in data link properties
Select your named data source that you created with ODBC Administrator
Test connection (has failed to give positive even though connected)
Hit ok
Now select attach in task pane
Select your named data source that was configured in the task pane
Navigate to database source using "all files"
Select your 2007 database by name and Hit OK
Highlight your database name for selection to confirm
Hit OK
You should be completed and database should show in task pane.
Valued Contributor
sam.cutbirth
Posts: 63
Registered: ‎10-18-2008
Message 4 of 5 (1,657 Views)

Re: Problemts Connecting to Microsoft Access Database

12-05-2011 12:57 PM in reply to: ajhayes

I'm not having any luck with databases either.  I just installed Civil3D 2012 on Windows 7 64-bit.

Create new ODBC connection..  FAIL

I even tried it on my 32-bit installation... NOPE!

 

I guess the process of connecting to .mdb just wasn't complicated enough.

Valued Contributor
edwa8511
Posts: 52
Registered: ‎11-21-2008
Message 5 of 5 (1,634 Views)

Re: Problems Connecting to Microsoft Access Database

12-07-2011 09:28 AM in reply to: sam.cutbirth

64 bit requires a Microsoft Access Driver

 

You may need to download from Microsoft

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=13255

 

Then you just need to create a new Data Source (in Control Panel -> Data Sources -> ODBC Data Source Administrator)

 

Check this out for more info:

http://gisexchange.typepad.com/blog/2010/08/odbc-on-x64-operating-systems.html?utm_source=feedburner...

Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.