AutoCAD Map 3D General Discussion

AutoCAD Map 3D General Discussion

Reply
Member
jon_s
Posts: 3
Registered: ‎09-14-2010
Message 1 of 2 (178 Views)

Problem with feature labels w/ 2012

178 Views, 1 Replies
05-01-2012 09:26 AM

Hello-

I'm new to the mapping world of the Autodesk products, and I apologize if I'm missing something basic, but I'm pretty much stuck. I'm running Civil3d 2012 64bit , but since this is a feature mapping issue I figured it is more appropriate to post this in the Map3D section. 

 

I have connected my drawing to a PostgreSQL+PostGIS database to pull in a couple test features. The points come in fine, and I have created a join between the spatial table and another data table (both housed within the same database). When I view the data table, the join seems to be working correctly (i.e., I can see the linked columns). 

 

The problem comes with trying to display the data to my map. I'd like to add a numeric column to my map. I go into the style editor and add a new feature label. I use the "Text Content" pop-up menu to select the table column I'd like to use (in this case, an elevation). When I select it, the software autmoatically adds the expression "ToString("LEVEL|Elev")" where LEVEL is my table name, and Elev is the column. When I close the style editors, the map simply posts "Text" instead of displaying the value.

 

Am I missing something? Is there another way I should be posting numeric data to my map? I assume a feature label is the way to do this, but if there's a better method to post text to a feature I'm all for it.

 

Any help would be greatly appreciated.

*Expert Elite*
Alfred.NESWADBA
Posts: 9,216
Registered: ‎06-29-2007
Message 2 of 2 (147 Views)

Re: Problem with feature labels w/ 2012

05-03-2012 12:53 PM in reply to: jon_s

Hi,

 

>> the software autmoatically adds the expression "ToString("LEVEL|Elev")"

I haven't used PostXXX as database, I jsut connected a shape and tried to get the result like you mentioned, that the software converts a field you select automatically into a formula. I never saw that.

 

To make sure I tried to ToString-function and get at least a difference to your syntax, because the fieldname has NOT to be enclosed within quotes, so I would try to modify the formula to

ToString(LEVEL|Elev)

...no quotes anywhere within this formula.

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.