AutoCAD Map 3D General Discussion

AutoCAD Map 3D General Discussion

Active Member
Posts: 10
Registered: ‎09-24-2012
Message 1 of 2 (571 Views)

PostGIS editing using AutoCAD Map

571 Views, 1 Replies
09-24-2012 05:09 AM


I am a user of LocalGIS, a Spanish GIS that works with a PostGIS database.

My objective is to edit the layers stored in PostGIS directly using the AutoCAD Map. The problem is that after adding a new feature (POINT) in AutoCAD, I try to open the layer in my GIS and I get an error. I think that something is missing in the way I am doing this cause the GEOMETRY column in the PostGIS table is filled with a WKB format string and the one created in AutocadMAP is so different from the ones previously stored in the database.

I explain the steps I am following just in case something is missing or wrong.

1. The PostGIS database table is as follows before starting the process (check the GEOMETRY column):

2. I load my layer in AutoCAD Map (getxo_semaforo_puntos). I define the layer as the coordinate system UTM30-ED50 which is the coordinate system I use for all my layers:

3.I add a new point by clicking on "New Feature-->Point"

4. After clicking on the "check-in" button to store the changes in the PostGIS database, the GEOMETRY stored for the new registry is quite different from the previous points. In fact, the digits from 3rd to 10th (8 digits) stand for the GEOMETRY type of the feature stored (point,linestring,polygon,multipolygon, geometry collection...) and  00000002 (POINT) is stored for all the features previously in the database and in this case it is stored as 00000008, which I don’t exactly know what it is.

5. After I try to open this layer in my GIS I get an error (it doesn’t understand the new GEOMETRY). Even after changing the 00000008 by 000000002 I get the error, so this is not the problem I guess.

I don’t know what could be happening but I really need to get this PostGIS edition from AutoCAD!


Active Member
Posts: 10
Registered: ‎09-24-2012
Message 2 of 2 (543 Views)

Re: PostGIS editing using AutoCAD Map

09-25-2012 04:18 AM in reply to: agmartin

Problem solved.

The thing is that when creating a new feature from Autocad MAP the EWKB generated in the GEOMETRY column of the postgis table has the SRID=-1 where all the other objects had SRID=23030. When reading the data from my GIS in the select query i called ST_GeomFromWKB("table"."GEOMETRY", 23030) function and everything worked!



Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.