AutoCAD Map 3D General Discussion

AutoCAD Map 3D General Discussion

Reply
Distinguished Contributor
lissaucad
Posts: 171
Registered: ‎10-08-2007
Message 1 of 4 (905 Views)

Plotting feature lines in black and white and not color in Map3D 2014

905 Views, 3 Replies
08-14-2013 05:43 PM

I'm new to Map 3D and not to Civil 3D.  I connected to a roads and streams shp file from a ArcGIS directory.  Everything came in great and I even was able to get everything named all at once from the attibute directory.  The problem is that the features seem to only plot in the colors that I see them as.  If I change them all to black, then I see can't see them at all.  I have been spening the past 3 hours trying to get them to jus plot black.  We also have to stick with stb plot styles in our department.

*Expert Elite*
Alfred.NESWADBA
Posts: 9,403
Registered: ‎06-29-2007
Message 2 of 4 (887 Views)

Re: Plotting feature lines in black and white and not color in Map3D 2014

08-15-2013 12:38 AM in reply to: lissaucad

Hi,

 

>> The problem is that the features seem to only plot in the colors that I see them as

Those colors are truecolors by default, but CTB/STB-files only work with AutoCAD colorindex (colors from 1 to 255).

So the colors you select in the style-dialog should be the colors to be used for plot.

 

>> If I change them all to black, then I see can't see them at all

Change your AutoCAD background color to white and all is ok (command _OPTIONS, tab "Display", button "Colors") ... at least for the layout.

 

>> We also have to stick with stb plot styles in our department.

You can, but only for AutoCAD geometry, not for the MapFeature-objects.

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Product Support
phil_borycens
Posts: 202
Registered: ‎10-25-2011
Message 3 of 4 (851 Views)

Re: Plotting feature lines in black and white and not color in Map3D 2014

08-23-2013 09:13 AM in reply to: lissaucad

Welcome to the club! :smileywink:

 

Yes, as Alfred brought out, CTB/STB files only control standard AutoCAD objects; GIS data connections are unaffected by plot style tables. GIS connection styles are controlled in the Style Editor for the FDO-connected layer.

 

An option for you is to MAPIMPORT your GIS data so that the map features become standard AutoCAD objects. You can import them with their attributes in tact (it's an option in the Import wizard), but you'll lose the 'live' connection to GIS.



Phil Borycens
*Expert Elite*
Murph
Posts: 2,061
Registered: ‎11-13-2006
Message 4 of 4 (844 Views)

Re: Plotting feature lines in black and white and not color in Map3D 2014

08-24-2013 06:44 AM in reply to: lissaucad

lissaucad wrote:

I'm new to Map 3D and not to Civil 3D.  I connected to a roads and streams shp file from a ArcGIS directory.  Everything came in great and I even was able to get everything named all at once from the attibute directory.  The problem is that the features seem to only plot in the colors that I see them as.  If I change them all to black, then I see can't see them at all.  I have been spening the past 3 hours trying to get them to jus plot black.  We also have to stick with stb plot styles in our department.


One option is change your background color to white, use the options command and on the display tab. I always set my background color in modle space to white when I know I'm creating a map to plot out. It gives me the WYSIWYG for my project.

Murph
Supportting the troops daily.
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are You Going To Be @ AU 2014? Feel free to drop by our AU topic post and share your plans, plug a class that you're teaching, or simply check out who else from the community might be in attendance. Ohh and don't forgot to stop by the Autodesk Help | Learn | Collaborate booths in the Exhibit Hall and meet our community team if you get a chance!