AutoCAD Map 3D General Discussion

AutoCAD Map 3D General Discussion

Reply
Valued Mentor
engrtech
Posts: 765
Registered: ‎05-05-2008
Message 1 of 29 (921 Views)

Mr. Sid Image Shifting

921 Views, 28 Replies
04-19-2013 11:06 AM

I have a Mr. Sid image that loads correctly in the model space (see screenshot). It was inserted using MAPIINSERT. In my layout, however, the image has shifted as shown in the attached screenshot. When I do a print preview, the image has shifted again, also shown in a screen shot. 

 

Why is the image shifting at all and why is it different between the layout and print preview?

IDSP 2015
Windows 8.1 Pro 64-bit
8GB RAM
New Member
kevinreed2
Posts: 2
Registered: ‎02-06-2007
Message 2 of 29 (907 Views)

Re: Mr. Sid Image Shifting

04-19-2013 11:28 AM in reply to: engrtech

I feel like ive had this problem before, either with a sid or with the arcgisonline addon that displays tiled map services.  i remember feeling like it was a graphics card issue.  Does the image shift differntly when you zoom in and out?  maybe try turning harware aceleration on and off to see if it makes a difference.  sorry i cant help much, i think my fix was to just unload the tile service or sid and use a geotiff. 

*Expert Elite*
Alfred.NESWADBA
Posts: 9,608
Registered: ‎06-29-2007
Message 3 of 29 (867 Views)

Re: Mr. Sid Image Shifting

04-20-2013 06:09 AM in reply to: engrtech

Hi,

 

>> It was inserted using MAPIINSERT

Does that happen with boh Civil3D versions? 2012 and 2013?

Have you tried to not reference the images with _MAPIINSERT, but instead with _MAPCONNECT?

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Valued Mentor
engrtech
Posts: 765
Registered: ‎05-05-2008
Message 4 of 29 (851 Views)

Re: Mr. Sid Image Shifting

04-22-2013 05:38 AM in reply to: Alfred.NESWADBA

alfred.neswadba wrote:

Hi,

 

>> It was inserted using MAPIINSERT

Does that happen with boh Civil3D versions? 2012 and 2013?

Have you tried to not reference the images with _MAPIINSERT, but instead with _MAPCONNECT?

 

- alfred -


I just checked in 2012 and it also is happening. I never use FDO for images because it's a pain to deal with, but that's another discussion. 

IDSP 2015
Windows 8.1 Pro 64-bit
8GB RAM
*Expert Elite*
Alfred.NESWADBA
Posts: 9,608
Registered: ‎06-29-2007
Message 5 of 29 (848 Views)

Re: Mr. Sid Image Shifting

04-22-2013 06:06 AM in reply to: engrtech

Hi,

 

>> I never use FDO for images

It might be interesting to at least try it as test ... just to know if you have the shifting also with that type of referencing.

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Valued Mentor
engrtech
Posts: 765
Registered: ‎05-05-2008
Message 6 of 29 (840 Views)

Re: Mr. Sid Image Shifting

04-22-2013 07:23 AM in reply to: Alfred.NESWADBA

alfred.neswadba wrote:

Hi,

 

>> I never use FDO for images

It might be interesting to at least try it as test ... just to know if you have the shifting also with that type of referencing.

 

- alfred -


FDO is horrible from a user standpoint regarding images. I shouldn't have to refresh the layer every time I zoom or pan. I constantly zoom and pan while working and adding a step like that is just horrible UI design. Then you have the issue of having the MAPWSPACE pallet up just for a single item. I don't want to have that open unless I'm working with our ArcSDE, which I try to avoid as often as possible. MAPIINSERT is great because it loads the entire image into memory and makes navigating the modelspace very snappy. 

 

This shifting is happening in a rotated viewport where the UCS>3 Point method was used. The shifting doesn't occur when the UCS hasn't been changed. This doesn't happen with GeoTIFFs, just with the Mr. Sid images.

IDSP 2015
Windows 8.1 Pro 64-bit
8GB RAM
*Expert Elite*
Alfred.NESWADBA
Posts: 9,608
Registered: ‎06-29-2007
Message 7 of 29 (832 Views)

Re: Mr. Sid Image Shifting

04-22-2013 08:14 AM in reply to: engrtech

Hi,

 

sorry, I never told you that you have to use FDO in the future. I just wanted to know if the problem also exists when the raster-file is referenced via FDO too (as that might be an info for isolating the problem, or at least to come more close to the source of the problem)

 

>> Then you have the issue of having the MAPWSPACE pallet

You don't have to have the MAPWSPACE open :smileywink:

 

>> This doesn't happen with GeoTIFFs, just with the Mr. Sid images.

So that might be your solution then (to convert the images to TIFF)?

 

>> This shifting is happening in a rotated viewport where the UCS>3 Point method was used

And after rotating the UCS have you done _PLAN or what was the command that rotates the view?

I can't reproduce it (with C3D2013, my SID-files) using:

  -   within the viewport _UCS 3P .... and then _PLAN to current ucs

  -   rotating the complete viewport in modelspace

  -   using northarrow-functionality (MAPINSERTPLE)

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Valued Mentor
engrtech
Posts: 765
Registered: ‎05-05-2008
Message 8 of 29 (829 Views)

Re: Mr. Sid Image Shifting

04-22-2013 09:00 AM in reply to: Alfred.NESWADBA

alfred.neswadba wrote:

Hi,

 

sorry, I never told you that you have to use FDO in the future. I just wanted to know if the problem also exists when the raster-file is referenced via FDO too (as that might be an info for isolating the problem, or at least to come more close to the source of the problem)

 

>> Then you have the issue of having the MAPWSPACE pallet

You don't have to have the MAPWSPACE open :smileywink:

 

>> This doesn't happen with GeoTIFFs, just with the Mr. Sid images.

So that might be your solution then (to convert the images to TIFF)?

 

>> This shifting is happening in a rotated viewport where the UCS>3 Point method was used

And after rotating the UCS have you done _PLAN or what was the command that rotates the view?

I can't reproduce it (with C3D2013, my SID-files) using:

  -   within the viewport _UCS 3P .... and then _PLAN to current ucs

  -   rotating the complete viewport in modelspace

  -   using northarrow-functionality (MAPINSERTPLE)

 

- alfred -


I did the UCS/Plan route. I stopped using the automatic north arrow as it's causing other issues with viewports that are locked still panning to 0,0. As to switching to a TIFF instead of the Sid image, that's not really a solution in my case. The Mr. Sid image is for our entire county and is 2.5GB in size. Mr. Sid images are known for their great compression and if I have to convert that to a TIFF the file would be massive in size. It's already huge as a Sid image, I couldn't image how large it'd be as a TIFF. 

IDSP 2015
Windows 8.1 Pro 64-bit
8GB RAM
Valued Mentor
engrtech
Posts: 765
Registered: ‎05-05-2008
Message 9 of 29 (812 Views)

Re: Mr. Sid Image Shifting

04-22-2013 12:00 PM in reply to: engrtech

I just checked this out in 2014 and it's still happening. 

IDSP 2015
Windows 8.1 Pro 64-bit
8GB RAM
Distinguished Contributor
nkg2
Posts: 110
Registered: ‎11-20-2008
Message 10 of 29 (780 Views)

Re: Mr. Sid Image Shifting

04-25-2013 10:39 AM in reply to: engrtech

Not to sound ignorant but could it be wrong based on printer setup for the layout tabs? 

Autodesk 2015 Infrastructure Design Suite - Premium
Windows 7 Professional, x64, Intel Xeon W3350 3.07GHz, 12GB Ram, NVidia Quadro 4000
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.