AutoCAD Map 3D General Discussion

AutoCAD Map 3D General Discussion

Reply
New Member
2 Posts
1 Kudo
Registered: ‎01-03-2012
Post 1 of 3

Map3D Connection Failure to PostgreSQL / Postgis (Linux Host)

529 Views, 2 Replies
05-31-2013 12:25 PM

I would like to connect a Map3D drawing to a PostgreSQL/PostGIS database hosted on a linux server on my network.  In the past I have successfully connected to PostgreSQL/PostGIS when the server/db is running on the same Windows box where I am using AutoCAD.  I've been able to do this with several combinations of Windows (XP/7/7x64)/PostgreSQL(8.4/9.1)/PostGIS (1.5/2.0) and AutoCAD Map (2013). 

 

I have even been able to connect from one Windows PC running AutoCAD Map to a PostGIS database hosted on another Windows machine on the network, but not to a database hosted by a Linux server.  When I try this from an XP workstation, the application (ACAD) immediately crashes without warning (this happens after I enter the connection information and try to "login").  On Windows 7, the application crash is almost as immediate, but it at least gives me an exit code error "FATAL ERROR: Unhandled e06d7363h Exception at..."

 

I've tried to view the postgres logs on the db server.  I usually get one of these for each failure:

2013-05-31 10:53:42 EDT LOG:  could not accept SSL connection: Connection reset by peer

 

I've tweaked the postgres file (pg_hba.conf) to allow non-ssl/ssl/etc to make sure that I don't have problems there.  In fact, I have other GIS apps on the AutoCAD workstation that I use to test the PostGIS connectivity prior to trying AutoCAD.  I've looked for other things like Antivirus/firewall that might be contributing, but I've come up empty.  I've also tried using the newer "OGR FDO" providers from osgeo.org.  I get the same behavior with those.

 

In short, has anyone been able to connect AutoCAD Map 3D 2013 to a non-Windows PostgreSQL/PostGIS host?  If so, can you share any advice/tips/experience that might lead me to a successful connection?

 

Thanks for your time,

 

-Jeffrey

 

Product Support
202 Posts
11 Kudos
Registered: ‎10-25-2011
Post 2 of 3

Re: Map3D Connection Failure to PostgreSQL / Postgis (Linux Host)

06-04-2013 08:11 AM in reply to: tech

We have another customer who is crashing like you are. They are using Postgres 9.1.9 and PostGIS 1.5.8, also on a Linux server. We have suggested that they try using AutoCAD Map (or Civil) 3D 2014 to make this connection. Have you tried that? We also have a ticket open with Development to investigate this further.



Phil Borycens
New Member
2 Posts
1 Kudo
Registered: ‎01-03-2012
Post 3 of 3

Re: Map3D Connection Failure to PostgreSQL / Postgis (Linux Host)

07-01-2013 06:54 AM in reply to: tech

I wanted to follow up on this topic after trying the suggestion for Autodesk support.  I was reluctant to upgrade my version of AutoCAD Map just to test this, but my curiousity eventually got the best of me.  I can report that on the same machine where I had trouble connecting AutoCAD Map 2013 to a PostGIS  layer hosted by a linux server, I can connect AutoCAD Map 2014 without error messages!

 

I haven't done any work with the map/model yet, but at least I'm connected!  Too bad I can't just waltz around to my other statios and do the same.  Something about upsetting their work flow for the purpose of enabling a feature that they aren't currently using ... what's wrong with people?

 

Thanks for your response and for your help!  Any way to supply a patch that would give me the same success with 2013?  (I can wish, can't I?)

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post