AutoCAD Map 3D General Discussion

AutoCAD Map 3D General Discussion

Reply
Valued Contributor
Gary_Braun
Posts: 100
Registered: ‎09-25-2007
Message 1 of 8 (776 Views)

Map 2013 Vanishing Act

776 Views, 7 Replies
01-24-2013 10:54 AM

We've had a few users noticing problems with entities becoming invisible in Map 2013. This has happened in a couple of different ways: 1) copy and pasting a block with editable attributes from one drawing into another can make objects disappear; 2) using Dview -> Twist to change the drawing rotation usually causes objects to disappear. The entities are still in the drawing database and can be selected, but they aren't visible and can't be picked by the mouse etc.
If I save and reopen the drawing, or wblock everything out to a new drawing and open it, then they all show up as they should, but that is a bit of a pain. So has anyone else experienced this or have any idea what might be going on.

BTW, this is happening on some older Windows XP machines as well as some newer Win7 systems.

*Expert Elite*
Alfred.NESWADBA
Posts: 8,982
Registered: ‎06-29-2007
Message 2 of 8 (744 Views)

Re: Map 2013 Vanishing Act

01-26-2013 03:20 AM in reply to: Gary_Braun

Hi,

 

>> copy and pasting a block with editable attributes from one drawing into another can make objects disappear

I know 2 options where that should/could not work (has phenomens like you described):

  • a blockdefinition with that name of the block(s) you like to copy already exists in the destination drawing, but have other units, or other base geometry, at least have other defintiions. Then the copy of your insertions will automatically represent itself in the "new style" (as it's defined in the destination drawing). Depending on zooming or depending on other layersettings it may look like "disappeared".
  • it where dynamic blocks then they based on a blockdefinition with a valid blockname, but displayed as unnamed blocks (internally in AutoCAD they get names like *U111, *U112, ... ). And if you now copy an insertion "*U111" to another drawing it also may be possible that *U111 as definition already exists there ... and now continue reading again in the paragraph above :smileywink:
  • you have annotative blocks (e.g. defined for beeing displayed in 1:100 and 1:200)  and while inserting you have a scaling active (in the destination drawing) that is not one of the assigned annoscales for beeing active (e.g. 1:500)

>> using Dview -> Twist to change the drawing rotation usually causes objects to disappear

What objects do disappear (select them and let us know what the property window or the LIST-command gives you as info about the object type). At least it might also be annotative elements and with _DVIEW in a viewport you have set the viewport scale to another scale then before _DVIEW.

 

Anyway the above suggestions are only valid for some very special cases. It might be helpful if you have a situation that you can reproduce, one drawing with elements to copy from and another drawing where the issue with disappearing happens when you paste geometry (or the drawing when objects disappear after command _DVIEW) ==> upload these drawings.

 

As long as you get these errors you should run _AUDIT quite often (or open the drawings with command _RECOVER instead of _OPEN). It might be a defect drawing and anytime you insert that special drawing into the current one you duplicate the defect (it's like a virus then). So if you get errors in your drawing remember back to what you did a few commands before to isolate the problem.

 

Good luck, - alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Valued Contributor
Gary_Braun
Posts: 100
Registered: ‎09-25-2007
Message 3 of 8 (713 Views)

Re: Map 2013 Vanishing Act

01-30-2013 01:47 PM in reply to: Alfred.NESWADBA

The behaviour I've mentioned has shown up on a few machines since moving to Map 2013, but so far it has been intermittent and I've had difficulty reproducing it today.

 

In answer to your reply Alfred, this has happened in situations where a block was already defined in the target drawing AND has also happened in cases where the block was not predefined in the target drawing. We don't use dynamic or annotative blocks, these are just the standard, old fashioned attributed blocks.

 

And it isn't just the block that disappears either, in both scenarios all objects in the drawing disappear. This includes all blocks, hatches, lines, polylines etc for the entire drawing database. I can select anything I want using filters or Quick Select, but I can't see them and I can't select them by mouse. Again, our drawings are quite basic, so annotation scales are irrelevant.

 

I would suspect a hardware or graphics driver problem, except that, as I mentioned, we've seen it on different machines, with different specs and different OS's.

*Expert Elite*
Alfred.NESWADBA
Posts: 8,982
Registered: ‎06-29-2007
Message 4 of 8 (707 Views)

Re: Map 2013 Vanishing Act

01-30-2013 11:07 PM in reply to: Gary_Braun

Hi,

 

>> using Dview -> Twist to change the drawing rotation usually causes objects to disappear.

Ok, next shot.

In case of using objects based on the AEC-functionality, like Civil3D has, like ACA or MEP has there is functionality included that might let objects be invisible in 3D-views and visible in 2D/plan-view. So my question is: was the drawing, from where you copy objects from, created/modified by one of these verticals?

 

And if you have the problem with copy/pastse next time ==> try to wblock this entities into a new drawing, then open this drawing and see if the entities now also disappear when using _DVIEW.

If yes ==> upload this new drawing (and try _AUDIT to see if AutoCAD finds any errors)

If no ==> copy now from this new drawing the entities in your destination drawing.

 

Good luck, - alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Valued Contributor
Gary_Braun
Posts: 100
Registered: ‎09-25-2007
Message 5 of 8 (677 Views)

Re: Map 2013 Vanishing Act

02-08-2013 01:29 PM in reply to: Gary_Braun

This has been a bit frustrating, but I think I've finally managed to reliably reproduce the error, at least in the case of the attributed blocks.

 

If I have a standard attributed block and single click on an attribute to activate its grip, then grab the attribute by the grip in order to move it, use the mouse wheel to zoom out and then back in to a different location in the drawing and drop the attribute there, the block I am editing will disappear. If I then do a regen or zoom extents, the rest of the drawing also disappears.

 

Still working on a reliable way to reproduce this using the dview twist command.

 

-gb

Distinguished Contributor
ceethreedee.com
Posts: 173
Registered: ‎10-04-2012
Message 6 of 8 (531 Views)

Re: Map 2013 Vanishing Act

06-11-2013 05:57 PM in reply to: Gary_Braun

Well i Confirm I have similar problems. 

 

In a viewport in paperspace, if I have zoom in out with my mouse. Map objects appear. If I set my annontation scale from my standard list. My Objects dissappear!!

 

Anyone solution?

Civil 3D 2014 (SP2)
Win 7 Pro x64 -DELL Precision Workstation T3500
Intel Xeon 3.3GHz (w3680) -24Gb Ram
NVIDIA Quadro 2000 (1GB)
ceethreedee.com
*Expert Elite*
Alfred.NESWADBA
Posts: 8,982
Registered: ‎06-29-2007
Message 7 of 8 (522 Views)

Re: Map 2013 Vanishing Act

06-11-2013 11:58 PM in reply to: ceethreedee.com

Hi,

 

>> if I have zoom in out with my mouse. Map objects appear.

In case they disappeared: have you tried to just switch off and back on the GIS-layer in the Map3D-workspace?

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Valued Contributor
Gary_Braun
Posts: 100
Registered: ‎09-25-2007
Message 8 of 8 (514 Views)

Re: Map 2013 Vanishing Act

06-12-2013 07:58 AM in reply to: ceethreedee.com

I'm not sure if your issue is exactly the same as mine or not, but in my case the resolution appears to have been turning on hardware acceleration. I had a parallel thread going on the Autocad group and had mentioned over there that this was resolved - sorry for not following up here as well.

 

http://forums.autodesk.com/t5/AutoCAD-2013-2014-DWG-Format/2013-Disappearing-Blocks/td-p/3905584

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.