AutoCAD Map 3D General Discussion

AutoCAD Map 3D General Discussion

Reply
Active Contributor
48 Posts
0 Kudos
Registered: ‎07-20-2011
Post 1 of 3

Instability in Map 3D 2012 with Oracle FDO provider

340 Views, 2 Replies
04-23-2012 10:21 PM

Is anyone using this provider without issue? I kept getting random errors while editing features like:

 

- failed to save edit set

 -feature source is disconnected

- failed to describe class

- item "layer name" not found in collection

- SchemaName: LayerName (304). Rev #<1>

 

In every instance I am absolutely connected to Oracle. Editing features typically works the first time I setup the drawing's connection. However after saving and reopening the drawing the issues sometimes, not always surface. 

 

This works 100% stable in Map 3D 2010 but I unfortunately need the ENHANCED styling that Map 2012 provides. 

 

My setup:

 

Windows 7 64bit

4gb ram

Oracle 11gR1 64bit client

Map 3d 2012 64bit

 

 

Valued Mentor
434 Posts
74 Kudos
Registered: ‎10-10-2003
Post 2 of 3

Re: Instability in Map 3D 2012 with Oracle FDO provider

05-16-2012 06:34 PM in reply to: tmblackflag

Yes, you are not alone.  This occurs in 2013 (Map 3D and AIMS) too.

I have been testing Autodesk FDO for Oracle and SL-KING FDO for Oracle and found that the Autodesk FDO for Oracle has some significant instabilities, especially over 100 users.  I've switched to SL-KING FDO but there are some limitations with Themeing etc.

 

The Autodesk FDO for Oracle definitely needs some tweaking, if not some serious re-work for both Autodesk Map 3D 2012 and 2013 as well as Autodesk Infrastructure Map Server 2012 and 2013.

 

 

Active Contributor
48 Posts
0 Kudos
Registered: ‎07-20-2011
Post 3 of 3

Re: Instability in Map 3D 2012 with Oracle FDO provider

05-16-2012 06:51 PM in reply to: tmblackflag

thank you Gordon.

 

I recently opened a ticket with Autodesk. They said my errors were linked to a change request that is fixed but not due out until their next patch which they have no date for.

 

They advised me that these issues are fixed in 2013 so I upgraded and have had good results so far. However my user group is only about 7 so I  would probably not encounter some of the issues you are having. 

 

 

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post