AutoCAD Map 3D General Discussion

AutoCAD Map 3D General Discussion

Reply
Valued Contributor
chierchio
Posts: 85
Registered: ‎05-03-2009
Message 1 of 1 (231 Views)

Annotation Text not working

231 Views, 0 Replies
02-16-2011 11:13 AM

I have been trying to extract annotation information from Object data, but the label doesnt' get much past 132 characters before turning to jibberish.

 

I tried linking the objects to a database with the information, but the annotation is not pulling the information from the attached database. I thought it might be due to the length of the information, but I switched to a much smaller field in the linked template, but no success. It just keeps placing the tag from the mappanntext object, no data is imported.

 

I am able to pull the data from the object data using GeoTools and I get the full string, without kanjii characters at the end of it, so I am of mind that the mapanntext object has a limitation where I cannot extract the data (over 132 characters). I also tried entering over 132 characters in the attached OD table, but it did not allow me to add information beyond this amount. Its 'a bit odd, because I was able to import over this amound from a shape file using the mapimport command.

 

My questions:

1. Is there a character limit on an object data table?

2. Have others tried to annotate map objects using a linked database as the source of information and been successful?

 

I am running Civil 3D 64 bit on Windows 64 bit and using a SQLite datasource.

 

Thanks,

 

Chris

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.