AutoCAD LT General Discussion

AutoCAD LT General Discussion

Reply
Mentor
katie1994
Posts: 198
Registered: ‎06-17-2008
Message 1 of 6 (2,016 Views)

AutoCAD LT How to stop drawings from opening in separate windows using Windows 7

2016 Views, 5 Replies
01-10-2012 01:31 PM

This just started happening after I downloaded DWG TruViewer. I am working on LT 2008 using Fusionware on a MacPro. I needed the viewer to convert newer drawings from an architect. Now, when I double click on a drawing in Explorer a separate AutoCad window opens for each drawing I need open. I prefer to just go up to Window>and click on the one I need at that time, especially if I have several to switch between because it is easier to see the file name I want.

 

SDI is set to 0

Taskbar is set to 0

Relaunched the program

 

I can't open files using File>Open because the program crashed each time and Autodesk is not issuing anymore fixes for 2008.  (Yes, we should upgrade but there is no money budgeted)

 

I followed a suggestion in another post to right-click on any .dwg file and go to Properties>General>Change> and select the AutoCad LT launcher as the preferred program

 

Since I am in Window 7 instead of XP the File Types tab has been removed from Folder Options  so I can't fix it that way, as suggested.

 

So, why did this change? FYI that stupid TruViewer made lots of unnecessay changes to my AutoCad and Explorer programs that I am still trying to sort out like changing the file icon and hiding the file extensions. Are they trying to make it hard to find files or what?

 

And next, how can I reset the default so that double clicking on a .dwg in Explorer opens in already open AutoCad window? Thanks for any advice is solving this. And please, don't assume I am a system administrator and understand what a lisp is, phrase your suggestions at a 1st grade level.

*Expert Elite*
pendean
Posts: 23,722
Registered: ‎11-06-2003
Message 2 of 6 (2,002 Views)

Re: AutoCAD LT How to stop drawings from opening in separate windows using Windo

01-11-2012 09:40 AM in reply to: katie1994

Best practice is to always open the inteded program then open the file from within: even in 2008, OPEN (and other program's Open pop-ups) all pretty much behave and look like Windows Explorer. Not much you cannot do in there.

 

But... since you asked, you issue has nothing to do with LT2008 and a lot to do with Windows and what the viewer did by hijacking the DWG format.

 

Windows Explorer (any version, including Win7)

Select a DWG, right-click, select OPEN WITH then select CHOOSE DEFAULT PROGRAM

In the new Window Pop-up, ensure the ALWAYS USE THE SELECTED PROGRAM.... is checked

Select the AutoCAD DWG Launcher then Click on the OK button.

 

The DWG file will open in the Autodesk application last used (may or may not be what you want).

 

Now, launch AutoCAD (not the viewer), open a file, pan and zoom around, then SAVE and CLOSE. now Close AutoCAD.

 

Restasrt your PC.

 

In Windows Explorer, double-click on a single DWG file and your desired 2008 should open the file. Now it should behave normally unless Windows still thinks another program is in control.

Dean Saadallah Blog | Facebook | Google+ | Twitter | PINS
Mentor
katie1994
Posts: 198
Registered: ‎06-17-2008
Message 3 of 6 (1,987 Views)

Re: AutoCAD LT How to stop drawings from opening in separate windows using Windo

01-12-2012 01:24 PM in reply to: pendean

I have already tried that and it has no effect, multpiple windows still open. There are 4 options for the program to use:

2 AutoCADD lauchers

1 AutoCADD LT launcher

1 TruView launcher

 

I chose the LT since that is the program I use.

 

Can you explain your last comment? Double clicking is how I always open a dwg.

*Expert Elite*
pendean
Posts: 23,722
Registered: ‎11-06-2003
Message 4 of 6 (1,979 Views)

Re: AutoCAD LT How to stop drawings from opening in separate windows using Windo

01-12-2012 01:57 PM in reply to: katie1994

You have two LAUNCHER programs? I only have one with multiple AutoCAD versions plus the viewer.

 

The ultimate fix is the most painful: remove LT and the viewer, install the Viewer first then LT last. Many had had luck just repair reinstalling LT.

Dean Saadallah Blog | Facebook | Google+ | Twitter | PINS
Mentor
katie1994
Posts: 198
Registered: ‎06-17-2008
Message 5 of 6 (1,968 Views)

Re: AutoCAD LT How to stop drawings from opening in separate windows using Windo

01-13-2012 08:28 AM in reply to: pendean

Yes, that would be painful. Thanks for the suggestion.

*Expert Elite*
pendean
Posts: 23,722
Registered: ‎11-06-2003
Message 6 of 6 (1,966 Views)

Re: AutoCAD LT How to stop drawings from opening in separate windows using Windo

01-13-2012 08:54 AM in reply to: katie1994

Just an FYI, I truly dislike the Viewer for all teh ahssle it creates for those of us still using AutoCAD on the same PCs.

Autodesk's naive assumption that only non-AutoCAD users would ever download and use the tool is very surprising for just a forward thinking tech company.

 

I wonder if Uncle Carl is aware of these little end-user annoyances that don't ever go away... .

Dean Saadallah Blog | Facebook | Google+ | Twitter | PINS
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.