AutoCAD Land Desktop

AutoCAD Land Desktop

Posts: 18
Registered: ‎06-10-2003
Message 11 of 17 (2,333 Views)

Re: LDD 2006 errors running on Win 7 64

08-25-2011 06:07 AM in reply to: gvildys

I think you just solved my issue but cannot test it yet.  I forgot all about the path variable!!!!!  I did not check it, so when the Laptop user comes back into the office I will make the edit to C:\program files (x86)\..........  if its not there.


We shall see.   


I do not believe its a .net issue.  I have the latest installed (Ver. 4) along with a force install of 1.1 and its service pack.   That was a whole other issue that drove me nuts also until someone also helped create a .msi file to do the install of .net 1.1 and its service pack.   


This is a new laptop and this is the first install of AutoCad so there should be no ref. to any past product anywhere..... I hope.


We did install the DWG Trueview 2012 on the Laptop and it works great for down converting drawings..... most of the time.... some point data goes away on some down conversions.... but can live with it.  


By the way, its a Asus G74sx and is it fast!!! It outruns most of our desktops!  


Really appreciate this help..   Hope I can return the favor someday.

Posts: 18
Registered: ‎06-10-2003
Message 12 of 17 (2,326 Views)

Re: LDD 2006 errors running on Win 7 64

08-25-2011 10:01 AM in reply to: briggleman

Well unfortunatly it was already pathed correctly under environmental variables.  So that is not the answer.  Frack!!!

Active Member
Posts: 6
Registered: ‎04-16-2003
Message 13 of 17 (2,321 Views)

Re: LDD 2006 errors running on Win 7 64

08-25-2011 10:25 AM in reply to: briggleman

You checked the SDSK.DFM file for correct pathing as well?? and the backslash was removed at the end of the C:\Program Files (x86)\Common Files\Autodesk Shared   in the PATH variable?

Posts: 18
Registered: ‎06-10-2003
Message 14 of 17 (2,312 Views)

Re: LDD 2006 errors running on Win 7 64

08-25-2011 11:52 AM in reply to: gvildys

Yes, the backslash was there, so I removed it..... Reboot, No change


By the way, thanks for the follow up on the backslash, I forgot about that part!


Checked the SDSK.dfm file and all pathing seemed correct.... in other words, I did not see any ref. to older versions and all ref. to C:\Users.......  Instead of C:\Documents and Settings\.......seemed correct.


Same two errors and no LDD commands will work.  Regular AutoCAD does work.


I do not know if this matters but the laptop borrows a lic. from the network to run while it is away from the office.


Our XP laptops are the same, no issues there.

Posts: 18
Registered: ‎06-10-2003
Message 15 of 17 (2,296 Views)

Re: LDD 2006 errors running on Win 7 64

08-26-2011 08:00 AM in reply to: briggleman



Really want to follow up on this so everyone does not go through what I have.




Installed AutoCAD LDD 2006, Civil 2006, Survey and Raster on Aug 1st.  You do the install with admin rights with a user that has admin rights.  We had the initial following errors but Autocad ran and LDD worked::


C:\Program Files (x86)\Autodesk Land Desktop 2007\AcMapWorkspace.arx cannot
find a dll or other file that it needs.
AcMapWorkspace.arx Load Failed
C:\Program Files (x86)\Autodesk Land Desktop 2007\AecCMapCogoCmds50.arx cannot
find a dll or other file that it needs.
AutoCAD Express Tools Copyright © 2002-2004 Autodesk, Inc.
AutoCAD menu utilities loaded.
AutoCAD menu utilities loaded.
C:\Program Files (x86)\Autodesk Land Desktop 2007\aeccapp50.arx cannot find a
dll or other file that it needs.
; error: ARXLOAD failed


I revised file support tab in autocad options to point to directories on the laptop for its stand alone operation and all is well.


CadUser goes to County for first day of contract, he is handed a 2009 drawing and attempts to open it up and bam... computer freezes, locks up, and he has to reboot. (I WAS NEVER TOLD THIS UNTIL TODAY).  They down convert the drawings and load them on the laptop.


So after this point, AutoCad still works but LDD commands no longer function.  No dialog box to get assigned to a project  and in addition to the errors before we now get the following.


C:\ADSK2006\LDT\Land\AecCmapCogoCmds46.arx is an invalid Arx file.
C:\ADSK2006\LDT\Land\Aeccapp46.arx is an invalid Arx file.

I start my research, internet forums and find this one.  I discover the file support tab under options in autocad points to "C:\program files....." instead of "C:\program files (x86)...."  I fix this and the intial errors go away but I am left with the red ones above. 


I found other solutions about net 1.1 needed to be installed and directx90c.  Did both of those, made sure Autocad pointed to the net 1.1..... still no luck.


gvildys suggested I check the pathing in enviromental variables... it was OK except for a / which I removed... still no luck


gvidys then suggested I review the SDSK.dfm file and it did have a lot of ref. to directories not supported in Windows 7 so I corrected those... Most pointed to "Documents and Settings" when it should have been pointing to "users"


(By the way gvildys... I was doing most of the work through a third party's eyes and I made him look at certain lines and at that time those lines were correct in the SDSK.dfm file.... certain lines, not all. So in person, today I have inspected them and discovered the other lines that were incorrect and fixed them)


OK, now time for system restore.... So I did this and took it back to the time when it worked........ and just like before ...IT WORKS.    I reset up all of the previous calls in the support file directories including the fixes to point to the correct Program Files directory, fixed the SDSK.dfm file.  IT WORKS.


So AutoDesk  Land Development Desktop 2006 will work.... in my case I did not need Directx90c nor an install of net 1.1


I am so happy now.    Thanks for everyones input on this.... Thank Gvildys..... appreciate the support and effort.  It is difficult to diagonose these issues over the net...... love the support forums.



New Member
Posts: 2
Registered: ‎11-18-2011
Message 16 of 17 (2,136 Views)

Re: LDD 2006 errors running on Win 7 64

07-15-2012 09:43 AM in reply to: gvildys

I got LDD2007 to work by making the appropriate changes to the SDSK file AND installing DirectX as described above. Then I installed Service Pack 2A and now get a fatal error upon trying to run LDD....go figure.

New Member
Posts: 1
Registered: ‎03-07-2013
Message 17 of 17 (1,104 Views)

Re: LDD 2006 errors running on Win 7 64

04-24-2013 01:38 PM in reply to: pasayten

We had to have our IT guys install a dual boot system with windows 7 and windows xp on our new computers to run LDD2007 with full funtionality.  Its a bit of a pain in the **** because now I have to restart the computer to choose xp or windows7 operating system.  When running civil3d2013 I use windows7 and when running LDD2007 i use windows xp.


Hope this helps.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.