AutoCAD Electrical General Discussion

AutoCAD Electrical General Discussion

New Member
Posts: 1
Registered: ‎04-27-2008
Message 1 of 11 (2,906 Views)
Accepted Solution

Error: malformed string on input

2906 Views, 10 Replies
08-19-2011 01:09 PM

I am receiving this error in release 2012 and it is causing two issues but I don’t know if they are related. The first issue is when I open AutoCAD Electrical there is no project list. Any projects I had opened from the previous session are no longer there. I also receive the error when I try to access any command from my ribbons. I have checked to see if the lastproj.fil exists and it does. I am using windows 7 as the operating system. Any suggestions?

Posts: 440
Registered: ‎04-13-2010
Message 2 of 11 (2,892 Views)

Re: Error: malformed string on input

08-21-2011 06:45 PM in reply to: GregFisher

Hi GregFisher,


Firstly thanks for your report. and we need more information about this error to investigate, for example, does it have reproducible steps ? when does this error throws ? after do some special operations or during Autocad Electrical initialize ?


For the first issue, can you open demo projects manually ? For the second issue, can you try to call command MENU in command line and reload acade.cuix file then check if this error still exists or not ?  From your obversation i suppose there is error during Autocad Electrical initialization, maybe some files are not loaded, so you can also reboot your machine and relauch Autocad Electrical for double check. Another suggestion is you can repair Autocad Electrical via Control Panel > Select Autocad Electrical 2012 > Uninstall > Repair or Reinstall > click Repair button .


Hope it can helps a bit !



Kevin Li

SQA Engineer

Autodesk, Inc.

Kevin-Hongyuan Li
Quality Assurance Team
Autodesk, Inc.
Posts: 14
Registered: ‎12-21-2009
Message 3 of 11 (2,728 Views)

Re: Error: malformed string on input

02-22-2012 06:53 AM in reply to: GregFisher

I don't recall "malformed string on input error", but I have the same problem with the Projects list being empty.

This never happened on 2010 or 2011. Just ACADE 2012. Repairing WILL NOT WORK! You have to completely remove

all AutoDesk products -Including manually wiping all references from the registry- Delete directories. Everything.

Then reinstall. (plan on several hours).

After reinstalling, you will find out, like I did, that the error (empty projects list) will return.

*Expert Elite*
Posts: 910
Registered: ‎09-21-2007
Message 4 of 11 (2,698 Views)

Re: Error: malformed string on input

02-28-2012 05:53 AM in reply to: GregFisher



Just wanted to say that I had the same problem last week.

My computer crashed while working in AcadE, and after a reboot AcadE just wouldn't work. Tried both repair and reinstall without luck.

I hade to do an actual uninstall/install to get it to work again.



Please select "Accept As Solution" if this post answers your question. Kudos don't hurt either. ;-)
Posts: 13
Registered: ‎08-01-2011
Message 5 of 11 (2,489 Views)

Re: Error: malformed string on input

08-16-2012 09:44 AM in reply to: rhesusminus

Had this same issue.  Deleted all text from lastproj.fil (in user folder).  Then it worked.  You will have to re-open all of your projects that you had open.

Posts: 18
Registered: ‎09-07-2012
Message 6 of 11 (2,388 Views)

Re: Error: malformed string on input

09-17-2012 06:47 AM in reply to: GregFisher

Did anyone else find any other solution? This is happening to me after I installed RSLogix5000. I can't find the lastproj.fil file. I did a search. 

New Member
Posts: 2
Registered: ‎01-24-2012
Message 7 of 11 (2,268 Views)

Re: Error: malformed string on input

11-06-2012 04:10 PM in reply to: GregFisher

This started for me yesterday with ACADE 2013 SP1. I cannot use any commands from the ribbon, and I am in the middle of a project scheduled for delivery to the client this week. I have some last minute additions and changes to wiring diagrams, and it is making things difficult. Tried to do a repair to ACADE but the problem still exists. I have been using the software for several months without problems.

Active Member
Posts: 8
Registered: ‎02-17-2010
Message 8 of 11 (2,014 Views)

Re: Error: malformed string on input

01-07-2013 01:50 PM in reply to: GregFisher

I am using ACADE 2013. I had a similar issue and was wondering if there has been any solution since the thread just ends. If I attempt to use any tools from the toolbar I receive the error malformed string on input. My project list was blanked but I can open projects and re-populate. I have re-started the program and the computer. I haven't gone any farther since none of the other replies give a solid solution. Any help would be greatly appreciated. Going to try the repair program option.

Valued Contributor
Posts: 97
Registered: ‎07-12-2012
Message 9 of 11 (2,008 Views)

Re: Error: malformed string on input

01-07-2013 05:22 PM in reply to: oharadi

Have you try to reset your <<ACADE>> profile in the options? Just remember to backup your existing profile in case.

Then type CUILOAD to see if your ELECTRICAL is loaded.

IF not then browse to "acade.cuix" and load it again.

Active Member
Posts: 8
Registered: ‎02-17-2010
Message 10 of 11 (1,989 Views)

Re: Error: malformed string on input

01-08-2013 06:00 AM in reply to: lionSG

Thanks for the quick reply. Last night i deleted my lastproj.fil and restarted the system. My projects list still needed to be re-populated but the error generated when using the toolbars was fixed.

Manufacturing Community
The Manufacturing Community provides additional access to tips, tutorials, blogs and networking with peers.
Need installation help?

Start with some of our most frequented solutions to get help installing your software.

New AutoCAD Electrical Category!

The AutoCAD Electrical forum has moved into it's very own category page, and can no longer be found within the Additional Product Forums.