AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
Valued Contributor
RPeter
Posts: 88
Registered: ‎01-09-2009
Message 1 of 13 (515 Views)
Accepted Solution

True-Color in surface analyses problem

515 Views, 12 Replies
06-17-2013 03:31 AM

At the moment we're testing the Civil3D 2014 version.

We have a lot of analysis with true-colors.

When we plot a layout where we can see the analysis the plot is not correct.

In the CTB file all colors are set to black, in the 2013 version the RGB/True-Color overruled the CTB file and plotted in color.

Now the same drawings plot black. How can I solve this issue?

It has been solved for Civil 2014 with SP1.

 

Regards

 

Peter

*Expert Elite*
Alfred.NESWADBA
Posts: 9,071
Registered: ‎06-29-2007
Message 2 of 13 (512 Views)

Re: True-Color in surface analyses problem

06-17-2013 03:40 AM in reply to: RPeter

Hi,

 

>> in the 2013 version the RGB/True-Color overruled the CTB file and plotted in color.

That has not changed in 2014, objects displayed in true-color aren't converted by CTB or STB.

Do you have an example that you can upload?

 

And just to make sure: you have not assigned color-index values as display-color(s) for the result of your analysis?

 

At least one test to know that you are not depending on any driver: do you also get black/white/greyscale results when you plot to PDF or DWF?

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Valued Contributor
RPeter
Posts: 88
Registered: ‎01-09-2009
Message 3 of 13 (508 Views)

Re: True-Color in surface analyses problem

06-17-2013 03:51 AM in reply to: Alfred.NESWADBA

I've made an Etransmit from a sample drawing.

Regards

 

Peter

*Expert Elite*
Alfred.NESWADBA
Posts: 9,071
Registered: ‎06-29-2007
Message 4 of 13 (505 Views)

Re: True-Color in surface analyses problem

06-17-2013 03:54 AM in reply to: RPeter

Hi,

 

>> I've made an Etransmit from a sample drawing.

Should this sample drawing be attached here? Just as info, it is not :smileywink:

May be the filesize exceeds 1.5MB? This is the limit for uploadable files here. In that case you might upload it to any free upload servers in the www and let us know the link where to find it.

 

[EDIT]: sorry, your edit and my post crossed :smileywink: [/EDIT]

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
*Expert Elite*
Alfred.NESWADBA
Posts: 9,071
Registered: ‎06-29-2007
Message 5 of 13 (496 Views)

Re: True-Color in surface analyses problem

06-17-2013 04:21 AM in reply to: RPeter

Hi,

 

well, if I open your drawing in 2013 it looks equal to if I open it in 2014, no difference. Some blue and some green colors are displayed in black (in 2013 and in 2014). That's surprising for me now after verifying that in the analysation tab the colors are all selected as true color values. Even more surprising is: when I exploded the surface the display changed from some areas black to the truecolor values (as estimated). So at least that might be a workaround for the moment (but a bad workaround too as you will have to explode the surface every time before plotting and then don't save the drawing in that state).

 

I'm still playing now with your drawing, that's just a first info, maybe someone else also has some ideas of how to get it really back to true-color, but it was also the first time I saw that for 2013.

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
*Expert Elite*
Alfred.NESWADBA
Posts: 9,071
Registered: ‎06-29-2007
Message 6 of 13 (491 Views)

Re: True-Color in surface analyses problem

06-17-2013 04:42 AM in reply to: RPeter

Hi,

 

one option might also be to set the visual style for this viewport to "wireframe" (instead of 2D-wireframe).

At the moment I'm lost of more ideas, I tried another CTB, other colors for the analyses-thematic in the surface-properties, currently I test on a surface that I exported from your drawing (using Land-XML), imported it into a new drawing (in 2014) and even don't get the elevation analyses working (all elevations are painted in the color of the last line in the thematic-ranges when using 2D-solids), strange .... ;(

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Valued Contributor
RPeter
Posts: 88
Registered: ‎01-09-2009
Message 7 of 13 (486 Views)

Re: True-Color in surface analyses problem

06-17-2013 04:53 AM in reply to: Alfred.NESWADBA

Alfred,

 

Wireframe is not an option.

 

In 2013 we know it will display black areas but will plot in true-color as told in the analysis.

In 2014 it stays black, exploding the surface is not done.

 

I hope someone finds a good work-arround or solution.

 

Regards

 

Peter

 

 

 

*Expert Elite*
Alfred.NESWADBA
Posts: 9,071
Registered: ‎06-29-2007
Message 8 of 13 (483 Views)

Re: True-Color in surface analyses problem

06-17-2013 05:04 AM in reply to: RPeter

Hi,

 

>> In 2013 we know it will display black areas but will plot in true-color as told in the analysis.

>>In 2014 it stays black, exploding the surface is not done.

Yep, you are very right, I only looked to the layout (having activated the "display plot styles"-option in the pagesetup-dialog) and there was no difference. With plot-preview or even really plotting to PDF ==> yep, there is the difference.

 

The more I guess why I have not seen that yet ... I'm never using CTB or STB for my projects and so that (bug) is really new to me.

 

Sorry to have no solution (at the moment), - alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------
Valued Contributor
RPeter
Posts: 88
Registered: ‎01-09-2009
Message 9 of 13 (482 Views)

Re: True-Color in surface analyses problem

06-17-2013 05:07 AM in reply to: Alfred.NESWADBA

Alfred,

 

Its good to hear you can simulate the same problem, so its not an installation issue.

No problem that you haven't got a solution, I'm already happy that you're trying to help.

 

I hope Autodesk can solve the issue someway....

 

We'll keep searching for a solution, if found some I'll post it over here.

 

Regards

 

Peter

New Member
ClaudiaL23
Posts: 2
Registered: ‎01-27-2014
Message 10 of 13 (279 Views)

Re: True-Color in surface analyses problem

01-27-2014 02:23 AM in reply to: RPeter

Someone found a solution for this problem?

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.