AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
Active Contributor
aluko0719
Posts: 41
Registered: ‎03-15-2011
Message 1 of 3 (1,217 Views)
Accepted Solution

There is a problem with the Script Control (msscript.ocx).

1217 Views, 2 Replies
12-13-2012 04:46 AM

i'm using civil 3d 2013 and when i try to make pipes i get the following error message "This problem may be corrected by reinstalling Internet Explorer or by reregistering the control.There is a problem with the Script Control (msscript.ocx)." this error only happens with pipes i can make structures, i can also make pipes with a pressure network. i have tried uninstalling internet explorer and unistallling civil 3d, but that did not work. i have also tried

  • Install the script control: http://support.microsoft.com/kb/184739    
  • The version of Internet Explorer (IE) 7, IE8, and IE9 may be preventing it from operating, you could try to uninstall it and reinstall it.
  • Try these steps:

1. Go to Start All Programs Accessories.

2. Right-click Command Prompt and choose "Run as administrator."

3. Enter the command:

Regsvr32 C:\Windows\SysWOW64\msscript.ocx

You can copy and paste this by right-clicking in the command prompt window to do the paste.

4. Click OK on the message that says the file registration succeeded.

5. On the keyboard, hold down the WINDOWS key and then hit R.

6. In the Run window, type REGEDIT and then click OK.

7. Find the following folder:

HKEY_CLASSES_ROOT\TypeLib\(0E59F1D2-1FBE-11D0-8FF2-00A0D10038BC)\1.0\0\win32

8. Right-click the win32 folder and choose "Permissions."

9. Make sure the administrator group has full control.

10. With the win32 folder selected, make sure the (Default) key at the right is set to the following path with no quotes around it: C:\Windows\SysWOW64\msscript.ocx

11. Close the Registry Editor.

 

but that did not work. can somebody give me some other ideas

 

thanks

*Expert Elite*
tcorey
Posts: 2,557
Registered: ‎12-18-2002
Message 2 of 3 (1,155 Views)

Re: There is a problem with the Script Control (msscript.ocx).

02-08-2013 03:29 PM in reply to: aluko0719

I know this thread is a little stale, but I had this error today and found a solution buried in another post.

 

http://forums.autodesk.com/t5/AutoCAD-MEP/msscript-ocx-AutoCAD-MEP-2012/td-p/3574092

 

Search for the entry at 04-08-2011 01:46 PM in reply to:jdaulton, by Joshua Benoist of Autodesk.Extract those files as he says, and be sure to import the .txt file into your registry.

 

I had tried all the things on the list posted by the OP of this thread. I finally read down far enough in the other post to see Joshua's good news. I was about to pull out my last three hairs.

 

Tim

 

Tim Corey, Owner
Delta Engineering Systems
Redding, CA
Autodesk Authorized Value-Added Reseller
Distinguished Mentor
andrewpuller3811
Posts: 770
Registered: ‎07-30-2008
Message 3 of 3 (1,086 Views)

Re: There is a problem with the Script Control (msscript.ocx).

04-28-2013 05:17 PM in reply to: tcorey
Thanks for posting that Tim. I just had this issue come up and your post help me solve the issue.
If this fixed your issue, click on "Accept as Solution"

Andrew Puller
Maitland, NSW, Australia
Windows 7 Enterprise 64bit
Intel core i7 2600 @ 3.40 GHz with 16GB Ram
Civil 3d 2013 64bit
Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.