AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
Active Contributor
javbarcelo
Posts: 39
Registered: ‎08-22-2012
Message 1 of 7 (2,663 Views)
Accepted Solution

Slope Pattern Style Issue

2663 Views, 6 Replies
08-22-2012 09:10 PM

Hi there,

 

I am having difficulties setting up a slope pattern to my company's standards. I would like it to look as a triangle on the top of the slope, then a line from the triangle, all the way to the edge of the batter. Please see image (01) attached. Unfortunately, the AutoCAD block masks the line so there's a gap between the line and the tip of the triangle. Please see image (01) attached. Does any one know why the block masks the line and how to prevent this? The block doesn't have any wipeout or anything like that in the background. I also attached an image (02) showing the configuration of my Slope Pattern Style, if that's of any help. I know that, setting up the block as percent of lenght, will fix this problem, but then the block will vary in size, which is not our standard. Tricky...

 

Also, for some reason, when I export to AutoCAD, the triangles get removed which make things even more frustrating. But this only happens if the feature line varies direction along its length, It won't happen on a straight one. Please see attached image (03). Have anybody experienced something similar when exporting to AutoCAD?

 

I am on Civil 3D 2011, Windows XP 64bits.

 

Thanks

Try changing your Symbol type from Autocad Block to Filled Triangle.

 

If that does not help, post a drawing file with the problem style in it.

 

Also in future, post the version you are using, as things like this can vary from version to version.

Active Contributor
javbarcelo
Posts: 39
Registered: ‎08-22-2012
Message 2 of 7 (2,563 Views)

Re: Slope Pattern Style Issue

10-03-2012 09:56 PM in reply to: javbarcelo

Hi there,

 

I was wondering if anybody can find a soultion for this issue. Please see first post for a full descrition.

 

Cheers

 

Javier

Distinguished Mentor
andrewpuller3811
Posts: 793
Registered: ‎07-30-2008
Message 3 of 7 (2,514 Views)

Re: Slope Pattern Style Issue

10-05-2012 04:40 AM in reply to: javbarcelo

Try changing your Symbol type from Autocad Block to Filled Triangle.

 

If that does not help, post a drawing file with the problem style in it.

 

Also in future, post the version you are using, as things like this can vary from version to version.

If this fixed your issue, click on "Accept as Solution"

Andrew Puller
Maitland, NSW, Australia
Windows 7 Enterprise 64bit
Intel core i7 2600 @ 3.40 GHz with 16GB Ram
Civil 3d 2013 64bit
Active Contributor
javbarcelo
Posts: 39
Registered: ‎08-22-2012
Message 4 of 7 (2,454 Views)

Re: Slope Pattern Style Issue

10-07-2012 03:09 PM in reply to: andrewpuller3811

Andrew,

 

Thank you for your reply. Using the Filled Triangle block works fine in Civil 3D but not when exporting to AutoCAD. The bottom line: we should stop exporting to AutoCAD. Now go and convince the other designers in my office to try harder instead of botched one and rely on the drafties to fix things by hand, (sigh). I should've tried that block before, but I didn't because the preview doesn't display it properly, as per image below

 

untitled.JPG

 

Anyway, thanks for that again.

Have a good one.

 

Javier

 

BTW, in the original post, I stated what C3D version I use.

Active Member
riaangroen
Posts: 8
Registered: ‎10-04-2012
Message 5 of 7 (2,433 Views)

Re: Slope Pattern Style Issue

10-07-2012 06:59 PM in reply to: javbarcelo

Hi Andrew

Hope you got a solution to the problem, maybe you can help me with something.

The slope patterns, are they only available for grading or can you use them for corridors as well, and set them as a surface style?

and how do you change the triangles or shapes in the pattern style window? Not sure how it works.

Cheers mate

Riaan

Active Contributor
javbarcelo
Posts: 39
Registered: ‎08-22-2012
Message 6 of 7 (2,430 Views)

Re: Slope Pattern Style Issue

10-07-2012 07:36 PM in reply to: riaangroen

Riaan,

 

Slope pattern styles can be found in Toolspace/Settings Tab/General/Multipurpose Styles

 

untitled.JPG

 

There, you can play around with the pattern you'd like to display.

 

As far as I know, you can't use them for surfaces.

 

Yes, you can use them in corridors. Once you've created your corridor you can add a slope pattern between the feature lines you select.

 

untitled2.JPG

 

Hope that helps.

 

Cheers

 

Javier

Active Member
riaangroen
Posts: 8
Registered: ‎10-04-2012
Message 7 of 7 (2,424 Views)

Re: Slope Pattern Style Issue

10-07-2012 08:30 PM in reply to: javbarcelo

Thanks Javier

I found it. If you do find a way to display them on the surface it would be great. I usually have 2m-5m or 5m-10m contours - and if i can add the slope marker the client would be very happy.

Thanks for the help so far.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.