AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
Contributor
ssaigeon
Posts: 13
Registered: ‎12-18-2012
Message 11 of 32 (478 Views)

Re: Sag and Crest profile labels keep disappearing

01-16-2013 07:36 AM in reply to: swatfor

Unfortunately the only thing that works for me is to lock the layer that the labels are on before saving and closing the drawing.  It will keep them how you have set them.  It's annoying but it works.

*Expert Elite*
LisaPohlmeyer
Posts: 563
Registered: ‎01-14-2009
Message 12 of 32 (466 Views)

Re: Sag and Crest profile labels keep disappearing

01-16-2013 09:45 AM in reply to: ssaigeon

Well, since you couldn't post the dwg, I created my own in 2013, SP1.  All profile labels work for me, and stay upon reopening the drawing.  Not sure what might be causing your issue.  I'd suggest submitting a case to Adesk.

Lisa Pohlmeyer

C3D 2012 SP4, C3D 2015
Please use "Accept as Solution" if this solved your issue.
Distinguished Contributor
swatfor
Posts: 139
Registered: ‎10-10-2003
Message 13 of 32 (460 Views)

Re: Sag and Crest profile labels keep disappearing

01-16-2013 10:50 AM in reply to: LisaPohlmeyer

Lisa,

I did not create this original discussion but I have the same problem with all of my dwgs on every machine.  It may have something to do with shortcuts.  I tried to save a dwg to send, but when I promoted all my references, the problem went away. 

 

Therefore, I'm attaching the problem dwg to this post and the referenced shortcut dwg in the next.  If you have time please check out the attach dwgs.  I'll attach the actual shortcut files in another post if necessary

Thanks,

Sandy W.

Sandy W.
Distinguished Contributor
swatfor
Posts: 139
Registered: ‎10-10-2003
Message 14 of 32 (459 Views)

Re: Sag and Crest profile labels keep disappearing

01-16-2013 10:52 AM in reply to: LisaPohlmeyer

Lisa,

Here's the referenced shortcut dwg and shortcut files - alignment & surface, respectively.

Thanks,

Sandy W.

Sandy W.
Distinguished Contributor
swatfor
Posts: 139
Registered: ‎10-10-2003
Message 15 of 32 (455 Views)

Re: Sag and Crest profile labels keep disappearing

01-16-2013 10:56 AM in reply to: ssaigeon

Thanks... that's what I will do. In addition, I've found that if you go into the profile properties and change the name slightly (add or take away a character) and apply, the labels reappear with customizations intact... weird

Sandy W.
*Expert Elite*
LisaPohlmeyer
Posts: 563
Registered: ‎01-14-2009
Message 16 of 32 (449 Views)

Re: Sag and Crest profile labels keep disappearing

01-16-2013 12:15 PM in reply to: ssaigeon

Sandy,

Post a screen shot of the profile label set that you'd use for this profile.

Lisa Pohlmeyer

C3D 2012 SP4, C3D 2015
Please use "Accept as Solution" if this solved your issue.
Distinguished Contributor
swatfor
Posts: 139
Registered: ‎10-10-2003
Message 17 of 32 (443 Views)

Re: Sag and Crest profile labels keep disappearing

01-16-2013 12:31 PM in reply to: LisaPohlmeyer

The labels are customized versions of what comes with Civ 3d.  The screenshot is attached.

Thanks for your help.

Sandy W.
*Expert Elite*
LisaPohlmeyer
Posts: 563
Registered: ‎01-14-2009
Message 18 of 32 (439 Views)

Re: Sag and Crest profile labels keep disappearing

01-16-2013 12:40 PM in reply to: swatfor

Sandy

Ok, not sure what to tell you.  I can replicate it with your drawing and the Drefs.  But... when I create a drawing with my data Dreffed into a file, label it, close, reopen, the labels are still there.  I've attached a dwt (in progres) that you can use to test your data.  When I did a -purge and removed the registered applications, there were 55, some I wasn't familiar with, but didn't seem to resolve the issue.

Since this system won't allow dwt files, I changed the extension to dwg.

Lisa Pohlmeyer

C3D 2012 SP4, C3D 2015
Please use "Accept as Solution" if this solved your issue.
Distinguished Contributor
swatfor
Posts: 139
Registered: ‎10-10-2003
Message 19 of 32 (435 Views)

Re: Sag and Crest profile labels keep disappearing

01-16-2013 12:47 PM in reply to: LisaPohlmeyer

OK... I'll give it a try - thanks

Sandy W.
*Expert Elite*
klugb
Posts: 693
Registered: ‎09-04-2008
Message 20 of 32 (415 Views)

Re: Sag and Crest profile labels keep disappearing

01-16-2013 07:47 PM in reply to: ssaigeon

Probably not the answer you were looking for but I was playing around with your drawings & data and can recreate several scenarios.

 

First, I get the same results as you when starting, with the labels disappearing.

If you synchronize the alignment the labels come back (not realistic workaround in a production environment).

It appears (IMHO) it's a timing issue where the profile view is created and labeled before it gets done synchronizing the data shortcut info.

We don't have our alignments and profiles in separate drawings, that's why we don't have this problem.  I took and put them together in one drawing and DS them out to another drawing (based on your files) and they label and update correctly. Not that it helps because it might change your workflow until Autodesk fixes this but it might help shed some light on the problem.

 

 

 

Bruce Klug
AutoCAD Expert Elite
AutoCAD Civil 3D 2014 Certified Professional
Infrastructure Design Suite 2014 (SP2)
Testing Civil 3D 2015
Win 7 Pro, 64-bit
Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.