AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
Distinguished Contributor
afdelarosa
Posts: 160
Registered: ‎09-23-2004
Message 21 of 29 (351 Views)

Re: PNEZD file import issue.

04-20-2012 02:09 PM in reply to: Jeff_M

Something similar to that was tried, but it came with the same error.

My descriptions are not importing still.

Valued Mentor
IanMcClain
Posts: 469
Registered: ‎09-29-2008
Message 22 of 29 (350 Views)

Re: PNEZD file import issue.

04-20-2012 02:10 PM in reply to: afdelarosa

Can you attach the file?

-Ian McClain
(running C3D 2012 sp4, Win7 64bit, 8GB)
Distinguished Contributor
afdelarosa
Posts: 160
Registered: ‎09-23-2004
Message 23 of 29 (346 Views)

Re: PNEZD file import issue.

04-20-2012 02:19 PM in reply to: IanMcClain

Which file? I had posted images of the .txt file and the import settings.

Thanks.

*Expert Elite*
Jeff_M
Posts: 4,519
Registered: ‎07-22-2003
Message 24 of 29 (345 Views)

Re: PNEZD file import issue.

04-20-2012 02:20 PM in reply to: afdelarosa

OK, then as Ian and someone else has asked, if you could post the file (or at least the first 10 lines of it) I'm sure someone could figure this out. And by 'the file', that means the actual text file, not an image of it.

Jeff_M, also a frequent Swamper
Distinguished Contributor
afdelarosa
Posts: 160
Registered: ‎09-23-2004
Message 25 of 29 (341 Views)

Re: PNEZD file import issue.

04-20-2012 02:43 PM in reply to: Jeff_M
 
*Expert Elite*
Jeff_M
Posts: 4,519
Registered: ‎07-22-2003
Message 26 of 29 (335 Views)

Re: PNEZD file import issue.

04-20-2012 02:51 PM in reply to: afdelarosa

OK, I just used the exact procedure I described before and the points come in fine. If you are keeping the elevation column in the point file format style, then both the original and your new will fail because the values are not numbers. By choosing the <not used> type for the elevation column it ignores these values. This is the file you just posted imported using doing just this.

 

4-20-2012 2-47-08 PM.png

Jeff_M, also a frequent Swamper
Valued Mentor
IanMcClain
Posts: 469
Registered: ‎09-29-2008
Message 27 of 29 (326 Views)

Re: PNEZD file import issue.

04-20-2012 03:01 PM in reply to: afdelarosa

Ok, just remove the quotes. When I said do a find and replace "<null>" with "0", I meant replace/use what was between the quotes.

 

Just for future refrence, when importing point files C3D doesn't like special characters. For instance if you had a description like TREE 10" OAK it would be truncated to TREE 10. For some reasone quotation marks end a description or in your case, skip the field entirely.

-Ian McClain
(running C3D 2012 sp4, Win7 64bit, 8GB)
Distinguished Contributor
afdelarosa
Posts: 160
Registered: ‎09-23-2004
Message 28 of 29 (307 Views)

Re: PNEZD file import issue.

04-23-2012 07:03 AM in reply to: IanMcClain

Good morning,

And thank you for responding. I replaced the "0" for 0 and the descriptions came in. So, if my point file has the " or any other special character in any field, it will void some of the fields?

My description column didn't have special characters.

Thanks!

Valued Mentor
IanMcClain
Posts: 469
Registered: ‎09-29-2008
Message 29 of 29 (304 Views)

Re: PNEZD file import issue.

04-23-2012 07:16 AM in reply to: afdelarosa

You had two " characters, one before and one after the 0. The first one truncated the elevation field, and the second truncated the description field. I don't know why those symbols do that, but they have always done it since I have been using autodesk software. It probably served some purpose in earlier versions.

-Ian McClain
(running C3D 2012 sp4, Win7 64bit, 8GB)
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.