AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
Distinguished Contributor
diegoal
Posts: 103
Registered: ‎03-05-2010
Message 1 of 4 (994 Views)

Navisworks 2013 fatal error

994 Views, 3 Replies
04-21-2012 07:06 AM

Hello all,

 

I can't append C3D 2013 files on Navisworks. Firstly I was able to append the file but I couldn't "see" C3D objects then I found here that I should install  C3D 2013 Object Enabler on Navisworks... now, after this installation (that should be mandatory when install Navis on Infraestructure modeller), the window freezes on "loading" and, sometimes, I get the fatal error msg: Unable to load file 'AcTcUiRes.dll'.

 

I already reisnstalled Navis and Object Enabler with no results... Do you guys would know what should be done?

 

Thanks a lot,

Diego Álvares
Civil Engineer - www.trentoengenharia.com.br
Autocad Civil 3D 2013 / 2014 / 2015 - Infrastructure Design Suite
Windows 7 64 i7 4770 @3.40GHz 8GB Ram GeForce GT 630
Active Contributor
keithw
Posts: 34
Registered: ‎08-24-2001
Message 2 of 4 (961 Views)

Re: Navisworks 2013 fatal error

04-25-2012 05:13 PM in reply to: diegoal

We were able to open our files until we loaded the Object Enabler after that DLL error one right after anther. Looks like a BUG in the patch.

 

KW

Distinguished Contributor
diegoal
Posts: 103
Registered: ‎03-05-2010
Message 3 of 4 (950 Views)

Re: Navisworks 2013 fatal error

04-26-2012 09:56 AM in reply to: keithw

Hello KW,

 

Yes it seems a BUG... I've writed to Autodesk and they sent me some instructions:

 

"Dear Diego,

 

I was able to reproduce the issue after installing Civil 3D 2013, the Civil object enabler, and Navisworks 2013 on a test machine.
I found another workaround in that if you turn off AutoCAD and Civil 3D properties in DWG reader, the error no longer occurs when opening your DWG.  

Please try the following :  
1. Delete the NWC file that was created upon opening the DWG in Navisworks 2013.
2. Open Navisworks 2013
3. Click Application Button > Options and expand File Readers > DWG
4. Click the Advance button in the bottom of the list of options
5. Unmark the AutoCAD and Civil3D boxes
NOTE:  Leaving AutoCAD marked will result in the 4 error windows and a freeze.  Unmarking and leaving Civil3D results in the application hanging at 2% while loading the file in my test.
6. Click OK and open the Civil 3D DWG file.

 

This first try didn't worked for me...

The side effect is that the AutoCAD and Civil 3D properties are then not able to covert and be used in Navisworks.   Therefore the best workaround would be to export directly from Civil 3D using the NWCOUT command.  If you installed Civil 3D after Navisworks, then this command may not be recognized.  If that is the case:

1. Open Control Panel > Programs
2. Open Autodesk Navisworks 2013 64-bit Export plug-ins
3. Click Add/Remove features
4. Mark the checkbox for AutoCAD 2013 and click update to install.

After loading the DWG in Civil 3D 2013, enter the command NWCOUT. This should allow you to save to an NWC file.  This also has the benefits in that it doesn’t require all users to have the enabler installed or their AutoCAD options set up the same way to view the model the way you intend.  By entering NWOPT in AutoCAD you can set the options and they will set in that NWC. 

If you are receiving these DWG files from another outside source and don’t have Civil 3D 2013 yourself, that other user can download and install the standalone exporters from the following page without having to install or license Navisworks Manage or Simulate and provide you NWC files:

http://usa.autodesk.com/adsk/servlet/pc/item?id=13947462&siteID=123112

Please give this a try and let me know if this works on your end.

I’ve documented your case with our development team so that they are aware that more users are experiencing this issue."

 

NWCOUT worked very well so I forgot to try to append Civil 3D DWGs...

 

KW, I hope it helps you too.

 

Best regards,

Diego Álvares
Civil Engineer - www.trentoengenharia.com.br
Autocad Civil 3D 2013 / 2014 / 2015 - Infrastructure Design Suite
Windows 7 64 i7 4770 @3.40GHz 8GB Ram GeForce GT 630
Member
Danny1972
Posts: 5
Registered: ‎10-23-2012
Message 4 of 4 (580 Views)

Re: Navisworks 2013 fatal error

12-18-2012 12:28 AM in reply to: diegoal

I find it very frustrating that with all the development that is taking place we are unable to open native 2013 Civil 3D files in Navisworks. Not only have I had trouble with pipework, but corridors have to be run through a corridor solids app first then exported. A real time waster!  Yes there are work arounds but this affects the workflow of the project and carrys the inherent danger of incorrect or out of date files being used.

AUTODESK can we PLEASE resolve this. 

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.