AutoCAD Civil 3D General Discussion

AutoCAD Civil 3D General Discussion

Reply
Mentor
oceanside
Posts: 390
Registered: ‎08-03-2006
Message 1 of 6 (4,413 Views)

Multileader Text Sitting On Line

4413 Views, 5 Replies
03-14-2012 09:10 AM

I have a Multileader Style and have the Mtext to come in with "Underline top line".  The text sits right where I want such as EXIST. 24 RCP but when I enter something with an inch or foot symbol such as EXIST. 24" RCP the text will end up sitting right on the leader line.  I don't see where I can set an offset for the Mtext coming in with the leader.  What can I do to make this change?

 

the best is at the beach!
Valued Mentor
gjrcmb
Posts: 326
Registered: ‎06-21-2011
Message 2 of 6 (4,401 Views)

Re: Multileader Text Sitting On Line

03-14-2012 12:25 PM in reply to: oceanside

I notice that what you are describing is somewhat dependant on the font style.  It does not seem to be an issue when using a Arial font style, but does when using a Romans font style.

 

Anyway, I am able to correct the issue (when using Romans) by viewing the Properties dialog box and then changing the "Line Space Style" to "Exactly" (see attached image).  Still looking for if there is some way to specify this setting through the MLeader Style or when creating the MText?

Mentor
oceanside
Posts: 390
Registered: ‎08-03-2006
Message 3 of 6 (4,396 Views)

Re: Multileader Text Sitting On Line

03-14-2012 12:36 PM in reply to: oceanside

Ok...I found if I do the Mtext...right click...Properties...I can change the Line Space Style to Exactly and that works.  But how do I make this change so this is the default?  I want this to be Exactly everytime I do Mtext without having to go to Properties each time to make this change.

the best is at the beach!
Valued Mentor
gjrcmb
Posts: 326
Registered: ‎06-21-2011
Message 4 of 6 (4,384 Views)

Re: Multileader Text Sitting On Line

03-14-2012 01:35 PM in reply to: oceanside

The only way I am finding to set this as a Default is to edit the MultiLeader Style to have a Default Text entry that includes a Paragraph Line Spacing of Exactly.  The downside of this is that you have to accept the default MText when placing the MultiLeader, and then edit the MText, but this allows you to keep the default text setting properties.  On the other hand maybe this will save you some typing as well, so maybe this is a good compromise solution.

So edit your MultiLeader Style, go to the Content tab, and select the ellipses button next to Default Text.  In the MText Editor, hit the Paragraph button, and the select the check box next to Paragraph Line Spacing and change Line Spacing setting to Exactly.  (Note: Incidentally it looks like you can also change the Line spacing number setting to increase the amount of space between the text and underline.)  Type in something like EXIST XX" RCP for your default text.  See images.

 

So actually it seems like you could create mutliple MultiLeader styles with different default text settings to use for different label types?


As a side note, this apparently can be handled differently for MText that is standalone as opposed to being part of a MultiLeader.  See following article:

Control Mtext Line Spacing
http://cadecorner.blogspot.com/2006/06/control-mtext-line-spacing.html

New Member
AISW_Jordan
Posts: 1
Registered: ‎12-11-2012
Message 5 of 6 (3,921 Views)

Re: Multileader Text Sitting On Line

01-02-2013 08:37 AM in reply to: oceanside

I had this same problem. I could never find any text offset for the Multileader Style Manager (like the Dimension Style Manager has). I am only using one line of MTEXT in this particular application. I had the Horizontal Attachment set to "Underline Top Line".  With this setting, my text was sitting directly on top of the leader underline, not over it.

 

MY FIX~ I set the Horizontal Attachment to "Underline Bottom Line" and it placed the text offset from the Leader underline exactly how I wanted it. Hope this helps some of your situations also.

 

Click HERE to see a screen shot of where this setting is located. It can be permanently changed in the Multileader Style Manager, OR on a case by case basis in the Properties Window.

New Member
lovebunnysarah
Posts: 1
Registered: ‎10-11-2014
Message 6 of 6 (135 Views)

Re: Multileader Text Sitting On Line

10-11-2014 05:52 AM in reply to: oceanside

im having a similar problem with my multileader line, when i use it on the left of my drawing it automatically underlines it and my control of moving it to the exact position that i desire is gone. 

can anyone help me figure out how to avoid this happening. step by step instructins would be much appreciated as i am a student and still learning. 

thanks.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.